This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-13 00:31
Elapsed3m17s
Revision
Buildergke-prow-default-pool-cf4891d4-qhc1
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/d73153d8-d0bd-4319-a7f0-812375e4f602/targets/test'}}
pode579db31-359b-11ea-9fef-d200904e1a96
resultstorehttps://source.cloud.google.com/results/invocations/d73153d8-d0bd-4319-a7f0-812375e4f602/targets/test
infra-commit5b37d6c80
job-versionv1.18.0-alpha.1.634+36e40fb8502930
pode579db31-359b-11ea-9fef-d200904e1a96
revisionv1.18.0-alpha.1.634+36e40fb8502930

Test Failures


Up 1m22s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-09 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.634+36e40fb8502930 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0113 00:31:09.625] process 47 exited with code 0 after 0.0m
I0113 00:31:09.625] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0113 00:31:09.625] Root: /workspace
I0113 00:31:09.626] cd to /workspace
I0113 00:31:09.626] Configure environment...
I0113 00:31:09.626] Call:  git show -s --format=format:%ct HEAD
W0113 00:31:09.631] fatal: not a git repository (or any of the parent directories): .git
I0113 00:31:09.631] process 60 exited with code 128 after 0.0m
W0113 00:31:09.631] Unable to print commit date for HEAD
I0113 00:31:09.632] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0113 00:31:10.142] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0113 00:31:10.469] process 61 exited with code 0 after 0.0m
I0113 00:31:10.469] Call:  gcloud config get-value account
... skipping 426 lines ...
W0113 00:33:31.176] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0113 00:33:31.177] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0113 00:33:31.177] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0113 00:33:31.177] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0113 00:33:31.178] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0113 00:33:31.178] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0113 00:34:13.277] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0113 00:34:13.317] 2020/01/13 00:34:13 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-09 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.634+36e40fb8502930 bootstrap-e2e' finished in 42.717761356s
W0113 00:34:14.843] 2020/01/13 00:34:14 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0113 00:34:19.501] 2020/01/13 00:34:19 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-09 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.634+36e40fb8502930 bootstrap-e2e: exit status 1
W0113 00:34:19.505] Traceback (most recent call last):
W0113 00:34:19.505]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0113 00:34:19.506]     main(parse_args())
W0113 00:34:19.506]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0113 00:34:19.506]     mode.start(runner_args)
W0113 00:34:19.506]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0113 00:34:19.506]     check_env(env, self.command, *args)
W0113 00:34:19.506]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0113 00:34:19.507]     subprocess.check_call(cmd, env=env)
W0113 00:34:19.507]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0113 00:34:19.507]     raise CalledProcessError(retcode, cmd)
W0113 00:34:19.508] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:StackdriverAcceleratorMonitoring\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0113 00:34:19.516] Command failed
I0113 00:34:19.516] process 268 exited with code 1 after 3.1m
E0113 00:34:19.516] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring
I0113 00:34:19.517] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0113 00:34:20.014] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0113 00:34:20.055] process 1391 exited with code 0 after 0.0m
I0113 00:34:20.055] Call:  gcloud config get-value account
I0113 00:34:20.348] process 1404 exited with code 0 after 0.0m
I0113 00:34:20.348] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0113 00:34:20.348] Upload result and artifacts...
I0113 00:34:20.349] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1216517940929630214
I0113 00:34:20.349] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1216517940929630214/artifacts
W0113 00:34:21.192] CommandException: One or more URLs matched no objects.
E0113 00:34:21.305] Command failed
I0113 00:34:21.305] process 1417 exited with code 1 after 0.0m
W0113 00:34:21.305] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1216517940929630214/artifacts not exist yet
I0113 00:34:21.305] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1216517940929630214/artifacts
I0113 00:34:22.759] process 1562 exited with code 0 after 0.0m
I0113 00:34:22.760] Call:  git rev-parse HEAD
W0113 00:34:22.764] fatal: not a git repository (or any of the parent directories): .git
E0113 00:34:22.764] Command failed
I0113 00:34:22.764] process 2089 exited with code 128 after 0.0m
I0113 00:34:22.764] Call:  git rev-parse HEAD
I0113 00:34:22.768] process 2090 exited with code 0 after 0.0m
I0113 00:34:22.769] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json
I0113 00:34:23.630] process 2091 exited with code 0 after 0.0m
I0113 00:34:23.634] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json#1578864883812897'
... skipping 8 lines ...