This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-13 03:31
Elapsed4m59s
Revision
Buildergke-prow-default-pool-cf4891d4-fwhg
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/1ad58ef7-113c-4157-be93-80cdc248ad20/targets/test'}}
pod0ad12aae-35b5-11ea-9fef-d200904e1a96
resultstorehttps://source.cloud.google.com/results/invocations/1ad58ef7-113c-4157-be93-80cdc248ad20/targets/test
infra-commit5b37d6c80
job-versionv1.18.0-alpha.1.634+36e40fb8502930
pod0ad12aae-35b5-11ea-9fef-d200904e1a96
revisionv1.18.0-alpha.1.634+36e40fb8502930

Test Failures


Up 1m32s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.634+36e40fb8502930 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0113 03:31:23.641] process 47 exited with code 0 after 0.0m
I0113 03:31:23.642] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0113 03:31:23.642] Root: /workspace
I0113 03:31:23.645] cd to /workspace
I0113 03:31:23.646] Configure environment...
I0113 03:31:23.650] Call:  git show -s --format=format:%ct HEAD
W0113 03:31:23.669] fatal: not a git repository (or any of the parent directories): .git
I0113 03:31:23.670] process 60 exited with code 128 after 0.0m
W0113 03:31:23.670] Unable to print commit date for HEAD
I0113 03:31:23.670] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0113 03:31:24.665] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0113 03:31:25.084] process 61 exited with code 0 after 0.0m
I0113 03:31:25.084] Call:  gcloud config get-value account
... skipping 422 lines ...
W0113 03:35:21.687] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0113 03:35:21.687] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0113 03:35:21.688] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0113 03:35:21.688] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0113 03:35:21.688] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0113 03:35:21.688] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0113 03:36:06.806] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0113 03:36:06.882] 2020/01/13 03:36:06 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.634+36e40fb8502930 bootstrap-e2e' finished in 45.914962721s
W0113 03:36:08.906] 2020/01/13 03:36:08 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0113 03:36:09.968] 2020/01/13 03:36:09 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.634+36e40fb8502930 bootstrap-e2e: exit status 1
W0113 03:36:09.973] Traceback (most recent call last):
W0113 03:36:09.974]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0113 03:36:09.974]     main(parse_args())
W0113 03:36:09.974]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0113 03:36:09.974]     mode.start(runner_args)
W0113 03:36:09.974]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0113 03:36:09.974]     check_env(env, self.command, *args)
W0113 03:36:09.975]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0113 03:36:09.975]     subprocess.check_call(cmd, env=env)
W0113 03:36:09.975]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0113 03:36:09.975]     raise CalledProcessError(retcode, cmd)
W0113 03:36:09.976] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:StackdriverAcceleratorMonitoring\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0113 03:36:09.988] Command failed
I0113 03:36:09.988] process 268 exited with code 1 after 4.7m
E0113 03:36:09.988] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring
I0113 03:36:09.989] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0113 03:36:10.880] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0113 03:36:10.962] process 1377 exited with code 0 after 0.0m
I0113 03:36:10.962] Call:  gcloud config get-value account
I0113 03:36:11.524] process 1390 exited with code 0 after 0.0m
I0113 03:36:11.525] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0113 03:36:11.525] Upload result and artifacts...
I0113 03:36:11.525] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1216563239299584000
I0113 03:36:11.526] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1216563239299584000/artifacts
W0113 03:36:12.482] CommandException: One or more URLs matched no objects.
E0113 03:36:12.618] Command failed
I0113 03:36:12.618] process 1403 exited with code 1 after 0.0m
W0113 03:36:12.618] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1216563239299584000/artifacts not exist yet
I0113 03:36:12.618] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1216563239299584000/artifacts
I0113 03:36:15.165] process 1548 exited with code 0 after 0.0m
I0113 03:36:15.166] Call:  git rev-parse HEAD
W0113 03:36:15.170] fatal: not a git repository (or any of the parent directories): .git
E0113 03:36:15.171] Command failed
I0113 03:36:15.171] process 2075 exited with code 128 after 0.0m
I0113 03:36:15.172] Call:  git rev-parse HEAD
I0113 03:36:15.178] process 2076 exited with code 0 after 0.0m
I0113 03:36:15.178] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json
I0113 03:36:16.718] process 2077 exited with code 0 after 0.0m
I0113 03:36:16.719] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json#1578875665462804'
... skipping 8 lines ...