This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-13 15:31
Elapsed3m29s
Revision
Buildergke-prow-default-pool-cf4891d4-0178
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/1cc756d0-47e2-450c-ae2f-60010858e325/targets/test'}}
poda07aa632-3619-11ea-9fef-d200904e1a96
resultstorehttps://source.cloud.google.com/results/invocations/1cc756d0-47e2-450c-ae2f-60010858e325/targets/test
infra-commitb3462c342
job-versionv1.18.0-alpha.1.634+36e40fb8502930
poda07aa632-3619-11ea-9fef-d200904e1a96
revisionv1.18.0-alpha.1.634+36e40fb8502930

Test Failures


Up 1m25s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-04 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.634+36e40fb8502930 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0113 15:31:09.423] process 48 exited with code 0 after 0.0m
I0113 15:31:09.423] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0113 15:31:09.423] Root: /workspace
I0113 15:31:09.423] cd to /workspace
I0113 15:31:09.423] Configure environment...
I0113 15:31:09.424] Call:  git show -s --format=format:%ct HEAD
W0113 15:31:09.427] fatal: not a git repository (or any of the parent directories): .git
I0113 15:31:09.428] process 61 exited with code 128 after 0.0m
W0113 15:31:09.428] Unable to print commit date for HEAD
I0113 15:31:09.429] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0113 15:31:10.012] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0113 15:31:10.158] process 62 exited with code 0 after 0.0m
I0113 15:31:10.158] Call:  gcloud config get-value account
... skipping 426 lines ...
W0113 15:33:37.377] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0113 15:33:37.378] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0113 15:33:37.378] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0113 15:33:37.378] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0113 15:33:37.379] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0113 15:33:37.379] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0113 15:34:23.302] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0113 15:34:23.353] 2020/01/13 15:34:23 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-04 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.634+36e40fb8502930 bootstrap-e2e' finished in 46.438450629s
W0113 15:34:25.095] 2020/01/13 15:34:25 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0113 15:34:29.985] 2020/01/13 15:34:29 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-04 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.634+36e40fb8502930 bootstrap-e2e: exit status 1
W0113 15:34:29.990] Traceback (most recent call last):
W0113 15:34:29.991]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0113 15:34:29.991]     main(parse_args())
W0113 15:34:29.991]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0113 15:34:29.991]     mode.start(runner_args)
W0113 15:34:29.991]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0113 15:34:29.992]     check_env(env, self.command, *args)
W0113 15:34:29.992]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0113 15:34:29.992]     subprocess.check_call(cmd, env=env)
W0113 15:34:29.992]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0113 15:34:29.993]     raise CalledProcessError(retcode, cmd)
W0113 15:34:29.994] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:StackdriverAcceleratorMonitoring\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0113 15:34:30.004] Command failed
I0113 15:34:30.004] process 269 exited with code 1 after 3.3m
E0113 15:34:30.005] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring
I0113 15:34:30.005] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0113 15:34:30.545] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0113 15:34:30.603] process 1392 exited with code 0 after 0.0m
I0113 15:34:30.603] Call:  gcloud config get-value account
I0113 15:34:30.979] process 1405 exited with code 0 after 0.0m
I0113 15:34:30.979] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0113 15:34:30.979] Upload result and artifacts...
I0113 15:34:30.980] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1216744434079633409
I0113 15:34:30.980] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1216744434079633409/artifacts
W0113 15:34:31.864] CommandException: One or more URLs matched no objects.
E0113 15:34:31.996] Command failed
I0113 15:34:31.996] process 1418 exited with code 1 after 0.0m
W0113 15:34:31.996] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1216744434079633409/artifacts not exist yet
I0113 15:34:31.997] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1216744434079633409/artifacts
I0113 15:34:33.724] process 1563 exited with code 0 after 0.0m
I0113 15:34:33.725] Call:  git rev-parse HEAD
W0113 15:34:33.729] fatal: not a git repository (or any of the parent directories): .git
E0113 15:34:33.730] Command failed
I0113 15:34:33.730] process 2090 exited with code 128 after 0.0m
I0113 15:34:33.730] Call:  git rev-parse HEAD
I0113 15:34:33.735] process 2091 exited with code 0 after 0.0m
I0113 15:34:33.735] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json
I0113 15:34:34.824] process 2092 exited with code 0 after 0.0m
I0113 15:34:34.824] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json#1578918921996869'
... skipping 8 lines ...