This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-13 18:31
Elapsed5m19s
Revision
Buildergke-prow-default-pool-cf4891d4-dttk
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/7b96807a-5313-4043-b57a-735987ff4a2c/targets/test'}}
podc6311c78-3632-11ea-9fef-d200904e1a96
resultstorehttps://source.cloud.google.com/results/invocations/7b96807a-5313-4043-b57a-735987ff4a2c/targets/test
infra-commit10207fa02
job-versionv1.18.0-alpha.1.638+e265afa2cdfb2b
podc6311c78-3632-11ea-9fef-d200904e1a96
revisionv1.18.0-alpha.1.638+e265afa2cdfb2b

Test Failures


Up 1m38s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.638+e265afa2cdfb2b bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0113 18:31:14.572] process 47 exited with code 0 after 0.0m
I0113 18:31:14.573] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0113 18:31:14.573] Root: /workspace
I0113 18:31:14.573] cd to /workspace
I0113 18:31:14.573] Configure environment...
I0113 18:31:14.574] Call:  git show -s --format=format:%ct HEAD
W0113 18:31:14.578] fatal: not a git repository (or any of the parent directories): .git
I0113 18:31:14.578] process 60 exited with code 128 after 0.0m
W0113 18:31:14.578] Unable to print commit date for HEAD
I0113 18:31:14.578] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0113 18:31:15.085] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0113 18:31:15.214] process 61 exited with code 0 after 0.0m
I0113 18:31:15.214] Call:  gcloud config get-value account
... skipping 426 lines ...
W0113 18:34:47.197] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0113 18:34:47.197] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0113 18:34:47.197] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0113 18:34:47.198] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0113 18:34:47.198] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0113 18:34:47.198] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0113 18:35:34.383] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0113 18:35:34.479] 2020/01/13 18:35:34 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.638+e265afa2cdfb2b bootstrap-e2e' finished in 47.820111653s
W0113 18:35:36.660] 2020/01/13 18:35:36 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0113 18:36:18.091] 2020/01/13 18:36:18 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.638+e265afa2cdfb2b bootstrap-e2e: exit status 1
W0113 18:36:18.103] Traceback (most recent call last):
W0113 18:36:18.103]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0113 18:36:18.110]     main(parse_args())
W0113 18:36:18.111]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0113 18:36:18.111]     mode.start(runner_args)
W0113 18:36:18.111]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0113 18:36:18.112]     check_env(env, self.command, *args)
W0113 18:36:18.112]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0113 18:36:18.115]     subprocess.check_call(cmd, env=env)
W0113 18:36:18.115]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0113 18:36:18.115]     raise CalledProcessError(retcode, cmd)
W0113 18:36:18.116] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:StackdriverAcceleratorMonitoring\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0113 18:36:18.139] Command failed
I0113 18:36:18.139] process 268 exited with code 1 after 5.0m
E0113 18:36:18.139] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring
I0113 18:36:18.140] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0113 18:36:19.090] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0113 18:36:19.253] process 1391 exited with code 0 after 0.0m
I0113 18:36:19.253] Call:  gcloud config get-value account
I0113 18:36:19.979] process 1404 exited with code 0 after 0.0m
I0113 18:36:19.979] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0113 18:36:19.979] Upload result and artifacts...
I0113 18:36:19.979] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1216789735805030400
I0113 18:36:19.980] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1216789735805030400/artifacts
W0113 18:36:21.839] CommandException: One or more URLs matched no objects.
E0113 18:36:22.099] Command failed
I0113 18:36:22.099] process 1417 exited with code 1 after 0.0m
W0113 18:36:22.099] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1216789735805030400/artifacts not exist yet
I0113 18:36:22.099] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1216789735805030400/artifacts
I0113 18:36:25.398] process 1562 exited with code 0 after 0.1m
I0113 18:36:25.403] Call:  git rev-parse HEAD
W0113 18:36:25.411] fatal: not a git repository (or any of the parent directories): .git
E0113 18:36:25.415] Command failed
I0113 18:36:25.415] process 2089 exited with code 128 after 0.0m
I0113 18:36:25.415] Call:  git rev-parse HEAD
I0113 18:36:25.427] process 2090 exited with code 0 after 0.0m
I0113 18:36:25.427] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json
I0113 18:36:27.547] process 2091 exited with code 0 after 0.0m
I0113 18:36:27.548] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json#1578929677223608'
... skipping 8 lines ...