This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-14 03:31
Elapsed3m46s
Revision
Buildergke-prow-default-pool-cf4891d4-rfrs
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/f7e06311-2680-49ce-b8b3-d51de6fb105b/targets/test'}}
pod37853a8a-367e-11ea-9f20-3687633bf296
resultstorehttps://source.cloud.google.com/results/invocations/f7e06311-2680-49ce-b8b3-d51de6fb105b/targets/test
infra-commitac4bda6bc
job-versionv1.18.0-alpha.1.658+61d36e4a43b831
pod37853a8a-367e-11ea-9f20-3687633bf296
revisionv1.18.0-alpha.1.658+61d36e4a43b831

Test Failures


Up 1m40s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.658+61d36e4a43b831 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0114 03:31:12.620] process 48 exited with code 0 after 0.0m
I0114 03:31:12.621] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0114 03:31:12.621] Root: /workspace
I0114 03:31:12.621] cd to /workspace
I0114 03:31:12.621] Configure environment...
I0114 03:31:12.622] Call:  git show -s --format=format:%ct HEAD
W0114 03:31:12.626] fatal: not a git repository (or any of the parent directories): .git
I0114 03:31:12.626] process 61 exited with code 128 after 0.0m
W0114 03:31:12.626] Unable to print commit date for HEAD
I0114 03:31:12.627] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0114 03:31:13.154] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0114 03:31:13.493] process 62 exited with code 0 after 0.0m
I0114 03:31:13.494] Call:  gcloud config get-value account
... skipping 426 lines ...
W0114 03:33:52.485] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0114 03:33:52.485] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0114 03:33:52.486] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0114 03:33:52.486] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0114 03:33:52.486] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0114 03:33:52.486] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0114 03:34:37.397] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0114 03:34:37.455] 2020/01/14 03:34:37 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.658+61d36e4a43b831 bootstrap-e2e' finished in 45.453951169s
W0114 03:34:39.112] 2020/01/14 03:34:39 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0114 03:34:50.686] 2020/01/14 03:34:50 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.658+61d36e4a43b831 bootstrap-e2e: exit status 1
W0114 03:34:50.689] Traceback (most recent call last):
W0114 03:34:50.690]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0114 03:34:50.690]     main(parse_args())
W0114 03:34:50.690]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0114 03:34:50.690]     mode.start(runner_args)
W0114 03:34:50.691]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0114 03:34:50.691]     check_env(env, self.command, *args)
W0114 03:34:50.691]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0114 03:34:50.691]     subprocess.check_call(cmd, env=env)
W0114 03:34:50.691]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0114 03:34:50.691]     raise CalledProcessError(retcode, cmd)
W0114 03:34:50.692] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:StackdriverAcceleratorMonitoring\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0114 03:34:50.700] Command failed
I0114 03:34:50.700] process 269 exited with code 1 after 3.6m
E0114 03:34:50.700] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring
I0114 03:34:50.701] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0114 03:34:51.271] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0114 03:34:51.327] process 1393 exited with code 0 after 0.0m
I0114 03:34:51.327] Call:  gcloud config get-value account
I0114 03:34:51.676] process 1406 exited with code 0 after 0.0m
I0114 03:34:51.677] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0114 03:34:51.677] Upload result and artifacts...
I0114 03:34:51.677] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1216925645079056384
I0114 03:34:51.677] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1216925645079056384/artifacts
W0114 03:34:52.636] CommandException: One or more URLs matched no objects.
E0114 03:34:52.758] Command failed
I0114 03:34:52.758] process 1419 exited with code 1 after 0.0m
W0114 03:34:52.758] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1216925645079056384/artifacts not exist yet
I0114 03:34:52.758] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1216925645079056384/artifacts
I0114 03:34:54.333] process 1564 exited with code 0 after 0.0m
I0114 03:34:54.333] Call:  git rev-parse HEAD
W0114 03:34:54.337] fatal: not a git repository (or any of the parent directories): .git
E0114 03:34:54.338] Command failed
I0114 03:34:54.338] process 2091 exited with code 128 after 0.0m
I0114 03:34:54.338] Call:  git rev-parse HEAD
I0114 03:34:54.342] process 2092 exited with code 0 after 0.0m
I0114 03:34:54.343] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json
I0114 03:34:55.351] process 2093 exited with code 0 after 0.0m
I0114 03:34:55.352] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json#1578962225853189'
... skipping 8 lines ...