This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-15 06:30
Elapsed3m5s
Revision
Buildergke-prow-default-pool-cf4891d4-1htj
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/9eaae105-831f-4c60-92fd-2424065c712e/targets/test'}}
pod765eef9b-3760-11ea-8603-da2f7a5855b4
resultstorehttps://source.cloud.google.com/results/invocations/9eaae105-831f-4c60-92fd-2424065c712e/targets/test
infra-commit29e07a334
job-versionv1.18.0-alpha.1.729+a25c6aa3506718
pod765eef9b-3760-11ea-8603-da2f7a5855b4
revisionv1.18.0-alpha.1.729+a25c6aa3506718

Test Failures


Up 40s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gce-plugin-gpus --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.729+a25c6aa3506718 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0115 06:30:49.147] process 47 exited with code 0 after 0.0m
I0115 06:30:49.147] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0115 06:30:49.148] Root: /workspace
I0115 06:30:49.148] cd to /workspace
I0115 06:30:49.148] Configure environment...
I0115 06:30:49.149] Call:  git show -s --format=format:%ct HEAD
W0115 06:30:49.154] fatal: not a git repository (or any of the parent directories): .git
I0115 06:30:49.154] process 60 exited with code 128 after 0.0m
W0115 06:30:49.155] Unable to print commit date for HEAD
I0115 06:30:49.155] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0115 06:30:49.745] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0115 06:30:49.889] process 61 exited with code 0 after 0.0m
I0115 06:30:49.889] Call:  gcloud config get-value account
... skipping 426 lines ...
W0115 06:33:40.702] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0115 06:33:40.703] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0115 06:33:40.703] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0115 06:33:40.703] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0115 06:33:40.704] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0115 06:33:40.704] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0115 06:33:40.794] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0115 06:33:40.852] 2020/01/15 06:33:40 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gce-plugin-gpus --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.729+a25c6aa3506718 bootstrap-e2e' finished in 637.041457ms
W0115 06:33:42.078] 2020/01/15 06:33:42 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0115 06:33:45.458] 2020/01/15 06:33:45 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gce-plugin-gpus --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.729+a25c6aa3506718 bootstrap-e2e: exit status 1
W0115 06:33:45.467] Traceback (most recent call last):
W0115 06:33:45.467]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0115 06:33:45.468]     main(parse_args())
W0115 06:33:45.468]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0115 06:33:45.468]     mode.start(runner_args)
W0115 06:33:45.468]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0115 06:33:45.469]     check_env(env, self.command, *args)
W0115 06:33:45.469]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0115 06:33:45.469]     subprocess.check_call(cmd, env=env)
W0115 06:33:45.469]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0115 06:33:45.469]     raise CalledProcessError(retcode, cmd)
W0115 06:33:45.470] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:StackdriverAcceleratorMonitoring\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0115 06:33:45.479] Command failed
I0115 06:33:45.480] process 268 exited with code 1 after 2.9m
E0115 06:33:45.480] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring
I0115 06:33:45.480] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0115 06:33:46.038] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0115 06:33:46.091] process 1392 exited with code 0 after 0.0m
I0115 06:33:46.092] Call:  gcloud config get-value account
I0115 06:33:46.441] process 1405 exited with code 0 after 0.0m
I0115 06:33:46.441] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0115 06:33:46.441] Upload result and artifacts...
I0115 06:33:46.441] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217333236493979650
I0115 06:33:46.442] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217333236493979650/artifacts
W0115 06:33:47.419] CommandException: One or more URLs matched no objects.
E0115 06:33:47.558] Command failed
I0115 06:33:47.559] process 1418 exited with code 1 after 0.0m
W0115 06:33:47.559] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217333236493979650/artifacts not exist yet
I0115 06:33:47.559] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217333236493979650/artifacts
I0115 06:33:49.437] process 1563 exited with code 0 after 0.0m
I0115 06:33:49.438] Call:  git rev-parse HEAD
W0115 06:33:49.445] fatal: not a git repository (or any of the parent directories): .git
E0115 06:33:49.445] Command failed
I0115 06:33:49.445] process 2090 exited with code 128 after 0.0m
I0115 06:33:49.446] Call:  git rev-parse HEAD
I0115 06:33:49.451] process 2091 exited with code 0 after 0.0m
I0115 06:33:49.451] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json
I0115 06:33:50.573] process 2092 exited with code 0 after 0.0m
I0115 06:33:50.574] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json#1579059222016044'
... skipping 8 lines ...