This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-15 09:30
Elapsed3m24s
Revision
Buildergke-prow-default-pool-cf4891d4-vb82
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/c1c40d1d-b9e7-4948-a569-d54c56638f45/targets/test'}}
pod9c05d6a1-3779-11ea-8603-da2f7a5855b4
resultstorehttps://source.cloud.google.com/results/invocations/c1c40d1d-b9e7-4948-a569-d54c56638f45/targets/test
infra-commit055aa0643
job-versionv1.18.0-alpha.1.737+45ad848b10fb26
pod9c05d6a1-3779-11ea-8603-da2f7a5855b4
revisionv1.18.0-alpha.1.737+45ad848b10fb26

Test Failures


Up 51s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.737+45ad848b10fb26 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0115 09:30:57.707] process 47 exited with code 0 after 0.0m
I0115 09:30:57.708] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0115 09:30:57.708] Root: /workspace
I0115 09:30:57.708] cd to /workspace
I0115 09:30:57.708] Configure environment...
I0115 09:30:57.709] Call:  git show -s --format=format:%ct HEAD
W0115 09:30:57.713] fatal: not a git repository (or any of the parent directories): .git
I0115 09:30:57.714] process 60 exited with code 128 after 0.0m
W0115 09:30:57.714] Unable to print commit date for HEAD
I0115 09:30:57.714] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0115 09:30:58.304] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0115 09:30:58.641] process 61 exited with code 0 after 0.0m
I0115 09:30:58.641] Call:  gcloud config get-value account
... skipping 426 lines ...
W0115 09:34:05.576] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0115 09:34:05.576] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0115 09:34:05.576] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0115 09:34:05.577] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0115 09:34:05.577] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0115 09:34:05.577] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0115 09:34:05.662] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0115 09:34:05.732] 2020/01/15 09:34:05 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.737+45ad848b10fb26 bootstrap-e2e' finished in 691.49244ms
W0115 09:34:07.021] 2020/01/15 09:34:07 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0115 09:34:12.553] 2020/01/15 09:34:12 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.737+45ad848b10fb26 bootstrap-e2e: exit status 1
W0115 09:34:12.560] Traceback (most recent call last):
W0115 09:34:12.560]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0115 09:34:12.560]     main(parse_args())
W0115 09:34:12.561]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0115 09:34:12.561]     mode.start(runner_args)
W0115 09:34:12.561]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0115 09:34:12.561]     check_env(env, self.command, *args)
W0115 09:34:12.561]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0115 09:34:12.561]     subprocess.check_call(cmd, env=env)
W0115 09:34:12.562]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0115 09:34:12.562]     raise CalledProcessError(retcode, cmd)
W0115 09:34:12.563] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:StackdriverAcceleratorMonitoring\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0115 09:34:12.572] Command failed
I0115 09:34:12.572] process 268 exited with code 1 after 3.2m
E0115 09:34:12.572] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring
I0115 09:34:12.573] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0115 09:34:13.157] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0115 09:34:13.222] process 1389 exited with code 0 after 0.0m
I0115 09:34:13.223] Call:  gcloud config get-value account
I0115 09:34:13.629] process 1402 exited with code 0 after 0.0m
I0115 09:34:13.630] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0115 09:34:13.630] Upload result and artifacts...
I0115 09:34:13.630] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217378537409875968
I0115 09:34:13.631] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217378537409875968/artifacts
W0115 09:34:14.631] CommandException: One or more URLs matched no objects.
E0115 09:34:14.784] Command failed
I0115 09:34:14.784] process 1415 exited with code 1 after 0.0m
W0115 09:34:14.784] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217378537409875968/artifacts not exist yet
I0115 09:34:14.784] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217378537409875968/artifacts
I0115 09:34:16.636] process 1560 exited with code 0 after 0.0m
I0115 09:34:16.637] Call:  git rev-parse HEAD
W0115 09:34:16.642] fatal: not a git repository (or any of the parent directories): .git
E0115 09:34:16.642] Command failed
I0115 09:34:16.642] process 2087 exited with code 128 after 0.0m
I0115 09:34:16.643] Call:  git rev-parse HEAD
I0115 09:34:16.647] process 2088 exited with code 0 after 0.0m
I0115 09:34:16.648] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json
I0115 09:34:17.831] process 2089 exited with code 0 after 0.0m
I0115 09:34:17.831] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json#1579070033017363'
... skipping 8 lines ...