This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-15 12:31
Elapsed4m14s
Revision
Buildergke-prow-default-pool-cf4891d4-658d
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/8617fe25-5388-43a9-b7db-a8c93a2cb9fd/targets/test'}}
podc14a1586-3792-11ea-8603-da2f7a5855b4
resultstorehttps://source.cloud.google.com/results/invocations/8617fe25-5388-43a9-b7db-a8c93a2cb9fd/targets/test
infra-commitff065cbb3
job-versionv1.18.0-alpha.1.751+c5982d03cf79b2
podc14a1586-3792-11ea-8603-da2f7a5855b4
revisionv1.18.0-alpha.1.751+c5982d03cf79b2

Test Failures


Up 45s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-10 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.751+c5982d03cf79b2 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0115 12:31:07.352] process 47 exited with code 0 after 0.0m
I0115 12:31:07.353] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0115 12:31:07.353] Root: /workspace
I0115 12:31:07.353] cd to /workspace
I0115 12:31:07.353] Configure environment...
I0115 12:31:07.354] Call:  git show -s --format=format:%ct HEAD
W0115 12:31:07.364] fatal: not a git repository (or any of the parent directories): .git
I0115 12:31:07.365] process 60 exited with code 128 after 0.0m
W0115 12:31:07.366] Unable to print commit date for HEAD
I0115 12:31:07.367] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0115 12:31:08.558] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0115 12:31:08.992] process 61 exited with code 0 after 0.0m
I0115 12:31:08.993] Call:  gcloud config get-value account
... skipping 426 lines ...
W0115 12:35:06.249] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0115 12:35:06.249] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0115 12:35:06.249] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0115 12:35:06.250] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0115 12:35:06.250] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0115 12:35:06.251] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0115 12:35:06.339] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0115 12:35:06.411] 2020/01/15 12:35:06 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-10 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.751+c5982d03cf79b2 bootstrap-e2e' finished in 786.188352ms
W0115 12:35:07.788] 2020/01/15 12:35:07 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0115 12:35:10.590] 2020/01/15 12:35:10 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-10 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.751+c5982d03cf79b2 bootstrap-e2e: exit status 1
W0115 12:35:10.600] Traceback (most recent call last):
W0115 12:35:10.600]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0115 12:35:10.600]     main(parse_args())
W0115 12:35:10.600]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0115 12:35:10.600]     mode.start(runner_args)
W0115 12:35:10.601]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0115 12:35:10.601]     check_env(env, self.command, *args)
W0115 12:35:10.601]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0115 12:35:10.601]     subprocess.check_call(cmd, env=env)
W0115 12:35:10.601]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0115 12:35:10.601]     raise CalledProcessError(retcode, cmd)
W0115 12:35:10.602] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:StackdriverAcceleratorMonitoring\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0115 12:35:10.614] Command failed
I0115 12:35:10.614] process 268 exited with code 1 after 4.0m
E0115 12:35:10.615] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring
I0115 12:35:10.615] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0115 12:35:11.189] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0115 12:35:11.257] process 1387 exited with code 0 after 0.0m
I0115 12:35:11.257] Call:  gcloud config get-value account
I0115 12:35:11.673] process 1400 exited with code 0 after 0.0m
I0115 12:35:11.673] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0115 12:35:11.673] Upload result and artifacts...
I0115 12:35:11.673] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217423839462428672
I0115 12:35:11.674] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217423839462428672/artifacts
W0115 12:35:12.711] CommandException: One or more URLs matched no objects.
E0115 12:35:12.888] Command failed
I0115 12:35:12.888] process 1413 exited with code 1 after 0.0m
W0115 12:35:12.889] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217423839462428672/artifacts not exist yet
I0115 12:35:12.889] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217423839462428672/artifacts
I0115 12:35:14.993] process 1558 exited with code 0 after 0.0m
I0115 12:35:14.994] Call:  git rev-parse HEAD
W0115 12:35:14.999] fatal: not a git repository (or any of the parent directories): .git
E0115 12:35:15.000] Command failed
I0115 12:35:15.000] process 2085 exited with code 128 after 0.0m
I0115 12:35:15.001] Call:  git rev-parse HEAD
I0115 12:35:15.008] process 2086 exited with code 0 after 0.0m
I0115 12:35:15.008] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json
I0115 12:35:16.403] process 2087 exited with code 0 after 0.0m
I0115 12:35:16.404] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json#1579080860341047'
... skipping 8 lines ...