This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-15 15:30
Elapsed3m11s
Revision
Buildergke-prow-default-pool-cf4891d4-p8rj
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/c1c6830b-07ed-4397-b45b-4e739f772456/targets/test'}}
pode6c24def-37ab-11ea-8603-da2f7a5855b4
resultstorehttps://source.cloud.google.com/results/invocations/c1c6830b-07ed-4397-b45b-4e739f772456/targets/test
infra-commitff065cbb3
job-versionv1.18.0-alpha.1.755+05209312b74eac
pode6c24def-37ab-11ea-8603-da2f7a5855b4
revisionv1.18.0-alpha.1.755+05209312b74eac

Test Failures


Up 50s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gce-gpus-beta --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.755+05209312b74eac bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0115 15:30:51.718] process 47 exited with code 0 after 0.0m
I0115 15:30:51.718] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0115 15:30:51.718] Root: /workspace
I0115 15:30:51.718] cd to /workspace
I0115 15:30:51.719] Configure environment...
I0115 15:30:51.719] Call:  git show -s --format=format:%ct HEAD
W0115 15:30:51.723] fatal: not a git repository (or any of the parent directories): .git
I0115 15:30:51.723] process 60 exited with code 128 after 0.0m
W0115 15:30:51.723] Unable to print commit date for HEAD
I0115 15:30:51.724] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0115 15:30:52.339] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0115 15:30:52.668] process 61 exited with code 0 after 0.0m
I0115 15:30:52.669] Call:  gcloud config get-value account
... skipping 426 lines ...
W0115 15:33:47.384] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0115 15:33:47.384] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0115 15:33:47.385] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0115 15:33:47.385] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0115 15:33:47.385] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0115 15:33:47.386] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0115 15:33:47.458] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0115 15:33:47.511] 2020/01/15 15:33:47 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gce-gpus-beta --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.755+05209312b74eac bootstrap-e2e' finished in 660.978908ms
W0115 15:33:48.924] 2020/01/15 15:33:48 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0115 15:33:53.342] 2020/01/15 15:33:53 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gce-gpus-beta --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.755+05209312b74eac bootstrap-e2e: exit status 1
W0115 15:33:53.346] Traceback (most recent call last):
W0115 15:33:53.346]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0115 15:33:53.346]     main(parse_args())
W0115 15:33:53.347]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0115 15:33:53.347]     mode.start(runner_args)
W0115 15:33:53.347]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0115 15:33:53.347]     check_env(env, self.command, *args)
W0115 15:33:53.347]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0115 15:33:53.347]     subprocess.check_call(cmd, env=env)
W0115 15:33:53.347]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0115 15:33:53.348]     raise CalledProcessError(retcode, cmd)
W0115 15:33:53.348] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:StackdriverAcceleratorMonitoring\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0115 15:33:53.357] Command failed
I0115 15:33:53.357] process 268 exited with code 1 after 3.0m
E0115 15:33:53.357] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring
I0115 15:33:53.358] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0115 15:33:53.950] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0115 15:33:54.015] process 1391 exited with code 0 after 0.0m
I0115 15:33:54.016] Call:  gcloud config get-value account
I0115 15:33:54.419] process 1404 exited with code 0 after 0.0m
I0115 15:33:54.420] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0115 15:33:54.420] Upload result and artifacts...
I0115 15:33:54.420] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217469140550291456
I0115 15:33:54.421] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217469140550291456/artifacts
W0115 15:33:55.435] CommandException: One or more URLs matched no objects.
E0115 15:33:55.577] Command failed
I0115 15:33:55.578] process 1417 exited with code 1 after 0.0m
W0115 15:33:55.578] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217469140550291456/artifacts not exist yet
I0115 15:33:55.578] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217469140550291456/artifacts
I0115 15:33:57.420] process 1562 exited with code 0 after 0.0m
I0115 15:33:57.421] Call:  git rev-parse HEAD
W0115 15:33:57.425] fatal: not a git repository (or any of the parent directories): .git
E0115 15:33:57.425] Command failed
I0115 15:33:57.425] process 2089 exited with code 128 after 0.0m
I0115 15:33:57.425] Call:  git rev-parse HEAD
I0115 15:33:57.430] process 2090 exited with code 0 after 0.0m
I0115 15:33:57.430] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json
I0115 15:33:58.448] process 2091 exited with code 0 after 0.0m
I0115 15:33:58.448] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json#1579091719188689'
... skipping 8 lines ...