This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-16 03:31
Elapsed4m42s
Revision
Buildergke-prow-default-pool-cf4891d4-6sc2
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/aff169c4-c208-4aa9-859f-ea3c9e54215a/targets/test'}}
pod7e65d530-3810-11ea-8f3e-66e48c863062
resultstorehttps://source.cloud.google.com/results/invocations/aff169c4-c208-4aa9-859f-ea3c9e54215a/targets/test
infra-commit70a5174aa
job-versionv1.18.0-alpha.1.793+2b6d875504d3af
pod7e65d530-3810-11ea-8f3e-66e48c863062
revisionv1.18.0-alpha.1.793+2b6d875504d3af

Test Failures


Up 47s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus-beta --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.793+2b6d875504d3af bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0116 03:31:11.724] process 47 exited with code 0 after 0.0m
I0116 03:31:11.724] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0116 03:31:11.725] Root: /workspace
I0116 03:31:11.725] cd to /workspace
I0116 03:31:11.725] Configure environment...
I0116 03:31:11.726] Call:  git show -s --format=format:%ct HEAD
W0116 03:31:11.733] fatal: not a git repository (or any of the parent directories): .git
I0116 03:31:11.733] process 60 exited with code 128 after 0.0m
W0116 03:31:11.734] Unable to print commit date for HEAD
I0116 03:31:11.734] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0116 03:31:13.078] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0116 03:31:13.517] process 61 exited with code 0 after 0.0m
I0116 03:31:13.518] Call:  gcloud config get-value account
... skipping 426 lines ...
W0116 03:35:27.888] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0116 03:35:27.889] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0116 03:35:27.891] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0116 03:35:27.892] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0116 03:35:27.892] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0116 03:35:27.893] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0116 03:35:27.986] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0116 03:35:28.057] 2020/01/16 03:35:28 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus-beta --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.793+2b6d875504d3af bootstrap-e2e' finished in 971.492196ms
W0116 03:35:29.757] 2020/01/16 03:35:29 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0116 03:35:40.914] 2020/01/16 03:35:40 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus-beta --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.793+2b6d875504d3af bootstrap-e2e: exit status 1
W0116 03:35:40.922] Traceback (most recent call last):
W0116 03:35:40.922]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0116 03:35:40.923]     main(parse_args())
W0116 03:35:40.923]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0116 03:35:40.923]     mode.start(runner_args)
W0116 03:35:40.923]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0116 03:35:40.923]     check_env(env, self.command, *args)
W0116 03:35:40.924]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0116 03:35:40.924]     subprocess.check_call(cmd, env=env)
W0116 03:35:40.924]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0116 03:35:40.924]     raise CalledProcessError(retcode, cmd)
W0116 03:35:40.925] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:StackdriverAcceleratorMonitoring\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0116 03:35:40.934] Command failed
I0116 03:35:40.935] process 268 exited with code 1 after 4.4m
E0116 03:35:40.935] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring
I0116 03:35:40.935] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0116 03:35:41.645] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0116 03:35:41.736] process 1387 exited with code 0 after 0.0m
I0116 03:35:41.737] Call:  gcloud config get-value account
I0116 03:35:42.234] process 1400 exited with code 0 after 0.0m
I0116 03:35:42.234] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0116 03:35:42.234] Upload result and artifacts...
I0116 03:35:42.234] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217650321019375623
I0116 03:35:42.235] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217650321019375623/artifacts
W0116 03:35:43.784] CommandException: One or more URLs matched no objects.
E0116 03:35:44.028] Command failed
I0116 03:35:44.028] process 1413 exited with code 1 after 0.0m
W0116 03:35:44.028] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217650321019375623/artifacts not exist yet
I0116 03:35:44.028] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217650321019375623/artifacts
I0116 03:35:46.456] process 1558 exited with code 0 after 0.0m
I0116 03:35:46.457] Call:  git rev-parse HEAD
W0116 03:35:46.471] fatal: not a git repository (or any of the parent directories): .git
E0116 03:35:46.471] Command failed
I0116 03:35:46.472] process 2085 exited with code 128 after 0.0m
I0116 03:35:46.472] Call:  git rev-parse HEAD
I0116 03:35:46.480] process 2086 exited with code 0 after 0.0m
I0116 03:35:46.481] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json
I0116 03:35:48.067] process 2087 exited with code 0 after 0.0m
I0116 03:35:48.068] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json#1579134844073041'
... skipping 8 lines ...