This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-16 06:31
Elapsed3m18s
Revision
Buildergke-prow-default-pool-cf4891d4-p8rj
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/9326190e-9a9a-4471-8987-5916d7dcf0b9/targets/test'}}
poda3d6d5fe-3829-11ea-8f3e-66e48c863062
resultstorehttps://source.cloud.google.com/results/invocations/9326190e-9a9a-4471-8987-5916d7dcf0b9/targets/test
infra-commit70a5174aa
job-versionv1.18.0-alpha.1.810+f437ff75d45517
poda3d6d5fe-3829-11ea-8f3e-66e48c863062
revisionv1.18.0-alpha.1.810+f437ff75d45517

Test Failures


Up 40s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-09 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.810+f437ff75d45517 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0116 06:31:41.606] process 47 exited with code 0 after 0.0m
I0116 06:31:41.607] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0116 06:31:41.607] Root: /workspace
I0116 06:31:41.607] cd to /workspace
I0116 06:31:41.607] Configure environment...
I0116 06:31:41.608] Call:  git show -s --format=format:%ct HEAD
W0116 06:31:41.612] fatal: not a git repository (or any of the parent directories): .git
I0116 06:31:41.613] process 60 exited with code 128 after 0.0m
W0116 06:31:41.613] Unable to print commit date for HEAD
I0116 06:31:41.613] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0116 06:31:42.250] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0116 06:31:42.391] process 61 exited with code 0 after 0.0m
I0116 06:31:42.391] Call:  gcloud config get-value account
... skipping 426 lines ...
W0116 06:34:38.616] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0116 06:34:38.616] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0116 06:34:38.618] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0116 06:34:38.618] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0116 06:34:38.618] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0116 06:34:38.619] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0116 06:34:38.693] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0116 06:34:38.745] 2020/01/16 06:34:38 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-09 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.810+f437ff75d45517 bootstrap-e2e' finished in 602.779238ms
W0116 06:34:40.010] 2020/01/16 06:34:40 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0116 06:34:51.251] 2020/01/16 06:34:51 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-09 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.810+f437ff75d45517 bootstrap-e2e: exit status 1
W0116 06:34:51.256] Traceback (most recent call last):
W0116 06:34:51.256]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0116 06:34:51.257]     main(parse_args())
W0116 06:34:51.257]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0116 06:34:51.257]     mode.start(runner_args)
W0116 06:34:51.257]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0116 06:34:51.257]     check_env(env, self.command, *args)
W0116 06:34:51.258]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0116 06:34:51.258]     subprocess.check_call(cmd, env=env)
W0116 06:34:51.258]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0116 06:34:51.258]     raise CalledProcessError(retcode, cmd)
W0116 06:34:51.259] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:StackdriverAcceleratorMonitoring\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0116 06:34:51.268] Command failed
I0116 06:34:51.268] process 268 exited with code 1 after 3.1m
E0116 06:34:51.268] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring
I0116 06:34:51.269] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0116 06:34:51.842] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0116 06:34:51.899] process 1392 exited with code 0 after 0.0m
I0116 06:34:51.900] Call:  gcloud config get-value account
I0116 06:34:52.243] process 1405 exited with code 0 after 0.0m
I0116 06:34:52.244] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0116 06:34:52.244] Upload result and artifacts...
I0116 06:34:52.244] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217695619829731332
I0116 06:34:52.244] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217695619829731332/artifacts
W0116 06:34:53.184] CommandException: One or more URLs matched no objects.
E0116 06:34:53.305] Command failed
I0116 06:34:53.306] process 1418 exited with code 1 after 0.0m
W0116 06:34:53.306] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217695619829731332/artifacts not exist yet
I0116 06:34:53.306] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217695619829731332/artifacts
I0116 06:34:54.942] process 1563 exited with code 0 after 0.0m
I0116 06:34:54.943] Call:  git rev-parse HEAD
W0116 06:34:54.948] fatal: not a git repository (or any of the parent directories): .git
E0116 06:34:54.948] Command failed
I0116 06:34:54.948] process 2090 exited with code 128 after 0.0m
I0116 06:34:54.949] Call:  git rev-parse HEAD
I0116 06:34:54.953] process 2091 exited with code 0 after 0.0m
I0116 06:34:54.953] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json
I0116 06:34:55.976] process 2092 exited with code 0 after 0.0m
I0116 06:34:55.977] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json#1579145751131954'
... skipping 8 lines ...