This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-16 18:30
Elapsed3m1s
Revision
Buildergke-prow-default-pool-cf4891d4-rfrs
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/863e79eb-6a3d-4e26-8bfd-3f0bd0fb9bff/targets/test'}}
pod38a222c0-388e-11ea-8f3e-66e48c863062
resultstorehttps://source.cloud.google.com/results/invocations/863e79eb-6a3d-4e26-8bfd-3f0bd0fb9bff/targets/test
infra-commit52fe941d7
job-versionv1.18.0-alpha.1.824+450196a719ad34
pod38a222c0-388e-11ea-8f3e-66e48c863062
revisionv1.18.0-alpha.1.824+450196a719ad34

Test Failures


Up 39s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-06 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.824+450196a719ad34 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0116 18:30:51.873] process 47 exited with code 0 after 0.0m
I0116 18:30:51.873] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0116 18:30:51.874] Root: /workspace
I0116 18:30:51.874] cd to /workspace
I0116 18:30:51.874] Configure environment...
I0116 18:30:51.875] Call:  git show -s --format=format:%ct HEAD
W0116 18:30:51.881] fatal: not a git repository (or any of the parent directories): .git
I0116 18:30:51.882] process 60 exited with code 128 after 0.0m
W0116 18:30:51.882] Unable to print commit date for HEAD
I0116 18:30:51.883] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0116 18:30:52.670] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0116 18:30:53.047] process 61 exited with code 0 after 0.0m
I0116 18:30:53.048] Call:  gcloud config get-value account
... skipping 426 lines ...
W0116 18:33:35.884] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0116 18:33:35.885] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0116 18:33:35.885] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0116 18:33:35.885] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0116 18:33:35.886] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0116 18:33:35.886] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0116 18:33:35.980] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0116 18:33:36.039] 2020/01/16 18:33:36 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-06 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.824+450196a719ad34 bootstrap-e2e' finished in 646.506294ms
W0116 18:33:37.401] 2020/01/16 18:33:37 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0116 18:33:43.404] 2020/01/16 18:33:43 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-06 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.824+450196a719ad34 bootstrap-e2e: exit status 1
W0116 18:33:43.408] Traceback (most recent call last):
W0116 18:33:43.408]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0116 18:33:43.408]     main(parse_args())
W0116 18:33:43.409]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0116 18:33:43.409]     mode.start(runner_args)
W0116 18:33:43.409]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0116 18:33:43.409]     check_env(env, self.command, *args)
W0116 18:33:43.409]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0116 18:33:43.410]     subprocess.check_call(cmd, env=env)
W0116 18:33:43.410]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0116 18:33:43.411]     raise CalledProcessError(retcode, cmd)
W0116 18:33:43.412] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:StackdriverAcceleratorMonitoring\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0116 18:33:43.421] Command failed
I0116 18:33:43.421] process 268 exited with code 1 after 2.8m
E0116 18:33:43.421] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring
I0116 18:33:43.422] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0116 18:33:43.977] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0116 18:33:44.039] process 1388 exited with code 0 after 0.0m
I0116 18:33:44.039] Call:  gcloud config get-value account
I0116 18:33:44.359] process 1401 exited with code 0 after 0.0m
I0116 18:33:44.360] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0116 18:33:44.360] Upload result and artifacts...
I0116 18:33:44.360] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217876813376655361
I0116 18:33:44.360] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217876813376655361/artifacts
W0116 18:33:45.376] CommandException: One or more URLs matched no objects.
E0116 18:33:45.504] Command failed
I0116 18:33:45.504] process 1414 exited with code 1 after 0.0m
W0116 18:33:45.504] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217876813376655361/artifacts not exist yet
I0116 18:33:45.505] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1217876813376655361/artifacts
I0116 18:33:47.367] process 1559 exited with code 0 after 0.0m
I0116 18:33:47.368] Call:  git rev-parse HEAD
W0116 18:33:47.372] fatal: not a git repository (or any of the parent directories): .git
E0116 18:33:47.372] Command failed
I0116 18:33:47.372] process 2086 exited with code 128 after 0.0m
I0116 18:33:47.373] Call:  git rev-parse HEAD
I0116 18:33:47.376] process 2087 exited with code 0 after 0.0m
I0116 18:33:47.377] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json
I0116 18:33:48.532] process 2088 exited with code 0 after 0.0m
I0116 18:33:48.533] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json#1579188857431374'
... skipping 8 lines ...