This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-17 09:31
Elapsed2m56s
Revision
Buildergke-prow-default-pool-cf4891d4-jd8d
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/98fc06bc-d73b-4009-b13f-02a5fe37a62b/targets/test'}}
pod0bf4f252-390c-11ea-8780-468616f72408
resultstorehttps://source.cloud.google.com/results/invocations/98fc06bc-d73b-4009-b13f-02a5fe37a62b/targets/test
infra-commit573707797
job-versionv1.18.0-alpha.1.850+fdd575f8dc4413
pod0bf4f252-390c-11ea-8780-468616f72408
revisionv1.18.0-alpha.1.850+fdd575f8dc4413

Test Failures


Up 45s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gce-plugin-gpus --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.850+fdd575f8dc4413 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0117 09:31:40.194] process 47 exited with code 0 after 0.0m
I0117 09:31:40.195] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0117 09:31:40.195] Root: /workspace
I0117 09:31:40.195] cd to /workspace
I0117 09:31:40.195] Configure environment...
I0117 09:31:40.195] Call:  git show -s --format=format:%ct HEAD
W0117 09:31:40.199] fatal: not a git repository (or any of the parent directories): .git
I0117 09:31:40.200] process 60 exited with code 128 after 0.0m
W0117 09:31:40.200] Unable to print commit date for HEAD
I0117 09:31:40.200] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0117 09:31:40.701] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0117 09:31:41.020] process 61 exited with code 0 after 0.0m
I0117 09:31:41.020] Call:  gcloud config get-value account
... skipping 426 lines ...
W0117 09:34:24.297] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0117 09:34:24.297] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0117 09:34:24.298] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0117 09:34:24.298] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0117 09:34:24.298] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0117 09:34:24.298] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0117 09:34:24.382] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0117 09:34:24.427] 2020/01/17 09:34:24 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gce-plugin-gpus --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.850+fdd575f8dc4413 bootstrap-e2e' finished in 553.320723ms
W0117 09:34:25.536] 2020/01/17 09:34:25 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0117 09:34:27.224] 2020/01/17 09:34:27 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gce-plugin-gpus --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.850+fdd575f8dc4413 bootstrap-e2e: exit status 1
W0117 09:34:27.228] Traceback (most recent call last):
W0117 09:34:27.228]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0117 09:34:27.229]     main(parse_args())
W0117 09:34:27.229]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0117 09:34:27.229]     mode.start(runner_args)
W0117 09:34:27.229]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0117 09:34:27.229]     check_env(env, self.command, *args)
W0117 09:34:27.229]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0117 09:34:27.230]     subprocess.check_call(cmd, env=env)
W0117 09:34:27.230]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0117 09:34:27.230]     raise CalledProcessError(retcode, cmd)
W0117 09:34:27.231] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:StackdriverAcceleratorMonitoring\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0117 09:34:27.239] Command failed
I0117 09:34:27.239] process 268 exited with code 1 after 2.7m
E0117 09:34:27.239] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring
I0117 09:34:27.240] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0117 09:34:27.745] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0117 09:34:27.800] process 1391 exited with code 0 after 0.0m
I0117 09:34:27.800] Call:  gcloud config get-value account
I0117 09:34:28.156] process 1404 exited with code 0 after 0.0m
I0117 09:34:28.156] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0117 09:34:28.156] Upload result and artifacts...
I0117 09:34:28.156] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1218103510155923457
I0117 09:34:28.157] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1218103510155923457/artifacts
W0117 09:34:29.087] CommandException: One or more URLs matched no objects.
E0117 09:34:29.209] Command failed
I0117 09:34:29.209] process 1417 exited with code 1 after 0.0m
W0117 09:34:29.210] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1218103510155923457/artifacts not exist yet
I0117 09:34:29.210] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/1218103510155923457/artifacts
I0117 09:34:31.190] process 1562 exited with code 0 after 0.0m
I0117 09:34:31.191] Call:  git rev-parse HEAD
W0117 09:34:31.195] fatal: not a git repository (or any of the parent directories): .git
E0117 09:34:31.195] Command failed
I0117 09:34:31.195] process 2089 exited with code 128 after 0.0m
I0117 09:34:31.196] Call:  git rev-parse HEAD
I0117 09:34:31.203] process 2090 exited with code 0 after 0.0m
I0117 09:34:31.204] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json
I0117 09:34:32.308] process 2091 exited with code 0 after 0.0m
I0117 09:34:32.309] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-monitoring/jobResultsCache.json#1579242951724271'
... skipping 8 lines ...