This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-12-30 20:31
Elapsed3m23s
Revision
Buildergke-prow-ssd-pool-1a225945-577q
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/ee2959ad-008e-40a3-9dce-112531dd3f58/targets/test'}}
pod348a0187-2b43-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/ee2959ad-008e-40a3-9dce-112531dd3f58/targets/test
infra-commit919806f44
job-versionv1.17.1-beta.0.30+7d04da8a4a80f2
pod348a0187-2b43-11ea-a07b-c6eb1bf16817
revisionv1.17.1-beta.0.30+7d04da8a4a80f2

Test Failures


Up 1m35s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.30+7d04da8a4a80f2 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1230 20:31:04.113] process 47 exited with code 0 after 0.0m
I1230 20:31:04.114] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1230 20:31:04.114] Root: /workspace
I1230 20:31:04.114] cd to /workspace
I1230 20:31:04.114] Configure environment...
I1230 20:31:04.115] Call:  git show -s --format=format:%ct HEAD
W1230 20:31:04.120] fatal: not a git repository (or any of the parent directories): .git
I1230 20:31:04.120] process 60 exited with code 128 after 0.0m
W1230 20:31:04.121] Unable to print commit date for HEAD
I1230 20:31:04.121] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1230 20:31:04.699] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1230 20:31:05.042] process 61 exited with code 0 after 0.0m
I1230 20:31:05.043] Call:  gcloud config get-value account
... skipping 426 lines ...
W1230 20:33:23.566] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1230 20:33:23.567] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W1230 20:33:23.567] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1230 20:33:23.568] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1230 20:33:23.569] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1230 20:33:23.569] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1230 20:34:08.139] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1230 20:34:08.211] 2019/12/30 20:34:08 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.30+7d04da8a4a80f2 bootstrap-e2e' finished in 45.160663676s
W1230 20:34:10.103] 2019/12/30 20:34:10 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1230 20:34:16.089] 2019/12/30 20:34:16 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.30+7d04da8a4a80f2 bootstrap-e2e: exit status 1
W1230 20:34:16.095] Traceback (most recent call last):
W1230 20:34:16.096]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1230 20:34:16.096]     main(parse_args())
W1230 20:34:16.096]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1230 20:34:16.096]     mode.start(runner_args)
W1230 20:34:16.097]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1230 20:34:16.097]     check_env(env, self.command, *args)
W1230 20:34:16.097]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1230 20:34:16.097]     subprocess.check_call(cmd, env=env)
W1230 20:34:16.097]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1230 20:34:16.098]     raise CalledProcessError(retcode, cmd)
W1230 20:34:16.098] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-beta', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1230 20:34:16.111] Command failed
I1230 20:34:16.111] process 268 exited with code 1 after 3.2m
E1230 20:34:16.111] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta
I1230 20:34:16.112] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1230 20:34:16.737] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1230 20:34:16.785] process 1389 exited with code 0 after 0.0m
I1230 20:34:16.785] Call:  gcloud config get-value account
I1230 20:34:17.265] process 1402 exited with code 0 after 0.0m
I1230 20:34:17.265] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1230 20:34:17.265] Upload result and artifacts...
I1230 20:34:17.266] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1211746474971369473
I1230 20:34:17.266] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1211746474971369473/artifacts
W1230 20:34:18.801] CommandException: One or more URLs matched no objects.
E1230 20:34:19.006] Command failed
I1230 20:34:19.006] process 1415 exited with code 1 after 0.0m
W1230 20:34:19.007] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1211746474971369473/artifacts not exist yet
I1230 20:34:19.007] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1211746474971369473/artifacts
I1230 20:34:21.476] process 1560 exited with code 0 after 0.0m
I1230 20:34:21.477] Call:  git rev-parse HEAD
W1230 20:34:21.487] fatal: not a git repository (or any of the parent directories): .git
E1230 20:34:21.488] Command failed
I1230 20:34:21.488] process 2087 exited with code 128 after 0.0m
I1230 20:34:21.489] Call:  git rev-parse HEAD
I1230 20:34:21.500] process 2088 exited with code 0 after 0.0m
I1230 20:34:21.501] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json
I1230 20:34:23.148] process 2089 exited with code 0 after 0.0m
I1230 20:34:23.150] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json#1577694855419484'
... skipping 8 lines ...