This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-12-31 20:31
Elapsed4m30s
Revision
Buildergke-prow-ssd-pool-1a225945-zhlt
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/ace2f85d-463a-4496-9ab5-35135adb0cd6/targets/test'}}
pod600c5853-2c0c-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/ace2f85d-463a-4496-9ab5-35135adb0cd6/targets/test
infra-commitc9b56298d
job-versionv1.17.1-beta.0.30+7d04da8a4a80f2
pod600c5853-2c0c-11ea-a07b-c6eb1bf16817
revisionv1.17.1-beta.0.30+7d04da8a4a80f2

Test Failures


Up 1m39s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.30+7d04da8a4a80f2 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1231 20:31:13.855] process 47 exited with code 0 after 0.0m
I1231 20:31:13.856] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1231 20:31:13.856] Root: /workspace
I1231 20:31:13.856] cd to /workspace
I1231 20:31:13.856] Configure environment...
I1231 20:31:13.857] Call:  git show -s --format=format:%ct HEAD
W1231 20:31:13.863] fatal: not a git repository (or any of the parent directories): .git
I1231 20:31:13.864] process 60 exited with code 128 after 0.0m
W1231 20:31:13.864] Unable to print commit date for HEAD
I1231 20:31:13.864] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1231 20:31:14.791] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1231 20:31:15.011] process 61 exited with code 0 after 0.0m
I1231 20:31:15.012] Call:  gcloud config get-value account
... skipping 422 lines ...
W1231 20:34:39.587] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1231 20:34:39.589] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W1231 20:34:39.590] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1231 20:34:39.591] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1231 20:34:39.592] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1231 20:34:39.592] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1231 20:35:27.914] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1231 20:35:27.969] 2019/12/31 20:35:27 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.30+7d04da8a4a80f2 bootstrap-e2e' finished in 48.915403844s
W1231 20:35:29.799] 2019/12/31 20:35:29 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1231 20:35:33.226] 2019/12/31 20:35:33 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.30+7d04da8a4a80f2 bootstrap-e2e: exit status 1
W1231 20:35:33.233] Traceback (most recent call last):
W1231 20:35:33.234]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1231 20:35:33.234]     main(parse_args())
W1231 20:35:33.234]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1231 20:35:33.235]     mode.start(runner_args)
W1231 20:35:33.235]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1231 20:35:33.235]     check_env(env, self.command, *args)
W1231 20:35:33.236]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1231 20:35:33.236]     subprocess.check_call(cmd, env=env)
W1231 20:35:33.236]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1231 20:35:33.236]     raise CalledProcessError(retcode, cmd)
W1231 20:35:33.237] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-beta', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1231 20:35:33.243] Command failed
I1231 20:35:33.243] process 268 exited with code 1 after 4.2m
E1231 20:35:33.243] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta
I1231 20:35:33.244] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1231 20:35:33.844] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1231 20:35:33.907] process 1376 exited with code 0 after 0.0m
I1231 20:35:33.907] Call:  gcloud config get-value account
I1231 20:35:34.324] process 1389 exited with code 0 after 0.0m
I1231 20:35:34.325] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1231 20:35:34.325] Upload result and artifacts...
I1231 20:35:34.325] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1212108880880865284
I1231 20:35:34.325] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1212108880880865284/artifacts
W1231 20:35:35.561] CommandException: One or more URLs matched no objects.
E1231 20:35:35.717] Command failed
I1231 20:35:35.717] process 1402 exited with code 1 after 0.0m
W1231 20:35:35.717] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1212108880880865284/artifacts not exist yet
I1231 20:35:35.717] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1212108880880865284/artifacts
I1231 20:35:37.720] process 1547 exited with code 0 after 0.0m
I1231 20:35:37.721] Call:  git rev-parse HEAD
W1231 20:35:37.725] fatal: not a git repository (or any of the parent directories): .git
E1231 20:35:37.726] Command failed
I1231 20:35:37.726] process 2074 exited with code 128 after 0.0m
I1231 20:35:37.726] Call:  git rev-parse HEAD
I1231 20:35:37.732] process 2075 exited with code 0 after 0.0m
I1231 20:35:37.733] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json
I1231 20:35:39.022] process 2076 exited with code 0 after 0.0m
I1231 20:35:39.023] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json#1577781299421616'
... skipping 8 lines ...