This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-01 20:31
Elapsed3m28s
Revision
Buildergke-prow-ssd-pool-1a225945-4zm0
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/aab5e37f-d8b6-4cc9-a866-117218954ad4/targets/test'}}
pod8adb7068-2cd5-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/aab5e37f-d8b6-4cc9-a866-117218954ad4/targets/test
infra-commit35a960fa0
job-versionv1.17.1-beta.0.30+7d04da8a4a80f2
pod8adb7068-2cd5-11ea-a07b-c6eb1bf16817
revisionv1.17.1-beta.0.30+7d04da8a4a80f2

Test Failures


Up 1m36s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-04 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.30+7d04da8a4a80f2 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0101 20:31:10.357] process 48 exited with code 0 after 0.0m
I0101 20:31:10.357] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0101 20:31:10.358] Root: /workspace
I0101 20:31:10.358] cd to /workspace
I0101 20:31:10.358] Configure environment...
I0101 20:31:10.358] Call:  git show -s --format=format:%ct HEAD
W0101 20:31:10.362] fatal: not a git repository (or any of the parent directories): .git
I0101 20:31:10.363] process 61 exited with code 128 after 0.0m
W0101 20:31:10.363] Unable to print commit date for HEAD
I0101 20:31:10.363] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0101 20:31:10.834] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0101 20:31:11.166] process 62 exited with code 0 after 0.0m
I0101 20:31:11.166] Call:  gcloud config get-value account
... skipping 426 lines ...
W0101 20:33:41.660] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0101 20:33:41.661] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0101 20:33:41.662] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0101 20:33:41.663] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0101 20:33:41.664] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0101 20:33:41.664] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0101 20:34:23.036] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0101 20:34:23.162] 2020/01/01 20:34:23 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-04 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.30+7d04da8a4a80f2 bootstrap-e2e' finished in 41.869332166s
W0101 20:34:25.958] 2020/01/01 20:34:25 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0101 20:34:31.272] 2020/01/01 20:34:31 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-04 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.30+7d04da8a4a80f2 bootstrap-e2e: exit status 1
W0101 20:34:31.276] Traceback (most recent call last):
W0101 20:34:31.276]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0101 20:34:31.276]     main(parse_args())
W0101 20:34:31.276]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0101 20:34:31.276]     mode.start(runner_args)
W0101 20:34:31.276]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0101 20:34:31.276]     check_env(env, self.command, *args)
W0101 20:34:31.277]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0101 20:34:31.277]     subprocess.check_call(cmd, env=env)
W0101 20:34:31.277]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0101 20:34:31.277]     raise CalledProcessError(retcode, cmd)
W0101 20:34:31.278] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-beta', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0101 20:34:31.283] Command failed
I0101 20:34:31.284] process 269 exited with code 1 after 3.3m
E0101 20:34:31.284] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta
I0101 20:34:31.284] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0101 20:34:31.745] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0101 20:34:31.786] process 1391 exited with code 0 after 0.0m
I0101 20:34:31.786] Call:  gcloud config get-value account
I0101 20:34:32.063] process 1404 exited with code 0 after 0.0m
I0101 20:34:32.063] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0101 20:34:32.064] Upload result and artifacts...
I0101 20:34:32.064] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1212471281383903233
I0101 20:34:32.064] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1212471281383903233/artifacts
W0101 20:34:32.828] CommandException: One or more URLs matched no objects.
E0101 20:34:32.928] Command failed
I0101 20:34:32.929] process 1417 exited with code 1 after 0.0m
W0101 20:34:32.929] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1212471281383903233/artifacts not exist yet
I0101 20:34:32.930] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1212471281383903233/artifacts
I0101 20:34:34.339] process 1562 exited with code 0 after 0.0m
I0101 20:34:34.340] Call:  git rev-parse HEAD
W0101 20:34:34.343] fatal: not a git repository (or any of the parent directories): .git
E0101 20:34:34.344] Command failed
I0101 20:34:34.344] process 2089 exited with code 128 after 0.0m
I0101 20:34:34.344] Call:  git rev-parse HEAD
I0101 20:34:34.348] process 2090 exited with code 0 after 0.0m
I0101 20:34:34.348] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json
I0101 20:34:35.228] process 2091 exited with code 0 after 0.0m
I0101 20:34:35.229] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json#1577867717455876'
... skipping 8 lines ...