This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-03 08:31
Elapsed3m42s
Revision
Buildergke-prow-ssd-pool-1a225945-lf79
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/8881ad12-4ad3-4dec-b1d2-4c1f4b6be231/targets/test'}}
pod4cae527c-2e03-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/8881ad12-4ad3-4dec-b1d2-4c1f4b6be231/targets/test
infra-commitd58556ac6
job-versionv1.17.1-beta.0.30+7d04da8a4a80f2
pod4cae527c-2e03-11ea-a07b-c6eb1bf16817
revisionv1.17.1-beta.0.30+7d04da8a4a80f2

Test Failures


Up 1m35s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.30+7d04da8a4a80f2 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0103 08:31:16.253] process 47 exited with code 0 after 0.0m
I0103 08:31:16.254] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0103 08:31:16.254] Root: /workspace
I0103 08:31:16.254] cd to /workspace
I0103 08:31:16.254] Configure environment...
I0103 08:31:16.255] Call:  git show -s --format=format:%ct HEAD
W0103 08:31:16.259] fatal: not a git repository (or any of the parent directories): .git
I0103 08:31:16.259] process 60 exited with code 128 after 0.0m
W0103 08:31:16.260] Unable to print commit date for HEAD
I0103 08:31:16.260] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0103 08:31:16.793] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0103 08:31:17.120] process 61 exited with code 0 after 0.0m
I0103 08:31:17.120] Call:  gcloud config get-value account
... skipping 426 lines ...
W0103 08:33:53.104] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0103 08:33:53.104] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0103 08:33:53.105] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0103 08:33:53.106] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0103 08:33:53.106] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0103 08:33:53.107] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0103 08:34:38.350] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0103 08:34:38.402] 2020/01/03 08:34:38 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.30+7d04da8a4a80f2 bootstrap-e2e' finished in 45.715733413s
W0103 08:34:39.929] 2020/01/03 08:34:39 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0103 08:34:50.883] 2020/01/03 08:34:50 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.30+7d04da8a4a80f2 bootstrap-e2e: exit status 1
W0103 08:34:50.887] Traceback (most recent call last):
W0103 08:34:50.888]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0103 08:34:50.888]     main(parse_args())
W0103 08:34:50.888]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0103 08:34:50.888]     mode.start(runner_args)
W0103 08:34:50.888]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0103 08:34:50.888]     check_env(env, self.command, *args)
W0103 08:34:50.889]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0103 08:34:50.889]     subprocess.check_call(cmd, env=env)
W0103 08:34:50.889]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0103 08:34:50.889]     raise CalledProcessError(retcode, cmd)
W0103 08:34:50.889] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-beta', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0103 08:34:50.898] Command failed
I0103 08:34:50.898] process 268 exited with code 1 after 3.5m
E0103 08:34:50.898] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta
I0103 08:34:50.899] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0103 08:34:51.406] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0103 08:34:51.464] process 1391 exited with code 0 after 0.0m
I0103 08:34:51.465] Call:  gcloud config get-value account
I0103 08:34:51.790] process 1404 exited with code 0 after 0.0m
I0103 08:34:51.791] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0103 08:34:51.791] Upload result and artifacts...
I0103 08:34:51.791] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1213014887798673410
I0103 08:34:51.792] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1213014887798673410/artifacts
W0103 08:34:52.669] CommandException: One or more URLs matched no objects.
E0103 08:34:52.789] Command failed
I0103 08:34:52.790] process 1417 exited with code 1 after 0.0m
W0103 08:34:52.790] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1213014887798673410/artifacts not exist yet
I0103 08:34:52.790] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1213014887798673410/artifacts
I0103 08:34:54.522] process 1562 exited with code 0 after 0.0m
I0103 08:34:54.523] Call:  git rev-parse HEAD
W0103 08:34:54.527] fatal: not a git repository (or any of the parent directories): .git
E0103 08:34:54.527] Command failed
I0103 08:34:54.528] process 2089 exited with code 128 after 0.0m
I0103 08:34:54.528] Call:  git rev-parse HEAD
I0103 08:34:54.533] process 2090 exited with code 0 after 0.0m
I0103 08:34:54.533] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json
I0103 08:34:55.482] process 2091 exited with code 0 after 0.0m
I0103 08:34:55.483] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json#1577997299048651'
... skipping 8 lines ...