This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-03 20:31
Elapsed3m38s
Revision
Buildergke-prow-ssd-pool-1a225945-gzk6
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/7cfbd7ea-a45e-4229-9ee9-0c5f4183ec57/targets/test'}}
pode306779d-2e67-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/7cfbd7ea-a45e-4229-9ee9-0c5f4183ec57/targets/test
infra-commitee7d95a4f
job-versionv1.17.1-beta.0.30+7d04da8a4a80f2
pode306779d-2e67-11ea-a07b-c6eb1bf16817
revisionv1.17.1-beta.0.30+7d04da8a4a80f2

Test Failures


Up 1m33s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-04 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.30+7d04da8a4a80f2 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0103 20:31:21.486] process 47 exited with code 0 after 0.0m
I0103 20:31:21.487] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0103 20:31:21.487] Root: /workspace
I0103 20:31:21.487] cd to /workspace
I0103 20:31:21.487] Configure environment...
I0103 20:31:21.488] Call:  git show -s --format=format:%ct HEAD
W0103 20:31:21.492] fatal: not a git repository (or any of the parent directories): .git
I0103 20:31:21.493] process 60 exited with code 128 after 0.0m
W0103 20:31:21.493] Unable to print commit date for HEAD
I0103 20:31:21.493] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0103 20:31:22.203] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0103 20:31:22.524] process 61 exited with code 0 after 0.0m
I0103 20:31:22.524] Call:  gcloud config get-value account
... skipping 426 lines ...
W0103 20:33:50.853] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0103 20:33:50.854] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0103 20:33:50.855] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0103 20:33:50.855] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0103 20:33:50.856] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0103 20:33:50.856] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0103 20:34:38.555] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0103 20:34:38.626] 2020/01/03 20:34:38 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-04 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.30+7d04da8a4a80f2 bootstrap-e2e' finished in 48.216556739s
W0103 20:34:41.045] 2020/01/03 20:34:41 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0103 20:34:46.954] 2020/01/03 20:34:46 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-04 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.30+7d04da8a4a80f2 bootstrap-e2e: exit status 1
W0103 20:34:46.972] Traceback (most recent call last):
W0103 20:34:46.973]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0103 20:34:46.973]     main(parse_args())
W0103 20:34:46.974]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0103 20:34:46.975]     mode.start(runner_args)
W0103 20:34:46.976]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0103 20:34:46.976]     check_env(env, self.command, *args)
W0103 20:34:46.977]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0103 20:34:46.978]     subprocess.check_call(cmd, env=env)
W0103 20:34:46.978]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0103 20:34:46.978]     raise CalledProcessError(retcode, cmd)
W0103 20:34:46.980] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-beta', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0103 20:34:46.982] Command failed
I0103 20:34:46.982] process 268 exited with code 1 after 3.4m
E0103 20:34:46.982] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta
I0103 20:34:46.983] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0103 20:34:50.410] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0103 20:34:50.469] process 1391 exited with code 0 after 0.1m
I0103 20:34:50.469] Call:  gcloud config get-value account
I0103 20:34:50.863] process 1404 exited with code 0 after 0.0m
I0103 20:34:50.864] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0103 20:34:50.864] Upload result and artifacts...
I0103 20:34:50.864] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1213196093592965124
I0103 20:34:50.864] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1213196093592965124/artifacts
W0103 20:34:51.875] CommandException: One or more URLs matched no objects.
E0103 20:34:52.006] Command failed
I0103 20:34:52.006] process 1417 exited with code 1 after 0.0m
W0103 20:34:52.006] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1213196093592965124/artifacts not exist yet
I0103 20:34:52.007] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1213196093592965124/artifacts
I0103 20:34:54.054] process 1562 exited with code 0 after 0.0m
I0103 20:34:54.054] Call:  git rev-parse HEAD
W0103 20:34:54.060] fatal: not a git repository (or any of the parent directories): .git
E0103 20:34:54.060] Command failed
I0103 20:34:54.060] process 2089 exited with code 128 after 0.0m
I0103 20:34:54.061] Call:  git rev-parse HEAD
I0103 20:34:54.065] process 2090 exited with code 0 after 0.0m
I0103 20:34:54.066] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json
I0103 20:34:55.595] process 2091 exited with code 0 after 0.0m
I0103 20:34:55.596] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json#1578040497497631'
... skipping 8 lines ...