This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-04 20:31
Elapsed3m27s
Revision
Buildergke-prow-ssd-pool-1a225945-5wt3
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/1e655b67-f8d1-4844-818d-5b66c4aa2534/targets/test'}}
pod0e028d3a-2f31-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/1e655b67-f8d1-4844-818d-5b66c4aa2534/targets/test
infra-commitfa0e0f711
job-versionv1.17.1-beta.0.30+7d04da8a4a80f2
pod0e028d3a-2f31-11ea-a07b-c6eb1bf16817
revisionv1.17.1-beta.0.30+7d04da8a4a80f2

Test Failures


Up 1m28s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-04 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.30+7d04da8a4a80f2 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0104 20:31:24.342] process 47 exited with code 0 after 0.0m
I0104 20:31:24.343] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0104 20:31:24.343] Root: /workspace
I0104 20:31:24.343] cd to /workspace
I0104 20:31:24.343] Configure environment...
I0104 20:31:24.344] Call:  git show -s --format=format:%ct HEAD
W0104 20:31:24.348] fatal: not a git repository (or any of the parent directories): .git
I0104 20:31:24.349] process 60 exited with code 128 after 0.0m
W0104 20:31:24.349] Unable to print commit date for HEAD
I0104 20:31:24.349] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0104 20:31:24.854] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0104 20:31:25.171] process 61 exited with code 0 after 0.0m
I0104 20:31:25.172] Call:  gcloud config get-value account
... skipping 426 lines ...
W0104 20:33:53.985] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0104 20:33:53.986] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0104 20:33:53.987] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0104 20:33:53.987] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0104 20:33:53.988] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0104 20:33:53.989] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0104 20:34:36.711] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0104 20:34:36.759] 2020/01/04 20:34:36 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-04 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.30+7d04da8a4a80f2 bootstrap-e2e' finished in 43.176808045s
W0104 20:34:38.322] 2020/01/04 20:34:38 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0104 20:34:42.666] 2020/01/04 20:34:42 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-04 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.30+7d04da8a4a80f2 bootstrap-e2e: exit status 1
W0104 20:34:42.671] Traceback (most recent call last):
W0104 20:34:42.671]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0104 20:34:42.672]     main(parse_args())
W0104 20:34:42.672]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0104 20:34:42.672]     mode.start(runner_args)
W0104 20:34:42.672]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0104 20:34:42.672]     check_env(env, self.command, *args)
W0104 20:34:42.673]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0104 20:34:42.673]     subprocess.check_call(cmd, env=env)
W0104 20:34:42.674]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0104 20:34:42.674]     raise CalledProcessError(retcode, cmd)
W0104 20:34:42.674] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-beta', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0104 20:34:42.678] Command failed
I0104 20:34:42.678] process 268 exited with code 1 after 3.3m
E0104 20:34:42.679] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta
I0104 20:34:42.679] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0104 20:34:43.282] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0104 20:34:43.340] process 1390 exited with code 0 after 0.0m
I0104 20:34:43.341] Call:  gcloud config get-value account
I0104 20:34:43.678] process 1403 exited with code 0 after 0.0m
I0104 20:34:43.679] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0104 20:34:43.679] Upload result and artifacts...
I0104 20:34:43.679] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1213558499884142595
I0104 20:34:43.679] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1213558499884142595/artifacts
W0104 20:34:44.600] CommandException: One or more URLs matched no objects.
E0104 20:34:44.705] Command failed
I0104 20:34:44.705] process 1416 exited with code 1 after 0.0m
W0104 20:34:44.706] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1213558499884142595/artifacts not exist yet
I0104 20:34:44.706] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1213558499884142595/artifacts
I0104 20:34:46.376] process 1561 exited with code 0 after 0.0m
I0104 20:34:46.377] Call:  git rev-parse HEAD
W0104 20:34:46.381] fatal: not a git repository (or any of the parent directories): .git
E0104 20:34:46.382] Command failed
I0104 20:34:46.382] process 2088 exited with code 128 after 0.0m
I0104 20:34:46.383] Call:  git rev-parse HEAD
I0104 20:34:46.387] process 2089 exited with code 0 after 0.0m
I0104 20:34:46.387] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json
I0104 20:34:47.367] process 2090 exited with code 0 after 0.0m
I0104 20:34:47.368] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json#1578126969823603'
... skipping 8 lines ...