This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-05 08:31
Elapsed3m40s
Revision
Buildergke-prow-ssd-pool-1a225945-qrg4
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/a231011d-0476-4e73-a7b4-2ec81d7d153a/targets/test'}}
poda37255b2-2f95-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/a231011d-0476-4e73-a7b4-2ec81d7d153a/targets/test
infra-commit235805981
job-versionv1.17.1-beta.0.30+7d04da8a4a80f2
poda37255b2-2f95-11ea-a07b-c6eb1bf16817
revisionv1.17.1-beta.0.30+7d04da8a4a80f2

Test Failures


Up 1m35s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.30+7d04da8a4a80f2 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0105 08:31:25.645] process 47 exited with code 0 after 0.0m
I0105 08:31:25.645] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0105 08:31:25.645] Root: /workspace
I0105 08:31:25.645] cd to /workspace
I0105 08:31:25.645] Configure environment...
I0105 08:31:25.646] Call:  git show -s --format=format:%ct HEAD
W0105 08:31:25.650] fatal: not a git repository (or any of the parent directories): .git
I0105 08:31:25.650] process 60 exited with code 128 after 0.0m
W0105 08:31:25.651] Unable to print commit date for HEAD
I0105 08:31:25.651] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0105 08:31:26.147] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0105 08:31:26.464] process 61 exited with code 0 after 0.0m
I0105 08:31:26.465] Call:  gcloud config get-value account
... skipping 426 lines ...
W0105 08:33:56.528] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0105 08:33:56.528] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0105 08:33:56.529] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0105 08:33:56.530] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0105 08:33:56.530] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0105 08:33:56.531] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0105 08:34:40.657] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0105 08:34:40.700] 2020/01/05 08:34:40 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.30+7d04da8a4a80f2 bootstrap-e2e' finished in 44.568345715s
W0105 08:34:42.212] 2020/01/05 08:34:42 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0105 08:34:57.104] 2020/01/05 08:34:57 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.30+7d04da8a4a80f2 bootstrap-e2e: exit status 1
W0105 08:34:57.108] Traceback (most recent call last):
W0105 08:34:57.108]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0105 08:34:57.108]     main(parse_args())
W0105 08:34:57.108]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0105 08:34:57.108]     mode.start(runner_args)
W0105 08:34:57.109]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0105 08:34:57.109]     check_env(env, self.command, *args)
W0105 08:34:57.109]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0105 08:34:57.109]     subprocess.check_call(cmd, env=env)
W0105 08:34:57.109]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0105 08:34:57.109]     raise CalledProcessError(retcode, cmd)
W0105 08:34:57.110] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-beta', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0105 08:34:57.117] Command failed
I0105 08:34:57.117] process 268 exited with code 1 after 3.5m
E0105 08:34:57.118] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta
I0105 08:34:57.118] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0105 08:34:57.604] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0105 08:34:57.651] process 1389 exited with code 0 after 0.0m
I0105 08:34:57.652] Call:  gcloud config get-value account
I0105 08:34:57.951] process 1402 exited with code 0 after 0.0m
I0105 08:34:57.951] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0105 08:34:57.951] Upload result and artifacts...
I0105 08:34:57.952] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1213739700339085317
I0105 08:34:57.952] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1213739700339085317/artifacts
W0105 08:34:58.731] CommandException: One or more URLs matched no objects.
E0105 08:34:58.825] Command failed
I0105 08:34:58.826] process 1415 exited with code 1 after 0.0m
W0105 08:34:58.826] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1213739700339085317/artifacts not exist yet
I0105 08:34:58.826] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1213739700339085317/artifacts
I0105 08:35:00.553] process 1560 exited with code 0 after 0.0m
I0105 08:35:00.554] Call:  git rev-parse HEAD
W0105 08:35:00.560] fatal: not a git repository (or any of the parent directories): .git
E0105 08:35:00.561] Command failed
I0105 08:35:00.561] process 2087 exited with code 128 after 0.0m
I0105 08:35:00.561] Call:  git rev-parse HEAD
I0105 08:35:00.568] process 2088 exited with code 0 after 0.0m
I0105 08:35:00.569] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json
I0105 08:35:01.769] process 2089 exited with code 0 after 0.0m
I0105 08:35:01.770] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json#1578170089725930'
... skipping 8 lines ...