This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-06 08:31
Elapsed3m30s
Revision
Buildergke-prow-ssd-pool-1a225945-s2ps
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/186600d2-724c-4e7d-861e-09fe09affcca/targets/test'}}
podce4a42cd-305e-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/186600d2-724c-4e7d-861e-09fe09affcca/targets/test
infra-commit6b50e8c07
job-versionv1.17.1-beta.0.30+7d04da8a4a80f2
podce4a42cd-305e-11ea-a07b-c6eb1bf16817
revisionv1.17.1-beta.0.30+7d04da8a4a80f2

Test Failures


Up 1m24s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.30+7d04da8a4a80f2 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0106 08:31:29.776] process 47 exited with code 0 after 0.0m
I0106 08:31:29.777] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0106 08:31:29.777] Root: /workspace
I0106 08:31:29.778] cd to /workspace
I0106 08:31:29.778] Configure environment...
I0106 08:31:29.778] Call:  git show -s --format=format:%ct HEAD
W0106 08:31:29.783] fatal: not a git repository (or any of the parent directories): .git
I0106 08:31:29.784] process 60 exited with code 128 after 0.0m
W0106 08:31:29.784] Unable to print commit date for HEAD
I0106 08:31:29.784] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0106 08:31:30.321] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0106 08:31:30.452] process 61 exited with code 0 after 0.0m
I0106 08:31:30.452] Call:  gcloud config get-value account
... skipping 426 lines ...
W0106 08:33:55.147] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0106 08:33:55.148] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0106 08:33:55.149] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0106 08:33:55.150] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0106 08:33:55.151] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0106 08:33:55.151] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0106 08:34:39.601] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0106 08:34:39.633] 2020/01/06 08:34:39 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.30+7d04da8a4a80f2 bootstrap-e2e' finished in 44.87953912s
W0106 08:34:41.141] 2020/01/06 08:34:41 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0106 08:34:51.363] 2020/01/06 08:34:51 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.30+7d04da8a4a80f2 bootstrap-e2e: exit status 1
W0106 08:34:51.369] Traceback (most recent call last):
W0106 08:34:51.369]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0106 08:34:51.370]     main(parse_args())
W0106 08:34:51.370]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0106 08:34:51.370]     mode.start(runner_args)
W0106 08:34:51.370]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0106 08:34:51.370]     check_env(env, self.command, *args)
W0106 08:34:51.370]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0106 08:34:51.371]     subprocess.check_call(cmd, env=env)
W0106 08:34:51.371]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0106 08:34:51.371]     raise CalledProcessError(retcode, cmd)
W0106 08:34:51.372] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-beta', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0106 08:34:51.380] Command failed
I0106 08:34:51.380] process 268 exited with code 1 after 3.3m
E0106 08:34:51.380] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta
I0106 08:34:51.381] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0106 08:34:51.882] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0106 08:34:51.929] process 1390 exited with code 0 after 0.0m
I0106 08:34:51.929] Call:  gcloud config get-value account
I0106 08:34:52.240] process 1403 exited with code 0 after 0.0m
I0106 08:34:52.240] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0106 08:34:52.240] Upload result and artifacts...
I0106 08:34:52.241] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1214102100699516928
I0106 08:34:52.241] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1214102100699516928/artifacts
W0106 08:34:53.062] CommandException: One or more URLs matched no objects.
E0106 08:34:53.176] Command failed
I0106 08:34:53.176] process 1416 exited with code 1 after 0.0m
W0106 08:34:53.177] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1214102100699516928/artifacts not exist yet
I0106 08:34:53.177] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1214102100699516928/artifacts
I0106 08:34:54.798] process 1561 exited with code 0 after 0.0m
I0106 08:34:54.798] Call:  git rev-parse HEAD
W0106 08:34:54.803] fatal: not a git repository (or any of the parent directories): .git
E0106 08:34:54.803] Command failed
I0106 08:34:54.803] process 2088 exited with code 128 after 0.0m
I0106 08:34:54.804] Call:  git rev-parse HEAD
I0106 08:34:54.808] process 2089 exited with code 0 after 0.0m
I0106 08:34:54.809] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json
I0106 08:34:55.741] process 2090 exited with code 0 after 0.0m
I0106 08:34:55.742] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json#1578256613971281'
... skipping 8 lines ...