This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-08 08:31
Elapsed4m8s
Revision
Buildergke-prow-default-pool-cf4891d4-e8h9
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/c3c339aa-1506-44ac-ab1f-eacc9f2f6e31/targets/test'}}
pod166cd644-31f1-11ea-9709-02f27a93e62e
resultstorehttps://source.cloud.google.com/results/invocations/c3c339aa-1506-44ac-ab1f-eacc9f2f6e31/targets/test
infra-commit82ee3dc23
job-versionv1.17.1-beta.0.40+f45fc1861acab2
pod166cd644-31f1-11ea-9709-02f27a93e62e
revisionv1.17.1-beta.0.40+f45fc1861acab2

Test Failures


Up 1m34s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.40+f45fc1861acab2 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0108 08:31:05.818] process 47 exited with code 0 after 0.0m
I0108 08:31:05.819] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0108 08:31:05.819] Root: /workspace
I0108 08:31:05.820] cd to /workspace
I0108 08:31:05.820] Configure environment...
I0108 08:31:05.820] Call:  git show -s --format=format:%ct HEAD
W0108 08:31:05.825] fatal: not a git repository (or any of the parent directories): .git
I0108 08:31:05.826] process 60 exited with code 128 after 0.0m
W0108 08:31:05.826] Unable to print commit date for HEAD
I0108 08:31:05.826] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0108 08:31:06.504] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0108 08:31:06.839] process 61 exited with code 0 after 0.0m
I0108 08:31:06.840] Call:  gcloud config get-value account
... skipping 426 lines ...
W0108 08:34:15.042] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0108 08:34:15.042] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0108 08:34:15.043] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0108 08:34:15.043] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0108 08:34:15.043] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0108 08:34:15.043] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0108 08:34:58.580] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0108 08:34:58.649] 2020/01/08 08:34:58 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.40+f45fc1861acab2 bootstrap-e2e' finished in 44.116447665s
W0108 08:35:00.496] 2020/01/08 08:35:00 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0108 08:35:03.854] 2020/01/08 08:35:03 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.40+f45fc1861acab2 bootstrap-e2e: exit status 1
W0108 08:35:03.860] Traceback (most recent call last):
W0108 08:35:03.860]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0108 08:35:03.860]     main(parse_args())
W0108 08:35:03.860]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0108 08:35:03.861]     mode.start(runner_args)
W0108 08:35:03.861]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0108 08:35:03.861]     check_env(env, self.command, *args)
W0108 08:35:03.861]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0108 08:35:03.861]     subprocess.check_call(cmd, env=env)
W0108 08:35:03.861]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0108 08:35:03.861]     raise CalledProcessError(retcode, cmd)
W0108 08:35:03.862] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-beta', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0108 08:35:03.872] Command failed
I0108 08:35:03.873] process 268 exited with code 1 after 3.9m
E0108 08:35:03.873] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta
I0108 08:35:03.873] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0108 08:35:04.455] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0108 08:35:04.515] process 1390 exited with code 0 after 0.0m
I0108 08:35:04.515] Call:  gcloud config get-value account
I0108 08:35:04.881] process 1403 exited with code 0 after 0.0m
I0108 08:35:04.881] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0108 08:35:04.881] Upload result and artifacts...
I0108 08:35:04.881] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1214826774437826561
I0108 08:35:04.882] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1214826774437826561/artifacts
W0108 08:35:05.990] CommandException: One or more URLs matched no objects.
E0108 08:35:06.166] Command failed
I0108 08:35:06.167] process 1416 exited with code 1 after 0.0m
W0108 08:35:06.167] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1214826774437826561/artifacts not exist yet
I0108 08:35:06.167] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1214826774437826561/artifacts
I0108 08:35:08.084] process 1561 exited with code 0 after 0.0m
I0108 08:35:08.085] Call:  git rev-parse HEAD
W0108 08:35:08.090] fatal: not a git repository (or any of the parent directories): .git
E0108 08:35:08.090] Command failed
I0108 08:35:08.090] process 2088 exited with code 128 after 0.0m
I0108 08:35:08.090] Call:  git rev-parse HEAD
I0108 08:35:08.096] process 2089 exited with code 0 after 0.0m
I0108 08:35:08.097] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json
I0108 08:35:09.244] process 2090 exited with code 0 after 0.0m
I0108 08:35:09.245] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json#1578429354094175'
... skipping 8 lines ...