This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-09 08:31
Elapsed3m35s
Revision
Buildergke-prow-default-pool-cf4891d4-mb35
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/b442be66-29b2-4341-a768-dbd7e55517be/targets/test'}}
pod42589917-32ba-11ea-9709-02f27a93e62e
resultstorehttps://source.cloud.google.com/results/invocations/b442be66-29b2-4341-a768-dbd7e55517be/targets/test
infra-commit3f347614f
job-versionv1.17.1-beta.0.46+4fe584afe8024e
pod42589917-32ba-11ea-9709-02f27a93e62e
revisionv1.17.1-beta.0.46+4fe584afe8024e

Test Failures


Up 1m28s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-06 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.46+4fe584afe8024e bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0109 08:31:02.148] process 47 exited with code 0 after 0.0m
I0109 08:31:02.148] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0109 08:31:02.149] Root: /workspace
I0109 08:31:02.149] cd to /workspace
I0109 08:31:02.149] Configure environment...
I0109 08:31:02.149] Call:  git show -s --format=format:%ct HEAD
W0109 08:31:02.152] fatal: not a git repository (or any of the parent directories): .git
I0109 08:31:02.153] process 60 exited with code 128 after 0.0m
W0109 08:31:02.153] Unable to print commit date for HEAD
I0109 08:31:02.153] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0109 08:31:02.589] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0109 08:31:02.913] process 61 exited with code 0 after 0.0m
I0109 08:31:02.914] Call:  gcloud config get-value account
... skipping 426 lines ...
W0109 08:33:28.320] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0109 08:33:28.320] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0109 08:33:28.321] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0109 08:33:28.321] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0109 08:33:28.321] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0109 08:33:28.322] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0109 08:34:12.693] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0109 08:34:12.728] 2020/01/09 08:34:12 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-06 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.46+4fe584afe8024e bootstrap-e2e' finished in 44.796593919s
W0109 08:34:14.110] 2020/01/09 08:34:14 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0109 08:34:30.396] 2020/01/09 08:34:30 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-06 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.46+4fe584afe8024e bootstrap-e2e: exit status 1
W0109 08:34:30.399] Traceback (most recent call last):
W0109 08:34:30.399]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0109 08:34:30.399]     main(parse_args())
W0109 08:34:30.400]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0109 08:34:30.400]     mode.start(runner_args)
W0109 08:34:30.400]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0109 08:34:30.400]     check_env(env, self.command, *args)
W0109 08:34:30.400]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0109 08:34:30.400]     subprocess.check_call(cmd, env=env)
W0109 08:34:30.401]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0109 08:34:30.401]     raise CalledProcessError(retcode, cmd)
W0109 08:34:30.401] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-beta', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0109 08:34:30.407] Command failed
I0109 08:34:30.408] process 268 exited with code 1 after 3.4m
E0109 08:34:30.408] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta
I0109 08:34:30.408] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0109 08:34:30.840] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0109 08:34:30.879] process 1390 exited with code 0 after 0.0m
I0109 08:34:30.879] Call:  gcloud config get-value account
I0109 08:34:31.142] process 1403 exited with code 0 after 0.0m
I0109 08:34:31.143] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0109 08:34:31.143] Upload result and artifacts...
I0109 08:34:31.143] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1215189167017824259
I0109 08:34:31.143] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1215189167017824259/artifacts
W0109 08:34:31.855] CommandException: One or more URLs matched no objects.
E0109 08:34:31.942] Command failed
I0109 08:34:31.942] process 1416 exited with code 1 after 0.0m
W0109 08:34:31.943] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1215189167017824259/artifacts not exist yet
I0109 08:34:31.943] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1215189167017824259/artifacts
I0109 08:34:33.180] process 1561 exited with code 0 after 0.0m
I0109 08:34:33.181] Call:  git rev-parse HEAD
W0109 08:34:33.184] fatal: not a git repository (or any of the parent directories): .git
E0109 08:34:33.185] Command failed
I0109 08:34:33.185] process 2088 exited with code 128 after 0.0m
I0109 08:34:33.185] Call:  git rev-parse HEAD
I0109 08:34:33.189] process 2089 exited with code 0 after 0.0m
I0109 08:34:33.189] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json
I0109 08:34:33.991] process 2090 exited with code 0 after 0.0m
I0109 08:34:33.992] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json#1578515727211620'
... skipping 8 lines ...