This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-11 08:31
Elapsed4m25s
Revision
Buildergke-prow-default-pool-cf4891d4-mrkw
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/66c2a98d-1d42-476d-a0cc-5887523e3435/targets/test'}}
poda0d7ba9a-344c-11ea-9fef-d200904e1a96
resultstorehttps://source.cloud.google.com/results/invocations/66c2a98d-1d42-476d-a0cc-5887523e3435/targets/test
infra-commitb82ca85d5
job-versionv1.17.1-beta.0.52+d224476cd0730b
poda0d7ba9a-344c-11ea-9fef-d200904e1a96
revisionv1.17.1-beta.0.52+d224476cd0730b

Test Failures


Up 1m31s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.52+d224476cd0730b bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0111 08:31:13.145] process 47 exited with code 0 after 0.0m
I0111 08:31:13.146] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0111 08:31:13.146] Root: /workspace
I0111 08:31:13.146] cd to /workspace
I0111 08:31:13.146] Configure environment...
I0111 08:31:13.146] Call:  git show -s --format=format:%ct HEAD
W0111 08:31:13.152] fatal: not a git repository (or any of the parent directories): .git
I0111 08:31:13.152] process 60 exited with code 128 after 0.0m
W0111 08:31:13.153] Unable to print commit date for HEAD
I0111 08:31:13.153] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0111 08:31:13.738] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0111 08:31:14.084] process 61 exited with code 0 after 0.0m
I0111 08:31:14.084] Call:  gcloud config get-value account
... skipping 426 lines ...
W0111 08:34:16.354] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0111 08:34:16.354] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0111 08:34:16.355] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0111 08:34:16.355] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0111 08:34:16.355] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0111 08:34:16.355] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0111 08:34:57.518] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0111 08:34:57.573] 2020/01/11 08:34:57 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.52+d224476cd0730b bootstrap-e2e' finished in 41.757194544s
W0111 08:34:59.266] 2020/01/11 08:34:59 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0111 08:35:29.183] 2020/01/11 08:35:29 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.52+d224476cd0730b bootstrap-e2e: exit status 1
W0111 08:35:29.188] Traceback (most recent call last):
W0111 08:35:29.188]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0111 08:35:29.188]     main(parse_args())
W0111 08:35:29.189]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0111 08:35:29.189]     mode.start(runner_args)
W0111 08:35:29.189]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0111 08:35:29.189]     check_env(env, self.command, *args)
W0111 08:35:29.189]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0111 08:35:29.189]     subprocess.check_call(cmd, env=env)
W0111 08:35:29.190]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0111 08:35:29.190]     raise CalledProcessError(retcode, cmd)
W0111 08:35:29.190] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-beta', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0111 08:35:29.199] Command failed
I0111 08:35:29.200] process 268 exited with code 1 after 4.2m
E0111 08:35:29.200] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta
I0111 08:35:29.200] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0111 08:35:29.768] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0111 08:35:29.825] process 1391 exited with code 0 after 0.0m
I0111 08:35:29.826] Call:  gcloud config get-value account
I0111 08:35:30.193] process 1404 exited with code 0 after 0.0m
I0111 08:35:30.194] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0111 08:35:30.194] Upload result and artifacts...
I0111 08:35:30.194] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1215913976437673988
I0111 08:35:30.194] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1215913976437673988/artifacts
W0111 08:35:31.156] CommandException: One or more URLs matched no objects.
E0111 08:35:31.289] Command failed
I0111 08:35:31.289] process 1417 exited with code 1 after 0.0m
W0111 08:35:31.289] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1215913976437673988/artifacts not exist yet
I0111 08:35:31.289] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1215913976437673988/artifacts
I0111 08:35:33.115] process 1562 exited with code 0 after 0.0m
I0111 08:35:33.116] Call:  git rev-parse HEAD
W0111 08:35:33.121] fatal: not a git repository (or any of the parent directories): .git
E0111 08:35:33.121] Command failed
I0111 08:35:33.121] process 2089 exited with code 128 after 0.0m
I0111 08:35:33.121] Call:  git rev-parse HEAD
I0111 08:35:33.128] process 2090 exited with code 0 after 0.0m
I0111 08:35:33.128] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json
I0111 08:35:34.226] process 2091 exited with code 0 after 0.0m
I0111 08:35:34.226] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json#1578688641463741'
... skipping 8 lines ...