This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-11 20:31
Elapsed3m43s
Revision
Buildergke-prow-default-pool-cf4891d4-k2ps
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/d5d32b16-0b68-4135-b3f2-db453027233e/targets/test'}}
pod354b1d6a-34b1-11ea-9fef-d200904e1a96
resultstorehttps://source.cloud.google.com/results/invocations/d5d32b16-0b68-4135-b3f2-db453027233e/targets/test
infra-commitb82ca85d5
job-versionv1.17.1-beta.0.52+d224476cd0730b
pod354b1d6a-34b1-11ea-9fef-d200904e1a96
revisionv1.17.1-beta.0.52+d224476cd0730b

Test Failures


Up 1m22s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-06 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.52+d224476cd0730b bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0111 20:31:10.969] process 47 exited with code 0 after 0.0m
I0111 20:31:10.970] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0111 20:31:10.970] Root: /workspace
I0111 20:31:10.970] cd to /workspace
I0111 20:31:10.970] Configure environment...
I0111 20:31:10.971] Call:  git show -s --format=format:%ct HEAD
W0111 20:31:10.976] fatal: not a git repository (or any of the parent directories): .git
I0111 20:31:10.976] process 60 exited with code 128 after 0.0m
W0111 20:31:10.976] Unable to print commit date for HEAD
I0111 20:31:10.977] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0111 20:31:11.579] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0111 20:31:11.956] process 61 exited with code 0 after 0.0m
I0111 20:31:11.956] Call:  gcloud config get-value account
... skipping 426 lines ...
W0111 20:33:52.530] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0111 20:33:52.531] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0111 20:33:52.531] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0111 20:33:52.531] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0111 20:33:52.531] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0111 20:33:52.532] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0111 20:34:35.377] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0111 20:34:35.473] 2020/01/11 20:34:35 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-06 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.52+d224476cd0730b bootstrap-e2e' finished in 43.415265466s
W0111 20:34:37.390] 2020/01/11 20:34:37 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0111 20:34:41.915] 2020/01/11 20:34:41 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-06 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.52+d224476cd0730b bootstrap-e2e: exit status 1
W0111 20:34:41.920] Traceback (most recent call last):
W0111 20:34:41.920]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0111 20:34:41.920]     main(parse_args())
W0111 20:34:41.921]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0111 20:34:41.921]     mode.start(runner_args)
W0111 20:34:41.921]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0111 20:34:41.921]     check_env(env, self.command, *args)
W0111 20:34:41.921]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0111 20:34:41.921]     subprocess.check_call(cmd, env=env)
W0111 20:34:41.922]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0111 20:34:41.922]     raise CalledProcessError(retcode, cmd)
W0111 20:34:41.922] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-beta', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0111 20:34:41.933] Command failed
I0111 20:34:41.933] process 268 exited with code 1 after 3.5m
E0111 20:34:41.933] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta
I0111 20:34:41.934] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0111 20:34:42.577] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0111 20:34:42.648] process 1391 exited with code 0 after 0.0m
I0111 20:34:42.648] Call:  gcloud config get-value account
I0111 20:34:43.066] process 1404 exited with code 0 after 0.0m
I0111 20:34:43.067] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0111 20:34:43.067] Upload result and artifacts...
I0111 20:34:43.067] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1216095163340820481
I0111 20:34:43.068] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1216095163340820481/artifacts
W0111 20:34:44.368] CommandException: One or more URLs matched no objects.
E0111 20:34:44.527] Command failed
I0111 20:34:44.527] process 1417 exited with code 1 after 0.0m
W0111 20:34:44.528] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1216095163340820481/artifacts not exist yet
I0111 20:34:44.528] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1216095163340820481/artifacts
I0111 20:34:47.502] process 1562 exited with code 0 after 0.0m
I0111 20:34:47.502] Call:  git rev-parse HEAD
W0111 20:34:47.511] fatal: not a git repository (or any of the parent directories): .git
E0111 20:34:47.512] Command failed
I0111 20:34:47.512] process 2089 exited with code 128 after 0.0m
I0111 20:34:47.512] Call:  git rev-parse HEAD
I0111 20:34:47.521] process 2090 exited with code 0 after 0.0m
I0111 20:34:47.522] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json
I0111 20:34:49.295] process 2091 exited with code 0 after 0.0m
I0111 20:34:49.296] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json#1578731736788666'
... skipping 8 lines ...