This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-12 08:31
Elapsed3m26s
Revision
Buildergke-prow-default-pool-cf4891d4-7178
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/2ad730d2-cfa2-4056-8f82-b94faf7886c4/targets/test'}}
podc9b229a2-3515-11ea-9fef-d200904e1a96
resultstorehttps://source.cloud.google.com/results/invocations/2ad730d2-cfa2-4056-8f82-b94faf7886c4/targets/test
infra-commitb82ca85d5
job-versionv1.17.1-beta.0.52+d224476cd0730b
podc9b229a2-3515-11ea-9fef-d200904e1a96
revisionv1.17.1-beta.0.52+d224476cd0730b

Test Failures


Up 1m30s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.52+d224476cd0730b bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0112 08:31:09.326] process 47 exited with code 0 after 0.0m
I0112 08:31:09.327] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0112 08:31:09.327] Root: /workspace
I0112 08:31:09.327] cd to /workspace
I0112 08:31:09.327] Configure environment...
I0112 08:31:09.328] Call:  git show -s --format=format:%ct HEAD
W0112 08:31:09.332] fatal: not a git repository (or any of the parent directories): .git
I0112 08:31:09.332] process 60 exited with code 128 after 0.0m
W0112 08:31:09.332] Unable to print commit date for HEAD
I0112 08:31:09.333] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0112 08:31:09.886] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0112 08:31:10.199] process 61 exited with code 0 after 0.0m
I0112 08:31:10.200] Call:  gcloud config get-value account
... skipping 426 lines ...
W0112 08:33:42.075] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0112 08:33:42.075] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0112 08:33:42.075] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0112 08:33:42.076] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0112 08:33:42.076] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0112 08:33:42.076] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0112 08:34:21.639] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0112 08:34:21.693] 2020/01/12 08:34:21 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.52+d224476cd0730b bootstrap-e2e' finished in 40.093092725s
W0112 08:34:23.374] 2020/01/12 08:34:23 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0112 08:34:26.815] 2020/01/12 08:34:26 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.52+d224476cd0730b bootstrap-e2e: exit status 1
W0112 08:34:26.819] Traceback (most recent call last):
W0112 08:34:26.819]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0112 08:34:26.822]     main(parse_args())
W0112 08:34:26.822]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0112 08:34:26.822]     mode.start(runner_args)
W0112 08:34:26.823]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0112 08:34:26.823]     check_env(env, self.command, *args)
W0112 08:34:26.823]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0112 08:34:26.823]     subprocess.check_call(cmd, env=env)
W0112 08:34:26.823]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0112 08:34:26.823]     raise CalledProcessError(retcode, cmd)
W0112 08:34:26.824] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-beta', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0112 08:34:26.832] Command failed
I0112 08:34:26.832] process 268 exited with code 1 after 3.2m
E0112 08:34:26.832] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta
I0112 08:34:26.832] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0112 08:34:27.378] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0112 08:34:27.434] process 1391 exited with code 0 after 0.0m
I0112 08:34:27.434] Call:  gcloud config get-value account
I0112 08:34:27.821] process 1404 exited with code 0 after 0.0m
I0112 08:34:27.821] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0112 08:34:27.821] Upload result and artifacts...
I0112 08:34:27.821] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1216276351833608194
I0112 08:34:27.822] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1216276351833608194/artifacts
W0112 08:34:28.814] CommandException: One or more URLs matched no objects.
E0112 08:34:28.949] Command failed
I0112 08:34:28.950] process 1417 exited with code 1 after 0.0m
W0112 08:34:28.950] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1216276351833608194/artifacts not exist yet
I0112 08:34:28.950] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1216276351833608194/artifacts
I0112 08:34:30.856] process 1562 exited with code 0 after 0.0m
I0112 08:34:30.857] Call:  git rev-parse HEAD
W0112 08:34:30.861] fatal: not a git repository (or any of the parent directories): .git
E0112 08:34:30.862] Command failed
I0112 08:34:30.862] process 2089 exited with code 128 after 0.0m
I0112 08:34:30.862] Call:  git rev-parse HEAD
I0112 08:34:30.868] process 2090 exited with code 0 after 0.0m
I0112 08:34:30.869] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json
I0112 08:34:31.919] process 2091 exited with code 0 after 0.0m
I0112 08:34:31.919] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json#1578774892391324'
... skipping 8 lines ...