This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-13 08:31
Elapsed4m5s
Revision
Buildergke-prow-default-pool-cf4891d4-r4zq
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/85713efb-3037-4057-9324-bcb81ccb63a2/targets/test'}}
podf389e1d9-35de-11ea-9fef-d200904e1a96
resultstorehttps://source.cloud.google.com/results/invocations/85713efb-3037-4057-9324-bcb81ccb63a2/targets/test
infra-commitd6212fa62
job-versionv1.17.1-beta.0.52+d224476cd0730b
podf389e1d9-35de-11ea-9fef-d200904e1a96
revisionv1.17.1-beta.0.52+d224476cd0730b

Test Failures


Up 1m42s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.52+d224476cd0730b bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0113 08:31:10.805] process 47 exited with code 0 after 0.0m
I0113 08:31:10.806] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0113 08:31:10.806] Root: /workspace
I0113 08:31:10.806] cd to /workspace
I0113 08:31:10.806] Configure environment...
I0113 08:31:10.806] Call:  git show -s --format=format:%ct HEAD
W0113 08:31:10.811] fatal: not a git repository (or any of the parent directories): .git
I0113 08:31:10.811] process 60 exited with code 128 after 0.0m
W0113 08:31:10.811] Unable to print commit date for HEAD
I0113 08:31:10.811] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0113 08:31:11.436] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0113 08:31:11.756] process 61 exited with code 0 after 0.0m
I0113 08:31:11.756] Call:  gcloud config get-value account
... skipping 426 lines ...
W0113 08:34:14.599] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0113 08:34:14.599] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0113 08:34:14.600] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0113 08:34:14.600] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0113 08:34:14.600] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0113 08:34:14.601] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0113 08:35:01.209] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0113 08:35:01.266] 2020/01/13 08:35:01 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.52+d224476cd0730b bootstrap-e2e' finished in 47.120913267s
W0113 08:35:02.962] 2020/01/13 08:35:02 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0113 08:35:05.942] 2020/01/13 08:35:05 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.52+d224476cd0730b bootstrap-e2e: exit status 1
W0113 08:35:05.945] Traceback (most recent call last):
W0113 08:35:05.945]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0113 08:35:05.945]     main(parse_args())
W0113 08:35:05.945]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0113 08:35:05.945]     mode.start(runner_args)
W0113 08:35:05.946]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0113 08:35:05.946]     check_env(env, self.command, *args)
W0113 08:35:05.946]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0113 08:35:05.946]     subprocess.check_call(cmd, env=env)
W0113 08:35:05.946]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0113 08:35:05.947]     raise CalledProcessError(retcode, cmd)
W0113 08:35:05.947] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-beta', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0113 08:35:05.955] Command failed
I0113 08:35:05.955] process 268 exited with code 1 after 3.9m
E0113 08:35:05.955] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta
I0113 08:35:05.955] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0113 08:35:06.529] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0113 08:35:06.591] process 1388 exited with code 0 after 0.0m
I0113 08:35:06.592] Call:  gcloud config get-value account
I0113 08:35:07.013] process 1401 exited with code 0 after 0.0m
I0113 08:35:07.013] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0113 08:35:07.014] Upload result and artifacts...
I0113 08:35:07.014] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1216638735341326345
I0113 08:35:07.014] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1216638735341326345/artifacts
W0113 08:35:08.349] CommandException: One or more URLs matched no objects.
E0113 08:35:08.513] Command failed
I0113 08:35:08.513] process 1414 exited with code 1 after 0.0m
W0113 08:35:08.514] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1216638735341326345/artifacts not exist yet
I0113 08:35:08.514] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1216638735341326345/artifacts
I0113 08:35:10.438] process 1559 exited with code 0 after 0.0m
I0113 08:35:10.439] Call:  git rev-parse HEAD
W0113 08:35:10.443] fatal: not a git repository (or any of the parent directories): .git
E0113 08:35:10.444] Command failed
I0113 08:35:10.444] process 2086 exited with code 128 after 0.0m
I0113 08:35:10.444] Call:  git rev-parse HEAD
I0113 08:35:10.449] process 2087 exited with code 0 after 0.0m
I0113 08:35:10.449] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json
I0113 08:35:11.532] process 2088 exited with code 0 after 0.0m
I0113 08:35:11.533] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json#1578861346346740'
... skipping 8 lines ...