This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-14 20:31
Elapsed4m50s
Revision
Buildergke-prow-default-pool-cf4891d4-sql7
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/2109ba0a-3353-4e6f-b3c1-87f14660cb3a/targets/test'}}
podb74157ef-370c-11ea-9f20-3687633bf296
resultstorehttps://source.cloud.google.com/results/invocations/2109ba0a-3353-4e6f-b3c1-87f14660cb3a/targets/test
infra-commitdd3ff6d1a
job-versionv1.17.1-beta.0.52+d224476cd0730b
podb74157ef-370c-11ea-9f20-3687633bf296
revisionv1.17.1-beta.0.52+d224476cd0730b

Test Failures


Up 52s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.52+d224476cd0730b bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0114 20:31:36.749] process 47 exited with code 0 after 0.0m
I0114 20:31:36.749] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0114 20:31:36.750] Root: /workspace
I0114 20:31:36.750] cd to /workspace
I0114 20:31:36.750] Configure environment...
I0114 20:31:36.750] Call:  git show -s --format=format:%ct HEAD
W0114 20:31:36.759] fatal: not a git repository (or any of the parent directories): .git
I0114 20:31:36.759] process 60 exited with code 128 after 0.0m
W0114 20:31:36.759] Unable to print commit date for HEAD
I0114 20:31:36.760] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0114 20:31:37.981] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0114 20:31:38.256] process 61 exited with code 0 after 0.0m
I0114 20:31:38.257] Call:  gcloud config get-value account
... skipping 426 lines ...
W0114 20:35:55.896] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0114 20:35:55.898] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0114 20:35:55.900] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0114 20:35:55.901] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0114 20:35:55.903] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0114 20:35:55.905] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0114 20:35:56.133] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0114 20:35:56.209] 2020/01/14 20:35:56 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.52+d224476cd0730b bootstrap-e2e' finished in 1.195296965s
W0114 20:35:58.392] 2020/01/14 20:35:58 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0114 20:36:11.897] 2020/01/14 20:36:11 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.1-beta.0.52+d224476cd0730b bootstrap-e2e: exit status 1
W0114 20:36:11.901] Traceback (most recent call last):
W0114 20:36:11.902]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0114 20:36:11.902]     main(parse_args())
W0114 20:36:11.902]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0114 20:36:11.903]     mode.start(runner_args)
W0114 20:36:11.903]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0114 20:36:11.903]     check_env(env, self.command, *args)
W0114 20:36:11.904]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0114 20:36:11.904]     subprocess.check_call(cmd, env=env)
W0114 20:36:11.905]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0114 20:36:11.905]     raise CalledProcessError(retcode, cmd)
W0114 20:36:11.906] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-beta', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0114 20:36:11.917] Command failed
I0114 20:36:11.917] process 268 exited with code 1 after 4.5m
E0114 20:36:11.917] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta
I0114 20:36:11.917] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0114 20:36:12.760] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0114 20:36:12.829] process 1387 exited with code 0 after 0.0m
I0114 20:36:12.830] Call:  gcloud config get-value account
I0114 20:36:13.434] process 1400 exited with code 0 after 0.0m
I0114 20:36:13.434] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0114 20:36:13.435] Upload result and artifacts...
I0114 20:36:13.435] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1217182348978688002
I0114 20:36:13.435] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1217182348978688002/artifacts
W0114 20:36:14.805] CommandException: One or more URLs matched no objects.
E0114 20:36:15.081] Command failed
I0114 20:36:15.081] process 1413 exited with code 1 after 0.0m
W0114 20:36:15.081] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1217182348978688002/artifacts not exist yet
I0114 20:36:15.081] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1217182348978688002/artifacts
I0114 20:36:17.983] process 1558 exited with code 0 after 0.0m
I0114 20:36:17.984] Call:  git rev-parse HEAD
W0114 20:36:17.993] fatal: not a git repository (or any of the parent directories): .git
E0114 20:36:17.993] Command failed
I0114 20:36:17.993] process 2085 exited with code 128 after 0.0m
I0114 20:36:17.993] Call:  git rev-parse HEAD
I0114 20:36:18.002] process 2086 exited with code 0 after 0.0m
I0114 20:36:18.003] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json
I0114 20:36:20.027] process 2087 exited with code 0 after 0.0m
I0114 20:36:20.028] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json#1578990910648789'
... skipping 8 lines ...