This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-15 08:30
Elapsed3m23s
Revision
Buildergke-prow-default-pool-cf4891d4-7vfm
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/194aa0b1-0d8b-4cf1-8c13-400b814c3c77/targets/test'}}
pod3a452f6d-3771-11ea-8603-da2f7a5855b4
resultstorehttps://source.cloud.google.com/results/invocations/194aa0b1-0d8b-4cf1-8c13-400b814c3c77/targets/test
infra-commit055aa0643
job-versionv1.17.2-beta.0
pod3a452f6d-3771-11ea-8603-da2f7a5855b4
revisionv1.17.2-beta.0

Test Failures


Up 1m7s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.2-beta.0 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0115 08:30:52.335] process 47 exited with code 0 after 0.0m
I0115 08:30:52.336] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0115 08:30:52.336] Root: /workspace
I0115 08:30:52.336] cd to /workspace
I0115 08:30:52.336] Configure environment...
I0115 08:30:52.337] Call:  git show -s --format=format:%ct HEAD
W0115 08:30:52.341] fatal: not a git repository (or any of the parent directories): .git
I0115 08:30:52.341] process 60 exited with code 128 after 0.0m
W0115 08:30:52.341] Unable to print commit date for HEAD
I0115 08:30:52.342] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0115 08:30:52.911] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0115 08:30:53.259] process 61 exited with code 0 after 0.0m
I0115 08:30:53.259] Call:  gcloud config get-value account
... skipping 426 lines ...
W0115 08:34:00.350] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0115 08:34:00.350] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0115 08:34:00.351] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0115 08:34:00.351] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0115 08:34:00.351] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0115 08:34:00.351] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0115 08:34:00.432] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0115 08:34:00.483] 2020/01/15 08:34:00 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.2-beta.0 bootstrap-e2e' finished in 590.114867ms
W0115 08:34:01.561] 2020/01/15 08:34:01 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0115 08:34:07.005] 2020/01/15 08:34:07 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.2-beta.0 bootstrap-e2e: exit status 1
W0115 08:34:07.008] Traceback (most recent call last):
W0115 08:34:07.008]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0115 08:34:07.008]     main(parse_args())
W0115 08:34:07.009]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0115 08:34:07.009]     mode.start(runner_args)
W0115 08:34:07.009]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0115 08:34:07.009]     check_env(env, self.command, *args)
W0115 08:34:07.010]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0115 08:34:07.010]     subprocess.check_call(cmd, env=env)
W0115 08:34:07.010]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0115 08:34:07.010]     raise CalledProcessError(retcode, cmd)
W0115 08:34:07.011] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-beta', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0115 08:34:07.018] Command failed
I0115 08:34:07.019] process 268 exited with code 1 after 3.2m
E0115 08:34:07.019] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta
I0115 08:34:07.019] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0115 08:34:07.516] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0115 08:34:07.569] process 1392 exited with code 0 after 0.0m
I0115 08:34:07.569] Call:  gcloud config get-value account
I0115 08:34:07.890] process 1405 exited with code 0 after 0.0m
I0115 08:34:07.891] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0115 08:34:07.891] Upload result and artifacts...
I0115 08:34:07.891] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1217363437265358852
I0115 08:34:07.892] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1217363437265358852/artifacts
W0115 08:34:08.742] CommandException: One or more URLs matched no objects.
E0115 08:34:08.859] Command failed
I0115 08:34:08.859] process 1418 exited with code 1 after 0.0m
W0115 08:34:08.859] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1217363437265358852/artifacts not exist yet
I0115 08:34:08.860] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1217363437265358852/artifacts
I0115 08:34:10.538] process 1563 exited with code 0 after 0.0m
I0115 08:34:10.539] Call:  git rev-parse HEAD
W0115 08:34:10.543] fatal: not a git repository (or any of the parent directories): .git
E0115 08:34:10.543] Command failed
I0115 08:34:10.543] process 2090 exited with code 128 after 0.0m
I0115 08:34:10.543] Call:  git rev-parse HEAD
I0115 08:34:10.547] process 2091 exited with code 0 after 0.0m
I0115 08:34:10.548] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json
I0115 08:34:11.458] process 2092 exited with code 0 after 0.0m
I0115 08:34:11.459] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json#1579034183783062'
... skipping 8 lines ...