This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-15 20:30
Elapsed3m12s
Revision
Buildergke-prow-default-pool-cf4891d4-z214
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/c9936669-d5c9-4aef-ad8b-152cdf7141cb/targets/test'}}
podd2035c14-37d5-11ea-8f3e-66e48c863062
resultstorehttps://source.cloud.google.com/results/invocations/c9936669-d5c9-4aef-ad8b-152cdf7141cb/targets/test
infra-commita421008f6
job-versionv1.17.2-beta.0
podd2035c14-37d5-11ea-8f3e-66e48c863062
revisionv1.17.2-beta.0

Test Failures


Up 1m6s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus-beta --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.2-beta.0 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0115 20:30:47.800] process 47 exited with code 0 after 0.0m
I0115 20:30:47.801] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0115 20:30:47.801] Root: /workspace
I0115 20:30:47.802] cd to /workspace
I0115 20:30:47.802] Configure environment...
I0115 20:30:47.802] Call:  git show -s --format=format:%ct HEAD
W0115 20:30:47.806] fatal: not a git repository (or any of the parent directories): .git
I0115 20:30:47.807] process 60 exited with code 128 after 0.0m
W0115 20:30:47.807] Unable to print commit date for HEAD
I0115 20:30:47.807] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0115 20:30:48.349] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0115 20:30:48.670] process 61 exited with code 0 after 0.0m
I0115 20:30:48.670] Call:  gcloud config get-value account
... skipping 426 lines ...
W0115 20:33:43.598] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0115 20:33:43.599] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0115 20:33:43.599] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0115 20:33:43.600] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0115 20:33:43.600] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0115 20:33:43.601] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0115 20:33:43.671] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0115 20:33:43.723] 2020/01/15 20:33:43 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus-beta --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.2-beta.0 bootstrap-e2e' finished in 617.597061ms
W0115 20:33:44.881] 2020/01/15 20:33:44 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0115 20:33:49.744] 2020/01/15 20:33:49 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus-beta --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.2-beta.0 bootstrap-e2e: exit status 1
W0115 20:33:49.770] Traceback (most recent call last):
W0115 20:33:49.770]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0115 20:33:49.770]     main(parse_args())
W0115 20:33:49.771]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0115 20:33:49.771]     mode.start(runner_args)
W0115 20:33:49.771]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0115 20:33:49.771]     check_env(env, self.command, *args)
W0115 20:33:49.771]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0115 20:33:49.772]     subprocess.check_call(cmd, env=env)
W0115 20:33:49.772]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0115 20:33:49.772]     raise CalledProcessError(retcode, cmd)
W0115 20:33:49.773] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-beta', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0115 20:33:49.773] Command failed
I0115 20:33:49.773] process 268 exited with code 1 after 3.0m
E0115 20:33:49.773] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta
I0115 20:33:49.774] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0115 20:33:50.432] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0115 20:33:50.497] process 1390 exited with code 0 after 0.0m
I0115 20:33:50.497] Call:  gcloud config get-value account
I0115 20:33:50.982] process 1403 exited with code 0 after 0.0m
I0115 20:33:50.983] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0115 20:33:50.983] Upload result and artifacts...
I0115 20:33:50.983] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1217544623979761668
I0115 20:33:50.984] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1217544623979761668/artifacts
W0115 20:33:52.148] CommandException: One or more URLs matched no objects.
E0115 20:33:52.300] Command failed
I0115 20:33:52.300] process 1416 exited with code 1 after 0.0m
W0115 20:33:52.300] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1217544623979761668/artifacts not exist yet
I0115 20:33:52.301] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/1217544623979761668/artifacts
I0115 20:33:54.045] process 1561 exited with code 0 after 0.0m
I0115 20:33:54.046] Call:  git rev-parse HEAD
W0115 20:33:54.050] fatal: not a git repository (or any of the parent directories): .git
E0115 20:33:54.050] Command failed
I0115 20:33:54.051] process 2088 exited with code 128 after 0.0m
I0115 20:33:54.051] Call:  git rev-parse HEAD
I0115 20:33:54.056] process 2089 exited with code 0 after 0.0m
I0115 20:33:54.056] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json
I0115 20:33:55.163] process 2090 exited with code 0 after 0.0m
I0115 20:33:55.164] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-beta/jobResultsCache.json#1579077253787918'
... skipping 8 lines ...