This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-12-29 00:00
Elapsed3m29s
Revision
Buildergke-prow-ssd-pool-1a225945-3t17
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/61e75a03-c0f4-4529-ab68-12620b4af0d3/targets/test'}}
pod3415bc81-29ce-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/61e75a03-c0f4-4529-ab68-12620b4af0d3/targets/test
infra-commit09d9247dc
job-versionv1.16.5-beta.1.37+5a9078c6025b30
pod3415bc81-29ce-11ea-a07b-c6eb1bf16817
revisionv1.16.5-beta.1.37+5a9078c6025b30

Test Failures


Up 1m27s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-10 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1229 00:00:58.163] process 47 exited with code 0 after 0.0m
I1229 00:00:58.163] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1229 00:00:58.163] Root: /workspace
I1229 00:00:58.163] cd to /workspace
I1229 00:00:58.163] Configure environment...
I1229 00:00:58.164] Call:  git show -s --format=format:%ct HEAD
W1229 00:00:58.167] fatal: not a git repository (or any of the parent directories): .git
I1229 00:00:58.167] process 60 exited with code 128 after 0.0m
W1229 00:00:58.168] Unable to print commit date for HEAD
I1229 00:00:58.168] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1229 00:00:58.665] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1229 00:00:59.002] process 61 exited with code 0 after 0.0m
I1229 00:00:59.002] Call:  gcloud config get-value account
... skipping 426 lines ...
W1229 00:03:23.746] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1229 00:03:23.747] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W1229 00:03:23.748] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1229 00:03:23.748] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1229 00:03:23.749] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1229 00:03:23.749] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1229 00:04:05.223] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1229 00:04:05.282] 2019/12/29 00:04:05 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-10 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e' finished in 42.03152369s
W1229 00:04:07.283] 2019/12/29 00:04:07 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1229 00:04:14.723] 2019/12/29 00:04:14 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-10 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e: exit status 1
W1229 00:04:14.724] Traceback (most recent call last):
W1229 00:04:14.724]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1229 00:04:14.724]     main(parse_args())
W1229 00:04:14.724]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1229 00:04:14.724]     mode.start(runner_args)
W1229 00:04:14.725]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1229 00:04:14.725]     check_env(env, self.command, *args)
W1229 00:04:14.725]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1229 00:04:14.725]     subprocess.check_call(cmd, env=env)
W1229 00:04:14.725]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1229 00:04:14.725]     raise CalledProcessError(retcode, cmd)
W1229 00:04:14.728] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable1', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1229 00:04:14.735] Command failed
I1229 00:04:14.736] process 268 exited with code 1 after 3.2m
E1229 00:04:14.736] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1
I1229 00:04:14.736] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1229 00:04:15.601] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1229 00:04:15.672] process 1389 exited with code 0 after 0.0m
I1229 00:04:15.673] Call:  gcloud config get-value account
I1229 00:04:16.328] process 1402 exited with code 0 after 0.0m
I1229 00:04:16.329] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1229 00:04:16.329] Upload result and artifacts...
I1229 00:04:16.329] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1211074518253047810
I1229 00:04:16.330] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1211074518253047810/artifacts
W1229 00:04:17.753] CommandException: One or more URLs matched no objects.
E1229 00:04:17.974] Command failed
I1229 00:04:17.974] process 1415 exited with code 1 after 0.0m
W1229 00:04:17.975] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1211074518253047810/artifacts not exist yet
I1229 00:04:17.975] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1211074518253047810/artifacts
I1229 00:04:20.678] process 1560 exited with code 0 after 0.0m
I1229 00:04:20.679] Call:  git rev-parse HEAD
W1229 00:04:20.684] fatal: not a git repository (or any of the parent directories): .git
E1229 00:04:20.685] Command failed
I1229 00:04:20.686] process 2087 exited with code 128 after 0.0m
I1229 00:04:20.686] Call:  git rev-parse HEAD
I1229 00:04:20.697] process 2088 exited with code 0 after 0.0m
I1229 00:04:20.698] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json
I1229 00:04:22.371] process 2089 exited with code 0 after 0.0m
I1229 00:04:22.372] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json#1577534645804515'
... skipping 8 lines ...