This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-12-30 00:01
Elapsed4m0s
Revision
Buildergke-prow-ssd-pool-1a225945-ld64
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/98782d73-55cd-455c-9580-a52bf8c16881/targets/test'}}
pod5ec53761-2a97-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/98782d73-55cd-455c-9580-a52bf8c16881/targets/test
infra-commit09d9247dc
job-versionv1.16.5-beta.1.37+5a9078c6025b30
pod5ec53761-2a97-11ea-a07b-c6eb1bf16817
revisionv1.16.5-beta.1.37+5a9078c6025b30

Test Failures


Up 1m52s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1230 00:01:06.869] process 47 exited with code 0 after 0.0m
I1230 00:01:06.869] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1230 00:01:06.869] Root: /workspace
I1230 00:01:06.870] cd to /workspace
I1230 00:01:06.870] Configure environment...
I1230 00:01:06.870] Call:  git show -s --format=format:%ct HEAD
W1230 00:01:06.875] fatal: not a git repository (or any of the parent directories): .git
I1230 00:01:06.875] process 60 exited with code 128 after 0.0m
W1230 00:01:06.875] Unable to print commit date for HEAD
I1230 00:01:06.876] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1230 00:01:07.409] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1230 00:01:07.726] process 61 exited with code 0 after 0.0m
I1230 00:01:07.726] Call:  gcloud config get-value account
... skipping 426 lines ...
W1230 00:04:01.353] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1230 00:04:01.354] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W1230 00:04:01.355] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1230 00:04:01.355] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1230 00:04:01.356] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1230 00:04:01.356] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1230 00:04:48.558] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1230 00:04:48.602] 2019/12/30 00:04:48 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e' finished in 47.662210298s
W1230 00:04:50.308] 2019/12/30 00:04:50 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1230 00:04:59.182] 2019/12/30 00:04:59 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e: exit status 1
W1230 00:04:59.184] Traceback (most recent call last):
W1230 00:04:59.185]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1230 00:04:59.185]     main(parse_args())
W1230 00:04:59.185]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1230 00:04:59.185]     mode.start(runner_args)
W1230 00:04:59.185]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1230 00:04:59.185]     check_env(env, self.command, *args)
W1230 00:04:59.186]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1230 00:04:59.186]     subprocess.check_call(cmd, env=env)
W1230 00:04:59.186]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1230 00:04:59.186]     raise CalledProcessError(retcode, cmd)
W1230 00:04:59.187] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable1', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1230 00:04:59.194] Command failed
I1230 00:04:59.194] process 268 exited with code 1 after 3.8m
E1230 00:04:59.194] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1
I1230 00:04:59.195] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1230 00:04:59.723] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1230 00:04:59.777] process 1390 exited with code 0 after 0.0m
I1230 00:04:59.777] Call:  gcloud config get-value account
I1230 00:05:00.136] process 1403 exited with code 0 after 0.0m
I1230 00:05:00.137] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1230 00:05:00.137] Upload result and artifacts...
I1230 00:05:00.137] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1211436918714142720
I1230 00:05:00.137] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1211436918714142720/artifacts
W1230 00:05:01.056] CommandException: One or more URLs matched no objects.
E1230 00:05:01.188] Command failed
I1230 00:05:01.188] process 1416 exited with code 1 after 0.0m
W1230 00:05:01.188] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1211436918714142720/artifacts not exist yet
I1230 00:05:01.189] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1211436918714142720/artifacts
I1230 00:05:02.701] process 1561 exited with code 0 after 0.0m
I1230 00:05:02.702] Call:  git rev-parse HEAD
W1230 00:05:02.706] fatal: not a git repository (or any of the parent directories): .git
E1230 00:05:02.707] Command failed
I1230 00:05:02.707] process 2088 exited with code 128 after 0.0m
I1230 00:05:02.707] Call:  git rev-parse HEAD
I1230 00:05:02.711] process 2089 exited with code 0 after 0.0m
I1230 00:05:02.711] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json
I1230 00:05:03.578] process 2090 exited with code 0 after 0.0m
I1230 00:05:03.579] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json#1577621071361099'
... skipping 8 lines ...