This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-01 12:01
Elapsed3m56s
Revision
Buildergke-prow-ssd-pool-1a225945-fqsc
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/76979a12-448c-41ea-9e5d-3f83448c6606/targets/test'}}
pod4b9da478-2c8e-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/76979a12-448c-41ea-9e5d-3f83448c6606/targets/test
infra-commit35a960fa0
job-versionv1.16.5-beta.1.37+5a9078c6025b30
pod4b9da478-2c8e-11ea-a07b-c6eb1bf16817
revisionv1.16.5-beta.1.37+5a9078c6025b30

Test Failures


Up 1m36s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0101 12:01:11.185] process 47 exited with code 0 after 0.0m
I0101 12:01:11.186] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0101 12:01:11.186] Root: /workspace
I0101 12:01:11.186] cd to /workspace
I0101 12:01:11.187] Configure environment...
I0101 12:01:11.187] Call:  git show -s --format=format:%ct HEAD
W0101 12:01:11.193] fatal: not a git repository (or any of the parent directories): .git
I0101 12:01:11.195] process 60 exited with code 128 after 0.0m
W0101 12:01:11.195] Unable to print commit date for HEAD
I0101 12:01:11.196] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0101 12:01:11.829] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0101 12:01:12.169] process 61 exited with code 0 after 0.0m
I0101 12:01:12.169] Call:  gcloud config get-value account
... skipping 426 lines ...
W0101 12:04:10.109] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0101 12:04:10.110] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0101 12:04:10.111] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0101 12:04:10.111] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0101 12:04:10.112] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0101 12:04:10.112] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0101 12:04:55.599] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0101 12:04:55.643] 2020/01/01 12:04:55 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e' finished in 46.03132859s
W0101 12:04:57.316] 2020/01/01 12:04:57 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0101 12:04:57.822] 2020/01/01 12:04:57 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e: exit status 1
W0101 12:04:57.830] Traceback (most recent call last):
W0101 12:04:57.831]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0101 12:04:57.831]     main(parse_args())
W0101 12:04:57.832]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0101 12:04:57.832]     mode.start(runner_args)
W0101 12:04:57.832]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0101 12:04:57.832]     check_env(env, self.command, *args)
W0101 12:04:57.832]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0101 12:04:57.833]     subprocess.check_call(cmd, env=env)
W0101 12:04:57.833]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0101 12:04:57.833]     raise CalledProcessError(retcode, cmd)
W0101 12:04:57.834] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable1', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0101 12:04:57.838] Command failed
I0101 12:04:57.839] process 268 exited with code 1 after 3.7m
E0101 12:04:57.840] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1
I0101 12:04:57.840] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0101 12:04:58.408] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0101 12:04:58.470] process 1390 exited with code 0 after 0.0m
I0101 12:04:58.471] Call:  gcloud config get-value account
I0101 12:04:58.841] process 1403 exited with code 0 after 0.0m
I0101 12:04:58.842] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0101 12:04:58.842] Upload result and artifacts...
I0101 12:04:58.842] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1212342930165993473
I0101 12:04:58.842] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1212342930165993473/artifacts
W0101 12:04:59.987] CommandException: One or more URLs matched no objects.
E0101 12:05:00.154] Command failed
I0101 12:05:00.155] process 1416 exited with code 1 after 0.0m
W0101 12:05:00.155] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1212342930165993473/artifacts not exist yet
I0101 12:05:00.155] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1212342930165993473/artifacts
I0101 12:05:02.388] process 1561 exited with code 0 after 0.0m
I0101 12:05:02.389] Call:  git rev-parse HEAD
W0101 12:05:02.395] fatal: not a git repository (or any of the parent directories): .git
E0101 12:05:02.395] Command failed
I0101 12:05:02.396] process 2088 exited with code 128 after 0.0m
I0101 12:05:02.396] Call:  git rev-parse HEAD
I0101 12:05:02.403] process 2089 exited with code 0 after 0.0m
I0101 12:05:02.403] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json
I0101 12:05:03.546] process 2090 exited with code 0 after 0.0m
I0101 12:05:03.547] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json#1577837069202326'
... skipping 8 lines ...