This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-02 00:01
Elapsed4m4s
Revision
Buildergke-prow-ssd-pool-1a225945-g9xl
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/dbbca30b-19a3-4f0f-beed-7a2e55565d60/targets/test'}}
pode1336cc3-2cf2-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/dbbca30b-19a3-4f0f-beed-7a2e55565d60/targets/test
infra-commit35a960fa0
job-versionv1.16.5-beta.1.37+5a9078c6025b30
pode1336cc3-2cf2-11ea-a07b-c6eb1bf16817
revisionv1.16.5-beta.1.37+5a9078c6025b30

Test Failures


Up 1m30s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0102 00:01:19.014] process 47 exited with code 0 after 0.0m
I0102 00:01:19.015] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0102 00:01:19.015] Root: /workspace
I0102 00:01:19.016] cd to /workspace
I0102 00:01:19.016] Configure environment...
I0102 00:01:19.016] Call:  git show -s --format=format:%ct HEAD
W0102 00:01:19.022] fatal: not a git repository (or any of the parent directories): .git
I0102 00:01:19.024] process 60 exited with code 128 after 0.0m
W0102 00:01:19.024] Unable to print commit date for HEAD
I0102 00:01:19.024] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0102 00:01:19.785] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0102 00:01:20.145] process 61 exited with code 0 after 0.0m
I0102 00:01:20.145] Call:  gcloud config get-value account
... skipping 422 lines ...
W0102 00:04:23.076] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0102 00:04:23.077] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0102 00:04:23.078] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0102 00:04:23.079] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0102 00:04:23.080] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0102 00:04:23.081] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0102 00:05:07.051] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0102 00:05:07.132] 2020/01/02 00:05:07 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e' finished in 44.555180178s
W0102 00:05:08.925] 2020/01/02 00:05:08 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0102 00:05:12.126] 2020/01/02 00:05:12 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e: exit status 1
W0102 00:05:12.136] Traceback (most recent call last):
W0102 00:05:12.136]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0102 00:05:12.136]     main(parse_args())
W0102 00:05:12.137]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0102 00:05:12.137]     mode.start(runner_args)
W0102 00:05:12.137]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0102 00:05:12.138]     check_env(env, self.command, *args)
W0102 00:05:12.138]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0102 00:05:12.138]     subprocess.check_call(cmd, env=env)
W0102 00:05:12.138]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0102 00:05:12.138]     raise CalledProcessError(retcode, cmd)
W0102 00:05:12.139] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable1', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0102 00:05:12.151] Command failed
I0102 00:05:12.152] process 268 exited with code 1 after 3.8m
E0102 00:05:12.152] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1
I0102 00:05:12.152] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0102 00:05:12.852] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0102 00:05:12.917] process 1376 exited with code 0 after 0.0m
I0102 00:05:12.918] Call:  gcloud config get-value account
I0102 00:05:13.352] process 1389 exited with code 0 after 0.0m
I0102 00:05:13.352] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0102 00:05:13.352] Upload result and artifacts...
I0102 00:05:13.352] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1212524129085820928
I0102 00:05:13.353] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1212524129085820928/artifacts
W0102 00:05:14.500] CommandException: One or more URLs matched no objects.
E0102 00:05:14.654] Command failed
I0102 00:05:14.654] process 1402 exited with code 1 after 0.0m
W0102 00:05:14.654] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1212524129085820928/artifacts not exist yet
I0102 00:05:14.655] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1212524129085820928/artifacts
I0102 00:05:16.730] process 1547 exited with code 0 after 0.0m
I0102 00:05:16.731] Call:  git rev-parse HEAD
W0102 00:05:16.737] fatal: not a git repository (or any of the parent directories): .git
E0102 00:05:16.738] Command failed
I0102 00:05:16.738] process 2074 exited with code 128 after 0.0m
I0102 00:05:16.739] Call:  git rev-parse HEAD
I0102 00:05:16.744] process 2075 exited with code 0 after 0.0m
I0102 00:05:16.744] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json
I0102 00:05:17.884] process 2076 exited with code 0 after 0.0m
I0102 00:05:17.885] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json#1577880305996022'
... skipping 8 lines ...