This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-03 00:01
Elapsed3m45s
Revision
Buildergke-prow-ssd-pool-1a225945-tmz8
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/594bb0b9-562f-472d-8990-28c4c7aa5499/targets/test'}}
pod0ce27c66-2dbc-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/594bb0b9-562f-472d-8990-28c4c7aa5499/targets/test
infra-commit0bde37ecf
job-versionv1.16.5-beta.1.37+5a9078c6025b30
pod0ce27c66-2dbc-11ea-a07b-c6eb1bf16817
revisionv1.16.5-beta.1.37+5a9078c6025b30

Test Failures


Up 1m23s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0103 00:01:23.289] process 47 exited with code 0 after 0.0m
I0103 00:01:23.290] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0103 00:01:23.290] Root: /workspace
I0103 00:01:23.290] cd to /workspace
I0103 00:01:23.291] Configure environment...
I0103 00:01:23.291] Call:  git show -s --format=format:%ct HEAD
W0103 00:01:23.296] fatal: not a git repository (or any of the parent directories): .git
I0103 00:01:23.297] process 60 exited with code 128 after 0.0m
W0103 00:01:23.297] Unable to print commit date for HEAD
I0103 00:01:23.298] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0103 00:01:24.052] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0103 00:01:24.410] process 61 exited with code 0 after 0.0m
I0103 00:01:24.411] Call:  gcloud config get-value account
... skipping 426 lines ...
W0103 00:04:02.337] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0103 00:04:02.337] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0103 00:04:02.338] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0103 00:04:02.339] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0103 00:04:02.339] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0103 00:04:02.339] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0103 00:04:44.621] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0103 00:04:44.689] 2020/01/03 00:04:44 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e' finished in 42.800920096s
W0103 00:04:46.468] 2020/01/03 00:04:46 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0103 00:04:57.737] 2020/01/03 00:04:57 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e: exit status 1
W0103 00:04:57.742] Traceback (most recent call last):
W0103 00:04:57.743]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0103 00:04:57.743]     main(parse_args())
W0103 00:04:57.743]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0103 00:04:57.743]     mode.start(runner_args)
W0103 00:04:57.744]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0103 00:04:57.744]     check_env(env, self.command, *args)
W0103 00:04:57.744]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0103 00:04:57.744]     subprocess.check_call(cmd, env=env)
W0103 00:04:57.745]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0103 00:04:57.745]     raise CalledProcessError(retcode, cmd)
W0103 00:04:57.746] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable1', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0103 00:04:57.754] Command failed
I0103 00:04:57.757] process 268 exited with code 1 after 3.5m
E0103 00:04:57.757] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1
I0103 00:04:57.758] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0103 00:04:58.365] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0103 00:04:58.430] process 1392 exited with code 0 after 0.0m
I0103 00:04:58.431] Call:  gcloud config get-value account
I0103 00:04:58.873] process 1405 exited with code 0 after 0.0m
I0103 00:04:58.874] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0103 00:04:58.874] Upload result and artifacts...
I0103 00:04:58.874] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1212886535976783875
I0103 00:04:58.875] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1212886535976783875/artifacts
W0103 00:05:00.055] CommandException: One or more URLs matched no objects.
E0103 00:05:00.207] Command failed
I0103 00:05:00.207] process 1418 exited with code 1 after 0.0m
W0103 00:05:00.207] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1212886535976783875/artifacts not exist yet
I0103 00:05:00.208] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1212886535976783875/artifacts
I0103 00:05:02.523] process 1563 exited with code 0 after 0.0m
I0103 00:05:02.524] Call:  git rev-parse HEAD
W0103 00:05:02.529] fatal: not a git repository (or any of the parent directories): .git
E0103 00:05:02.530] Command failed
I0103 00:05:02.530] process 2090 exited with code 128 after 0.0m
I0103 00:05:02.530] Call:  git rev-parse HEAD
I0103 00:05:02.536] process 2091 exited with code 0 after 0.0m
I0103 00:05:02.536] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json
I0103 00:05:03.742] process 2092 exited with code 0 after 0.0m
I0103 00:05:03.743] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json#1577966732047958'
... skipping 8 lines ...