This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-03 12:01
Elapsed4m57s
Revision
Buildergke-prow-ssd-pool-1a225945-txmz
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/d63ccd29-6e0b-4ea9-9ce7-e2738bf82107/targets/test'}}
poda2e421c1-2e20-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/d63ccd29-6e0b-4ea9-9ce7-e2738bf82107/targets/test
infra-commit830f0cf43
job-versionv1.16.5-beta.1.37+5a9078c6025b30
poda2e421c1-2e20-11ea-a07b-c6eb1bf16817
revisionv1.16.5-beta.1.37+5a9078c6025b30

Test Failures


Up 1m46s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0103 12:01:28.878] process 47 exited with code 0 after 0.0m
I0103 12:01:28.878] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0103 12:01:28.879] Root: /workspace
I0103 12:01:28.879] cd to /workspace
I0103 12:01:28.879] Configure environment...
I0103 12:01:28.879] Call:  git show -s --format=format:%ct HEAD
W0103 12:01:28.890] fatal: not a git repository (or any of the parent directories): .git
I0103 12:01:28.893] process 60 exited with code 128 after 0.0m
W0103 12:01:28.893] Unable to print commit date for HEAD
I0103 12:01:28.894] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0103 12:01:29.791] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0103 12:01:30.193] process 61 exited with code 0 after 0.0m
I0103 12:01:30.194] Call:  gcloud config get-value account
... skipping 426 lines ...
W0103 12:05:18.933] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0103 12:05:18.934] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0103 12:05:18.936] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0103 12:05:18.937] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0103 12:05:18.937] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0103 12:05:18.938] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0103 12:06:07.554] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0103 12:06:07.641] 2020/01/03 12:06:07 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e' finished in 49.407191929s
W0103 12:06:09.962] 2020/01/03 12:06:09 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0103 12:06:12.001] 2020/01/03 12:06:12 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e: exit status 1
W0103 12:06:12.012] Traceback (most recent call last):
W0103 12:06:12.013]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0103 12:06:12.014]     main(parse_args())
W0103 12:06:12.014]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0103 12:06:12.014]     mode.start(runner_args)
W0103 12:06:12.015]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0103 12:06:12.015]     check_env(env, self.command, *args)
W0103 12:06:12.016]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0103 12:06:12.016]     subprocess.check_call(cmd, env=env)
W0103 12:06:12.016]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0103 12:06:12.016]     raise CalledProcessError(retcode, cmd)
W0103 12:06:12.018] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable1', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0103 12:06:12.031] Command failed
I0103 12:06:12.031] process 268 exited with code 1 after 4.6m
E0103 12:06:12.032] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1
I0103 12:06:12.032] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0103 12:06:12.816] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0103 12:06:12.904] process 1388 exited with code 0 after 0.0m
I0103 12:06:12.905] Call:  gcloud config get-value account
I0103 12:06:13.483] process 1401 exited with code 0 after 0.0m
I0103 12:06:13.484] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0103 12:06:13.485] Upload result and artifacts...
I0103 12:06:13.485] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1213067739225133056
I0103 12:06:13.487] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1213067739225133056/artifacts
W0103 12:06:15.044] CommandException: One or more URLs matched no objects.
E0103 12:06:15.268] Command failed
I0103 12:06:15.268] process 1414 exited with code 1 after 0.0m
W0103 12:06:15.269] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1213067739225133056/artifacts not exist yet
I0103 12:06:15.269] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1213067739225133056/artifacts
I0103 12:06:18.169] process 1559 exited with code 0 after 0.0m
I0103 12:06:18.170] Call:  git rev-parse HEAD
W0103 12:06:18.180] fatal: not a git repository (or any of the parent directories): .git
E0103 12:06:18.181] Command failed
I0103 12:06:18.181] process 2086 exited with code 128 after 0.0m
I0103 12:06:18.181] Call:  git rev-parse HEAD
I0103 12:06:18.196] process 2087 exited with code 0 after 0.0m
I0103 12:06:18.197] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json
I0103 12:06:19.857] process 2088 exited with code 0 after 0.0m
I0103 12:06:19.859] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json#1578009906668320'
... skipping 8 lines ...