This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-05 12:01
Elapsed4m1s
Revision
Buildergke-prow-ssd-pool-1a225945-g951
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/0be3fdb6-bc12-490a-a65c-8504be069d63/targets/test'}}
podf9d700fd-2fb2-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/0be3fdb6-bc12-490a-a65c-8504be069d63/targets/test
infra-commit235805981
job-versionv1.16.5-beta.1.37+5a9078c6025b30
podf9d700fd-2fb2-11ea-a07b-c6eb1bf16817
revisionv1.16.5-beta.1.37+5a9078c6025b30

Test Failures


Up 1m41s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0105 12:01:29.174] process 47 exited with code 0 after 0.0m
I0105 12:01:29.175] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0105 12:01:29.175] Root: /workspace
I0105 12:01:29.175] cd to /workspace
I0105 12:01:29.175] Configure environment...
I0105 12:01:29.176] Call:  git show -s --format=format:%ct HEAD
W0105 12:01:29.181] fatal: not a git repository (or any of the parent directories): .git
I0105 12:01:29.181] process 60 exited with code 128 after 0.0m
W0105 12:01:29.181] Unable to print commit date for HEAD
I0105 12:01:29.182] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0105 12:01:29.713] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0105 12:01:29.837] process 61 exited with code 0 after 0.0m
I0105 12:01:29.837] Call:  gcloud config get-value account
... skipping 426 lines ...
W0105 12:04:18.620] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0105 12:04:18.622] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0105 12:04:18.623] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0105 12:04:18.624] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0105 12:04:18.625] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0105 12:04:18.625] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0105 12:05:08.538] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0105 12:05:08.609] 2020/01/05 12:05:08 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e' finished in 50.70754319s
W0105 12:05:10.880] 2020/01/05 12:05:10 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0105 12:05:17.757] 2020/01/05 12:05:17 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e: exit status 1
W0105 12:05:17.766] Traceback (most recent call last):
W0105 12:05:17.767]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0105 12:05:17.767]     main(parse_args())
W0105 12:05:17.767]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0105 12:05:17.768]     mode.start(runner_args)
W0105 12:05:17.769]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0105 12:05:17.769]     check_env(env, self.command, *args)
W0105 12:05:17.770]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0105 12:05:17.770]     subprocess.check_call(cmd, env=env)
W0105 12:05:17.770]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0105 12:05:17.772]     raise CalledProcessError(retcode, cmd)
W0105 12:05:17.773] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable1', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0105 12:05:17.780] Command failed
I0105 12:05:17.780] process 268 exited with code 1 after 3.8m
E0105 12:05:17.780] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1
I0105 12:05:17.781] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0105 12:05:18.638] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0105 12:05:18.705] process 1388 exited with code 0 after 0.0m
I0105 12:05:18.705] Call:  gcloud config get-value account
I0105 12:05:19.220] process 1401 exited with code 0 after 0.0m
I0105 12:05:19.220] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0105 12:05:19.221] Upload result and artifacts...
I0105 12:05:19.221] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1213792551048318977
I0105 12:05:19.221] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1213792551048318977/artifacts
W0105 12:05:20.754] CommandException: One or more URLs matched no objects.
E0105 12:05:20.944] Command failed
I0105 12:05:20.945] process 1414 exited with code 1 after 0.0m
W0105 12:05:20.945] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1213792551048318977/artifacts not exist yet
I0105 12:05:20.945] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1213792551048318977/artifacts
I0105 12:05:23.703] process 1559 exited with code 0 after 0.0m
I0105 12:05:23.704] Call:  git rev-parse HEAD
W0105 12:05:23.712] fatal: not a git repository (or any of the parent directories): .git
E0105 12:05:23.713] Command failed
I0105 12:05:23.714] process 2086 exited with code 128 after 0.0m
I0105 12:05:23.714] Call:  git rev-parse HEAD
I0105 12:05:23.724] process 2087 exited with code 0 after 0.0m
I0105 12:05:23.725] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json
I0105 12:05:25.569] process 2088 exited with code 0 after 0.0m
I0105 12:05:25.571] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json#1578182698692399'
... skipping 8 lines ...