This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-06 12:01
Elapsed3m57s
Revision
Buildergke-prow-ssd-pool-1a225945-g8h1
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/478e8dc0-2d79-4460-81c1-8b2a61aaf29d/targets/test'}}
pod24c0f75b-307c-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/478e8dc0-2d79-4460-81c1-8b2a61aaf29d/targets/test
infra-commit6b50e8c07
job-versionv1.16.5-beta.1.37+5a9078c6025b30
pod24c0f75b-307c-11ea-a07b-c6eb1bf16817
revisionv1.16.5-beta.1.37+5a9078c6025b30

Test Failures


Up 1m40s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0106 12:01:32.351] process 47 exited with code 0 after 0.0m
I0106 12:01:32.351] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0106 12:01:32.351] Root: /workspace
I0106 12:01:32.351] cd to /workspace
I0106 12:01:32.351] Configure environment...
I0106 12:01:32.352] Call:  git show -s --format=format:%ct HEAD
W0106 12:01:32.358] fatal: not a git repository (or any of the parent directories): .git
I0106 12:01:32.359] process 60 exited with code 128 after 0.0m
W0106 12:01:32.359] Unable to print commit date for HEAD
I0106 12:01:32.360] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0106 12:01:32.988] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0106 12:01:33.108] process 61 exited with code 0 after 0.0m
I0106 12:01:33.108] Call:  gcloud config get-value account
... skipping 426 lines ...
W0106 12:04:26.387] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0106 12:04:26.389] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0106 12:04:26.392] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0106 12:04:26.393] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0106 12:04:26.394] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0106 12:04:26.394] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0106 12:05:10.871] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0106 12:05:10.953] 2020/01/06 12:05:10 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e' finished in 45.253045026s
W0106 12:05:13.254] 2020/01/06 12:05:13 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0106 12:05:16.871] 2020/01/06 12:05:16 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e: exit status 1
W0106 12:05:16.877] Traceback (most recent call last):
W0106 12:05:16.878]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0106 12:05:16.883]     main(parse_args())
W0106 12:05:16.884]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0106 12:05:16.885]     mode.start(runner_args)
W0106 12:05:16.885]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0106 12:05:16.886]     check_env(env, self.command, *args)
W0106 12:05:16.886]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0106 12:05:16.887]     subprocess.check_call(cmd, env=env)
W0106 12:05:16.888]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0106 12:05:16.888]     raise CalledProcessError(retcode, cmd)
W0106 12:05:16.890] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable1', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0106 12:05:16.902] Command failed
I0106 12:05:16.903] process 268 exited with code 1 after 3.7m
E0106 12:05:16.903] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1
I0106 12:05:16.904] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0106 12:05:17.743] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0106 12:05:17.818] process 1388 exited with code 0 after 0.0m
I0106 12:05:17.819] Call:  gcloud config get-value account
I0106 12:05:18.294] process 1401 exited with code 0 after 0.0m
I0106 12:05:18.294] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0106 12:05:18.295] Upload result and artifacts...
I0106 12:05:18.295] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1214154953082277888
I0106 12:05:18.296] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1214154953082277888/artifacts
W0106 12:05:19.960] CommandException: One or more URLs matched no objects.
E0106 12:05:20.283] Command failed
I0106 12:05:20.284] process 1414 exited with code 1 after 0.0m
W0106 12:05:20.284] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1214154953082277888/artifacts not exist yet
I0106 12:05:20.284] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1214154953082277888/artifacts
I0106 12:05:22.829] process 1559 exited with code 0 after 0.0m
I0106 12:05:22.830] Call:  git rev-parse HEAD
W0106 12:05:22.852] fatal: not a git repository (or any of the parent directories): .git
E0106 12:05:22.854] Command failed
I0106 12:05:22.855] process 2086 exited with code 128 after 0.0m
I0106 12:05:22.855] Call:  git rev-parse HEAD
I0106 12:05:22.865] process 2087 exited with code 0 after 0.0m
I0106 12:05:22.867] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json
I0106 12:05:24.613] process 2088 exited with code 0 after 0.0m
I0106 12:05:24.614] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json#1578269116466061'
... skipping 8 lines ...