This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-07 00:01
Elapsed7m26s
Revision
Buildergke-prow-ssd-pool-1a225945-cx5g
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/4439f11e-b775-430f-803a-c8e531c38b59/targets/test'}}
podb7a32cc7-30e0-11ea-bef5-ca9a35e1927f
resultstorehttps://source.cloud.google.com/results/invocations/4439f11e-b775-430f-803a-c8e531c38b59/targets/test
infra-commit72789fc52
job-versionv1.16.5-beta.1.37+5a9078c6025b30
podb7a32cc7-30e0-11ea-bef5-ca9a35e1927f
revisionv1.16.5-beta.1.37+5a9078c6025b30

Test Failures


Up 1m39s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0107 00:01:34.323] process 47 exited with code 0 after 0.0m
I0107 00:01:34.323] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0107 00:01:34.324] Root: /workspace
I0107 00:01:34.324] cd to /workspace
I0107 00:01:34.324] Configure environment...
I0107 00:01:34.324] Call:  git show -s --format=format:%ct HEAD
W0107 00:01:34.333] fatal: not a git repository (or any of the parent directories): .git
I0107 00:01:34.334] process 60 exited with code 128 after 0.0m
W0107 00:01:34.334] Unable to print commit date for HEAD
I0107 00:01:34.335] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0107 00:01:35.175] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0107 00:01:35.546] process 61 exited with code 0 after 0.0m
I0107 00:01:35.546] Call:  gcloud config get-value account
... skipping 426 lines ...
W0107 00:07:57.722] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0107 00:07:57.727] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0107 00:07:57.728] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0107 00:07:57.730] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0107 00:07:57.731] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0107 00:07:57.731] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0107 00:08:40.717] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0107 00:08:40.791] 2020/01/07 00:08:40 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e' finished in 43.715446088s
W0107 00:08:43.230] 2020/01/07 00:08:43 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0107 00:08:48.042] 2020/01/07 00:08:48 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.37+5a9078c6025b30 bootstrap-e2e: exit status 1
W0107 00:08:48.051] Traceback (most recent call last):
W0107 00:08:48.051]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0107 00:08:48.051]     main(parse_args())
W0107 00:08:48.051]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0107 00:08:48.052]     mode.start(runner_args)
W0107 00:08:48.052]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0107 00:08:48.052]     check_env(env, self.command, *args)
W0107 00:08:48.052]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0107 00:08:48.052]     subprocess.check_call(cmd, env=env)
W0107 00:08:48.052]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0107 00:08:48.053]     raise CalledProcessError(retcode, cmd)
W0107 00:08:48.053] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable1', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0107 00:08:48.067] Command failed
I0107 00:08:48.068] process 268 exited with code 1 after 7.2m
E0107 00:08:48.068] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1
I0107 00:08:48.068] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0107 00:08:48.913] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0107 00:08:48.986] process 1388 exited with code 0 after 0.0m
I0107 00:08:48.987] Call:  gcloud config get-value account
I0107 00:08:49.471] process 1401 exited with code 0 after 0.0m
I0107 00:08:49.471] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0107 00:08:49.472] Upload result and artifacts...
I0107 00:08:49.472] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1214336017478193153
I0107 00:08:49.472] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1214336017478193153/artifacts
W0107 00:08:51.090] CommandException: One or more URLs matched no objects.
E0107 00:08:51.340] Command failed
I0107 00:08:51.340] process 1414 exited with code 1 after 0.0m
W0107 00:08:51.340] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1214336017478193153/artifacts not exist yet
I0107 00:08:51.341] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1214336017478193153/artifacts
I0107 00:08:53.931] process 1559 exited with code 0 after 0.0m
I0107 00:08:53.932] Call:  git rev-parse HEAD
W0107 00:08:53.941] fatal: not a git repository (or any of the parent directories): .git
E0107 00:08:53.942] Command failed
I0107 00:08:53.943] process 2086 exited with code 128 after 0.0m
I0107 00:08:53.943] Call:  git rev-parse HEAD
I0107 00:08:53.951] process 2087 exited with code 0 after 0.0m
I0107 00:08:53.952] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json
I0107 00:08:55.571] process 2088 exited with code 0 after 0.0m
I0107 00:08:55.572] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json#1578312327904849'
... skipping 8 lines ...