This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-08 00:01
Elapsed3m46s
Revision
Buildergke-prow-default-pool-cf4891d4-6stf
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/618873a7-a307-4e4d-9078-8876a0df8449/targets/test'}}
podd7375728-31a9-11ea-9709-02f27a93e62e
resultstorehttps://source.cloud.google.com/results/invocations/618873a7-a307-4e4d-9078-8876a0df8449/targets/test
infra-commit98b6e6085
job-versionv1.16.5-beta.1.41+2d91933c2bb0a3
podd7375728-31a9-11ea-9709-02f27a93e62e
revisionv1.16.5-beta.1.41+2d91933c2bb0a3

Test Failures


Up 1m16s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.41+2d91933c2bb0a3 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0108 00:01:04.109] process 47 exited with code 0 after 0.0m
I0108 00:01:04.109] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0108 00:01:04.110] Root: /workspace
I0108 00:01:04.110] cd to /workspace
I0108 00:01:04.110] Configure environment...
I0108 00:01:04.110] Call:  git show -s --format=format:%ct HEAD
W0108 00:01:04.115] fatal: not a git repository (or any of the parent directories): .git
I0108 00:01:04.116] process 60 exited with code 128 after 0.0m
W0108 00:01:04.116] Unable to print commit date for HEAD
I0108 00:01:04.117] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0108 00:01:04.672] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0108 00:01:05.023] process 61 exited with code 0 after 0.0m
I0108 00:01:05.023] Call:  gcloud config get-value account
... skipping 426 lines ...
W0108 00:03:51.082] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0108 00:03:51.082] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0108 00:03:51.083] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0108 00:03:51.083] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0108 00:03:51.083] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0108 00:03:51.084] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0108 00:04:32.673] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0108 00:04:32.731] 2020/01/08 00:04:32 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.41+2d91933c2bb0a3 bootstrap-e2e' finished in 42.133618758s
W0108 00:04:34.379] 2020/01/08 00:04:34 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0108 00:04:41.143] 2020/01/08 00:04:41 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.41+2d91933c2bb0a3 bootstrap-e2e: exit status 1
W0108 00:04:41.153] Traceback (most recent call last):
W0108 00:04:41.153]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0108 00:04:41.153]     main(parse_args())
W0108 00:04:41.153]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0108 00:04:41.153]     mode.start(runner_args)
W0108 00:04:41.154]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0108 00:04:41.154]     check_env(env, self.command, *args)
W0108 00:04:41.154]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0108 00:04:41.154]     subprocess.check_call(cmd, env=env)
W0108 00:04:41.154]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0108 00:04:41.154]     raise CalledProcessError(retcode, cmd)
W0108 00:04:41.155] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable1', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0108 00:04:41.166] Command failed
I0108 00:04:41.166] process 268 exited with code 1 after 3.6m
E0108 00:04:41.166] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1
I0108 00:04:41.167] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0108 00:04:41.783] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0108 00:04:41.854] process 1390 exited with code 0 after 0.0m
I0108 00:04:41.855] Call:  gcloud config get-value account
I0108 00:04:42.239] process 1403 exited with code 0 after 0.0m
I0108 00:04:42.240] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0108 00:04:42.240] Upload result and artifacts...
I0108 00:04:42.240] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1214698426164318210
I0108 00:04:42.240] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1214698426164318210/artifacts
W0108 00:04:43.289] CommandException: One or more URLs matched no objects.
E0108 00:04:43.462] Command failed
I0108 00:04:43.463] process 1416 exited with code 1 after 0.0m
W0108 00:04:43.463] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1214698426164318210/artifacts not exist yet
I0108 00:04:43.463] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1214698426164318210/artifacts
I0108 00:04:45.293] process 1561 exited with code 0 after 0.0m
I0108 00:04:45.294] Call:  git rev-parse HEAD
W0108 00:04:45.300] fatal: not a git repository (or any of the parent directories): .git
E0108 00:04:45.300] Command failed
I0108 00:04:45.300] process 2088 exited with code 128 after 0.0m
I0108 00:04:45.301] Call:  git rev-parse HEAD
I0108 00:04:45.306] process 2089 exited with code 0 after 0.0m
I0108 00:04:45.306] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json
I0108 00:04:46.368] process 2090 exited with code 0 after 0.0m
I0108 00:04:46.369] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json#1578398646428023'
... skipping 8 lines ...