This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-09 00:01
Elapsed3m49s
Revision
Buildergke-prow-default-pool-cf4891d4-0mh6
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/cf885195-eed5-460d-9b6a-a2351150ce20/targets/test'}}
pod0267e597-3273-11ea-9709-02f27a93e62e
resultstorehttps://source.cloud.google.com/results/invocations/cf885195-eed5-460d-9b6a-a2351150ce20/targets/test
infra-commitca0db2137
job-versionv1.16.5-beta.1.41+2d91933c2bb0a3
pod0267e597-3273-11ea-9709-02f27a93e62e
revisionv1.16.5-beta.1.41+2d91933c2bb0a3

Test Failures


Up 1m41s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.41+2d91933c2bb0a3 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0109 00:01:02.948] process 47 exited with code 0 after 0.0m
I0109 00:01:02.948] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0109 00:01:02.948] Root: /workspace
I0109 00:01:02.949] cd to /workspace
I0109 00:01:02.949] Configure environment...
I0109 00:01:02.949] Call:  git show -s --format=format:%ct HEAD
W0109 00:01:02.954] fatal: not a git repository (or any of the parent directories): .git
I0109 00:01:02.954] process 60 exited with code 128 after 0.0m
W0109 00:01:02.954] Unable to print commit date for HEAD
I0109 00:01:02.954] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0109 00:01:03.505] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0109 00:01:03.856] process 61 exited with code 0 after 0.0m
I0109 00:01:03.857] Call:  gcloud config get-value account
... skipping 426 lines ...
W0109 00:03:51.287] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0109 00:03:51.288] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0109 00:03:51.288] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0109 00:03:51.289] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0109 00:03:51.289] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0109 00:03:51.289] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0109 00:04:35.291] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0109 00:04:35.353] 2020/01/09 00:04:35 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.41+2d91933c2bb0a3 bootstrap-e2e' finished in 44.553218143s
W0109 00:04:36.994] 2020/01/09 00:04:36 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0109 00:04:44.385] 2020/01/09 00:04:44 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.41+2d91933c2bb0a3 bootstrap-e2e: exit status 1
W0109 00:04:44.391] Traceback (most recent call last):
W0109 00:04:44.391]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0109 00:04:44.391]     main(parse_args())
W0109 00:04:44.392]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0109 00:04:44.392]     mode.start(runner_args)
W0109 00:04:44.392]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0109 00:04:44.392]     check_env(env, self.command, *args)
W0109 00:04:44.392]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0109 00:04:44.392]     subprocess.check_call(cmd, env=env)
W0109 00:04:44.392]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0109 00:04:44.392]     raise CalledProcessError(retcode, cmd)
W0109 00:04:44.393] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable1', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0109 00:04:44.407] Command failed
I0109 00:04:44.407] process 268 exited with code 1 after 3.6m
E0109 00:04:44.407] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1
I0109 00:04:44.407] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0109 00:04:44.941] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0109 00:04:44.998] process 1391 exited with code 0 after 0.0m
I0109 00:04:44.999] Call:  gcloud config get-value account
I0109 00:04:45.322] process 1404 exited with code 0 after 0.0m
I0109 00:04:45.322] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0109 00:04:45.322] Upload result and artifacts...
I0109 00:04:45.322] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1215060822301085696
I0109 00:04:45.323] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1215060822301085696/artifacts
W0109 00:04:46.179] CommandException: One or more URLs matched no objects.
E0109 00:04:46.309] Command failed
I0109 00:04:46.309] process 1417 exited with code 1 after 0.0m
W0109 00:04:46.309] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1215060822301085696/artifacts not exist yet
I0109 00:04:46.309] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1215060822301085696/artifacts
I0109 00:04:47.820] process 1562 exited with code 0 after 0.0m
I0109 00:04:47.821] Call:  git rev-parse HEAD
W0109 00:04:47.826] fatal: not a git repository (or any of the parent directories): .git
E0109 00:04:47.826] Command failed
I0109 00:04:47.826] process 2089 exited with code 128 after 0.0m
I0109 00:04:47.827] Call:  git rev-parse HEAD
I0109 00:04:47.832] process 2090 exited with code 0 after 0.0m
I0109 00:04:47.832] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json
I0109 00:04:48.842] process 2091 exited with code 0 after 0.0m
I0109 00:04:48.842] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json#1578485050769848'
... skipping 8 lines ...