This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-10 00:01
Elapsed4m39s
Revision
Buildergke-prow-default-pool-cf4891d4-5q3v
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/6400ef1c-7879-4d11-91e8-618950cd186d/targets/test'}}
pod3f5bc6b3-333c-11ea-a4dc-8213d962824c
resultstorehttps://source.cloud.google.com/results/invocations/6400ef1c-7879-4d11-91e8-618950cd186d/targets/test
infra-commitb8502cc02
job-versionv1.16.5-beta.1.43+926ccb6ccb4e65
pod3f5bc6b3-333c-11ea-a4dc-8213d962824c
revisionv1.16.5-beta.1.43+926ccb6ccb4e65

Test Failures


Up 1m35s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.43+926ccb6ccb4e65 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0110 00:01:43.846] process 47 exited with code 0 after 0.0m
I0110 00:01:43.846] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0110 00:01:43.847] Root: /workspace
I0110 00:01:43.847] cd to /workspace
I0110 00:01:43.847] Configure environment...
I0110 00:01:43.848] Call:  git show -s --format=format:%ct HEAD
W0110 00:01:43.854] fatal: not a git repository (or any of the parent directories): .git
I0110 00:01:43.855] process 60 exited with code 128 after 0.0m
W0110 00:01:43.855] Unable to print commit date for HEAD
I0110 00:01:43.855] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0110 00:01:44.502] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0110 00:01:44.836] process 61 exited with code 0 after 0.0m
I0110 00:01:44.836] Call:  gcloud config get-value account
... skipping 426 lines ...
W0110 00:05:12.464] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0110 00:05:12.465] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0110 00:05:12.465] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0110 00:05:12.465] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0110 00:05:12.465] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0110 00:05:12.466] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0110 00:05:56.692] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0110 00:05:56.765] 2020/01/10 00:05:56 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.43+926ccb6ccb4e65 bootstrap-e2e' finished in 44.882593008s
W0110 00:05:59.233] 2020/01/10 00:05:59 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0110 00:06:15.136] 2020/01/10 00:06:15 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.43+926ccb6ccb4e65 bootstrap-e2e: exit status 1
W0110 00:06:15.139] Traceback (most recent call last):
W0110 00:06:15.139]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0110 00:06:15.139]     main(parse_args())
W0110 00:06:15.139]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0110 00:06:15.139]     mode.start(runner_args)
W0110 00:06:15.140]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0110 00:06:15.140]     check_env(env, self.command, *args)
W0110 00:06:15.140]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0110 00:06:15.140]     subprocess.check_call(cmd, env=env)
W0110 00:06:15.140]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0110 00:06:15.141]     raise CalledProcessError(retcode, cmd)
W0110 00:06:15.141] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable1', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0110 00:06:15.149] Command failed
I0110 00:06:15.149] process 268 exited with code 1 after 4.5m
E0110 00:06:15.149] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1
I0110 00:06:15.149] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0110 00:06:15.645] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0110 00:06:15.694] process 1389 exited with code 0 after 0.0m
I0110 00:06:15.695] Call:  gcloud config get-value account
I0110 00:06:16.007] process 1402 exited with code 0 after 0.0m
I0110 00:06:16.007] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0110 00:06:16.007] Upload result and artifacts...
I0110 00:06:16.008] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1215423347802771466
I0110 00:06:16.008] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1215423347802771466/artifacts
W0110 00:06:16.917] CommandException: One or more URLs matched no objects.
E0110 00:06:17.028] Command failed
I0110 00:06:17.028] process 1415 exited with code 1 after 0.0m
W0110 00:06:17.028] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1215423347802771466/artifacts not exist yet
I0110 00:06:17.029] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1215423347802771466/artifacts
I0110 00:06:18.756] process 1560 exited with code 0 after 0.0m
I0110 00:06:18.757] Call:  git rev-parse HEAD
W0110 00:06:18.761] fatal: not a git repository (or any of the parent directories): .git
E0110 00:06:18.761] Command failed
I0110 00:06:18.762] process 2087 exited with code 128 after 0.0m
I0110 00:06:18.762] Call:  git rev-parse HEAD
I0110 00:06:18.767] process 2088 exited with code 0 after 0.0m
I0110 00:06:18.767] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json
I0110 00:06:19.653] process 2089 exited with code 0 after 0.0m
I0110 00:06:19.654] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json#1578571506132156'
... skipping 8 lines ...