This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-10 12:01
Elapsed3m48s
Revision
Buildergke-prow-default-pool-cf4891d4-33pg
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/69739f37-9cdc-4510-8661-cdb4d0390245/targets/test'}}
podd4f8f89f-33a0-11ea-a4dc-8213d962824c
resultstorehttps://source.cloud.google.com/results/invocations/69739f37-9cdc-4510-8661-cdb4d0390245/targets/test
infra-commit1856252e3
job-versionv1.16.5-beta.1.49+7d00adae4c21aa
podd4f8f89f-33a0-11ea-a4dc-8213d962824c
revisionv1.16.5-beta.1.49+7d00adae4c21aa

Test Failures


Up 1m22s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.49+7d00adae4c21aa bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0110 12:01:36.592] process 48 exited with code 0 after 0.0m
I0110 12:01:36.593] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0110 12:01:36.593] Root: /workspace
I0110 12:01:36.593] cd to /workspace
I0110 12:01:36.593] Configure environment...
I0110 12:01:36.594] Call:  git show -s --format=format:%ct HEAD
W0110 12:01:36.598] fatal: not a git repository (or any of the parent directories): .git
I0110 12:01:36.599] process 61 exited with code 128 after 0.0m
W0110 12:01:36.599] Unable to print commit date for HEAD
I0110 12:01:36.599] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0110 12:01:37.186] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0110 12:01:37.508] process 62 exited with code 0 after 0.0m
I0110 12:01:37.508] Call:  gcloud config get-value account
... skipping 426 lines ...
W0110 12:04:10.153] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0110 12:04:10.154] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0110 12:04:10.155] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0110 12:04:10.155] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0110 12:04:10.155] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0110 12:04:10.156] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0110 12:04:52.141] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0110 12:04:52.210] 2020/01/10 12:04:52 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.49+7d00adae4c21aa bootstrap-e2e' finished in 42.535374793s
W0110 12:04:54.466] 2020/01/10 12:04:54 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0110 12:05:10.360] 2020/01/10 12:05:10 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.49+7d00adae4c21aa bootstrap-e2e: exit status 1
W0110 12:05:10.373] Traceback (most recent call last):
W0110 12:05:10.373]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0110 12:05:10.373]     main(parse_args())
W0110 12:05:10.373]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0110 12:05:10.373]     mode.start(runner_args)
W0110 12:05:10.374]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0110 12:05:10.374]     check_env(env, self.command, *args)
W0110 12:05:10.374]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0110 12:05:10.374]     subprocess.check_call(cmd, env=env)
W0110 12:05:10.374]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0110 12:05:10.374]     raise CalledProcessError(retcode, cmd)
W0110 12:05:10.375] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable1', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0110 12:05:10.388] Command failed
I0110 12:05:10.388] process 269 exited with code 1 after 3.5m
E0110 12:05:10.388] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1
I0110 12:05:10.389] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0110 12:05:11.475] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0110 12:05:11.564] process 1392 exited with code 0 after 0.0m
I0110 12:05:11.564] Call:  gcloud config get-value account
I0110 12:05:12.363] process 1405 exited with code 0 after 0.0m
I0110 12:05:12.364] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0110 12:05:12.364] Upload result and artifacts...
I0110 12:05:12.364] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1215604541441970182
I0110 12:05:12.365] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1215604541441970182/artifacts
W0110 12:05:14.456] CommandException: One or more URLs matched no objects.
E0110 12:05:14.736] Command failed
I0110 12:05:14.736] process 1418 exited with code 1 after 0.0m
W0110 12:05:14.736] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1215604541441970182/artifacts not exist yet
I0110 12:05:14.737] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1215604541441970182/artifacts
I0110 12:05:18.374] process 1563 exited with code 0 after 0.1m
I0110 12:05:18.375] Call:  git rev-parse HEAD
W0110 12:05:18.396] fatal: not a git repository (or any of the parent directories): .git
E0110 12:05:18.397] Command failed
I0110 12:05:18.397] process 2090 exited with code 128 after 0.0m
I0110 12:05:18.397] Call:  git rev-parse HEAD
I0110 12:05:18.408] process 2091 exited with code 0 after 0.0m
I0110 12:05:18.409] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json
I0110 12:05:20.568] process 2092 exited with code 0 after 0.0m
I0110 12:05:20.569] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json#1578614781712171'
... skipping 8 lines ...