This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-11 00:01
Elapsed4m19s
Revision
Buildergke-prow-default-pool-cf4891d4-t4sm
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/5d31b165-b15a-4d5b-aceb-541536476dba/targets/test'}}
pod61c43c82-3405-11ea-9fef-d200904e1a96
resultstorehttps://source.cloud.google.com/results/invocations/5d31b165-b15a-4d5b-aceb-541536476dba/targets/test
infra-commit561dc2e96
job-versionv1.16.5-beta.1.49+7d00adae4c21aa
pod61c43c82-3405-11ea-9fef-d200904e1a96
revisionv1.16.5-beta.1.49+7d00adae4c21aa

Test Failures


Up 1m30s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.49+7d00adae4c21aa bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0111 00:01:14.535] process 47 exited with code 0 after 0.0m
I0111 00:01:14.535] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0111 00:01:14.536] Root: /workspace
I0111 00:01:14.536] cd to /workspace
I0111 00:01:14.536] Configure environment...
I0111 00:01:14.536] Call:  git show -s --format=format:%ct HEAD
W0111 00:01:14.540] fatal: not a git repository (or any of the parent directories): .git
I0111 00:01:14.541] process 60 exited with code 128 after 0.0m
W0111 00:01:14.541] Unable to print commit date for HEAD
I0111 00:01:14.542] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0111 00:01:15.060] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0111 00:01:15.394] process 61 exited with code 0 after 0.0m
I0111 00:01:15.395] Call:  gcloud config get-value account
... skipping 422 lines ...
W0111 00:04:09.772] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0111 00:04:09.772] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0111 00:04:09.773] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0111 00:04:09.773] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0111 00:04:09.773] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0111 00:04:09.774] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0111 00:04:53.699] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0111 00:04:53.753] 2020/01/11 00:04:53 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.49+7d00adae4c21aa bootstrap-e2e' finished in 44.514989503s
W0111 00:04:55.412] 2020/01/11 00:04:55 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0111 00:05:25.057] 2020/01/11 00:05:25 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.49+7d00adae4c21aa bootstrap-e2e: exit status 1
W0111 00:05:25.062] Traceback (most recent call last):
W0111 00:05:25.062]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0111 00:05:25.062]     main(parse_args())
W0111 00:05:25.062]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0111 00:05:25.063]     mode.start(runner_args)
W0111 00:05:25.063]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0111 00:05:25.063]     check_env(env, self.command, *args)
W0111 00:05:25.063]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0111 00:05:25.063]     subprocess.check_call(cmd, env=env)
W0111 00:05:25.064]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0111 00:05:25.064]     raise CalledProcessError(retcode, cmd)
W0111 00:05:25.065] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable1', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0111 00:05:25.074] Command failed
I0111 00:05:25.074] process 268 exited with code 1 after 4.1m
E0111 00:05:25.074] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1
I0111 00:05:25.075] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0111 00:05:25.617] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0111 00:05:25.669] process 1378 exited with code 0 after 0.0m
I0111 00:05:25.670] Call:  gcloud config get-value account
I0111 00:05:26.040] process 1391 exited with code 0 after 0.0m
I0111 00:05:26.041] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0111 00:05:26.041] Upload result and artifacts...
I0111 00:05:26.041] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1215785629774778369
I0111 00:05:26.041] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1215785629774778369/artifacts
W0111 00:05:27.008] CommandException: One or more URLs matched no objects.
E0111 00:05:27.146] Command failed
I0111 00:05:27.147] process 1404 exited with code 1 after 0.0m
W0111 00:05:27.147] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1215785629774778369/artifacts not exist yet
I0111 00:05:27.147] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1215785629774778369/artifacts
I0111 00:05:29.070] process 1549 exited with code 0 after 0.0m
I0111 00:05:29.071] Call:  git rev-parse HEAD
W0111 00:05:29.075] fatal: not a git repository (or any of the parent directories): .git
E0111 00:05:29.076] Command failed
I0111 00:05:29.076] process 2076 exited with code 128 after 0.0m
I0111 00:05:29.076] Call:  git rev-parse HEAD
I0111 00:05:29.080] process 2077 exited with code 0 after 0.0m
I0111 00:05:29.080] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json
I0111 00:05:30.222] process 2078 exited with code 0 after 0.0m
I0111 00:05:30.223] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json#1578657923299866'
... skipping 8 lines ...