This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-12 00:01
Elapsed3m17s
Revision
Buildergke-prow-default-pool-cf4891d4-jbj5
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/1f0939b9-ce3b-4679-8ece-c13174d75166/targets/test'}}
pod8b3a7108-34ce-11ea-9fef-d200904e1a96
resultstorehttps://source.cloud.google.com/results/invocations/1f0939b9-ce3b-4679-8ece-c13174d75166/targets/test
infra-commitb82ca85d5
job-versionv1.16.5-beta.1.51+e7f962ba86f4ce
pod8b3a7108-34ce-11ea-9fef-d200904e1a96
revisionv1.16.5-beta.1.51+e7f962ba86f4ce

Test Failures


Up 1m29s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.51+e7f962ba86f4ce bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0112 00:01:10.099] process 48 exited with code 0 after 0.0m
I0112 00:01:10.099] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0112 00:01:10.099] Root: /workspace
I0112 00:01:10.099] cd to /workspace
I0112 00:01:10.100] Configure environment...
I0112 00:01:10.100] Call:  git show -s --format=format:%ct HEAD
W0112 00:01:10.104] fatal: not a git repository (or any of the parent directories): .git
I0112 00:01:10.105] process 61 exited with code 128 after 0.0m
W0112 00:01:10.105] Unable to print commit date for HEAD
I0112 00:01:10.105] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0112 00:01:10.600] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0112 00:01:10.917] process 62 exited with code 0 after 0.0m
I0112 00:01:10.917] Call:  gcloud config get-value account
... skipping 426 lines ...
W0112 00:03:32.261] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0112 00:03:32.261] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0112 00:03:32.261] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0112 00:03:32.262] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0112 00:03:32.262] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0112 00:03:32.262] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0112 00:04:16.038] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0112 00:04:16.094] 2020/01/12 00:04:16 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.51+e7f962ba86f4ce bootstrap-e2e' finished in 44.263723875s
W0112 00:04:17.606] 2020/01/12 00:04:17 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0112 00:04:19.966] 2020/01/12 00:04:19 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.51+e7f962ba86f4ce bootstrap-e2e: exit status 1
W0112 00:04:19.974] Traceback (most recent call last):
W0112 00:04:19.974]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0112 00:04:19.974]     main(parse_args())
W0112 00:04:19.974]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0112 00:04:19.974]     mode.start(runner_args)
W0112 00:04:19.975]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0112 00:04:19.975]     check_env(env, self.command, *args)
W0112 00:04:19.975]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0112 00:04:19.975]     subprocess.check_call(cmd, env=env)
W0112 00:04:19.975]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0112 00:04:19.976]     raise CalledProcessError(retcode, cmd)
W0112 00:04:19.976] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable1', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0112 00:04:19.984] Command failed
I0112 00:04:19.985] process 269 exited with code 1 after 3.1m
E0112 00:04:19.985] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1
I0112 00:04:19.985] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0112 00:04:20.475] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0112 00:04:20.526] process 1391 exited with code 0 after 0.0m
I0112 00:04:20.527] Call:  gcloud config get-value account
I0112 00:04:20.839] process 1404 exited with code 0 after 0.0m
I0112 00:04:20.839] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0112 00:04:20.839] Upload result and artifacts...
I0112 00:04:20.839] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1216148010556198916
I0112 00:04:20.840] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1216148010556198916/artifacts
W0112 00:04:21.652] CommandException: One or more URLs matched no objects.
E0112 00:04:21.779] Command failed
I0112 00:04:21.780] process 1417 exited with code 1 after 0.0m
W0112 00:04:21.780] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1216148010556198916/artifacts not exist yet
I0112 00:04:21.780] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1216148010556198916/artifacts
I0112 00:04:23.396] process 1562 exited with code 0 after 0.0m
I0112 00:04:23.396] Call:  git rev-parse HEAD
W0112 00:04:23.401] fatal: not a git repository (or any of the parent directories): .git
E0112 00:04:23.401] Command failed
I0112 00:04:23.402] process 2089 exited with code 128 after 0.0m
I0112 00:04:23.402] Call:  git rev-parse HEAD
I0112 00:04:23.406] process 2090 exited with code 0 after 0.0m
I0112 00:04:23.406] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json
I0112 00:04:24.332] process 2091 exited with code 0 after 0.0m
I0112 00:04:24.333] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json#1578744288419656'
... skipping 8 lines ...