This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-13 12:01
Elapsed5m22s
Revision
Buildergke-prow-default-pool-cf4891d4-w60c
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/356fe9e0-23bd-4aa7-886b-7ee0c45e25e3/targets/test'}}
pod49fcbd86-35fc-11ea-9fef-d200904e1a96
resultstorehttps://source.cloud.google.com/results/invocations/356fe9e0-23bd-4aa7-886b-7ee0c45e25e3/targets/test
infra-commitd6212fa62
job-versionv1.16.5-beta.1.51+e7f962ba86f4ce
pod49fcbd86-35fc-11ea-9fef-d200904e1a96
revisionv1.16.5-beta.1.51+e7f962ba86f4ce

Test Failures


Up 1m47s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.51+e7f962ba86f4ce bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0113 12:01:18.886] process 47 exited with code 0 after 0.0m
I0113 12:01:18.887] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0113 12:01:18.887] Root: /workspace
I0113 12:01:18.887] cd to /workspace
I0113 12:01:18.887] Configure environment...
I0113 12:01:18.888] Call:  git show -s --format=format:%ct HEAD
W0113 12:01:18.896] fatal: not a git repository (or any of the parent directories): .git
I0113 12:01:18.896] process 60 exited with code 128 after 0.0m
W0113 12:01:18.896] Unable to print commit date for HEAD
I0113 12:01:18.897] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0113 12:01:20.113] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0113 12:01:20.329] process 61 exited with code 0 after 0.0m
I0113 12:01:20.438] Call:  gcloud config get-value account
... skipping 426 lines ...
W0113 12:05:34.404] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0113 12:05:34.404] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0113 12:05:34.405] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0113 12:05:34.405] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0113 12:05:34.406] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0113 12:05:34.406] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0113 12:06:18.882] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0113 12:06:19.001] 2020/01/13 12:06:19 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.51+e7f962ba86f4ce bootstrap-e2e' finished in 45.336184711s
W0113 12:06:21.420] 2020/01/13 12:06:21 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0113 12:06:27.841] 2020/01/13 12:06:27 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.51+e7f962ba86f4ce bootstrap-e2e: exit status 1
W0113 12:06:27.854] Traceback (most recent call last):
W0113 12:06:27.855]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0113 12:06:27.855]     main(parse_args())
W0113 12:06:27.855]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0113 12:06:27.856]     mode.start(runner_args)
W0113 12:06:27.856]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0113 12:06:27.856]     check_env(env, self.command, *args)
W0113 12:06:27.856]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0113 12:06:27.856]     subprocess.check_call(cmd, env=env)
W0113 12:06:27.857]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0113 12:06:27.857]     raise CalledProcessError(retcode, cmd)
W0113 12:06:27.858] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable1', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0113 12:06:27.873] Command failed
I0113 12:06:27.873] process 268 exited with code 1 after 5.1m
E0113 12:06:27.874] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1
I0113 12:06:27.874] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0113 12:06:28.801] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0113 12:06:28.907] process 1390 exited with code 0 after 0.0m
I0113 12:06:28.908] Call:  gcloud config get-value account
I0113 12:06:29.550] process 1403 exited with code 0 after 0.0m
I0113 12:06:29.551] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0113 12:06:29.551] Upload result and artifacts...
I0113 12:06:29.551] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1216691584666439680
I0113 12:06:29.552] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1216691584666439680/artifacts
W0113 12:06:31.084] CommandException: One or more URLs matched no objects.
E0113 12:06:31.355] Command failed
I0113 12:06:31.355] process 1416 exited with code 1 after 0.0m
W0113 12:06:31.355] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1216691584666439680/artifacts not exist yet
I0113 12:06:31.356] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1216691584666439680/artifacts
I0113 12:06:33.922] process 1561 exited with code 0 after 0.0m
I0113 12:06:33.923] Call:  git rev-parse HEAD
W0113 12:06:33.931] fatal: not a git repository (or any of the parent directories): .git
E0113 12:06:33.932] Command failed
I0113 12:06:33.932] process 2088 exited with code 128 after 0.0m
I0113 12:06:33.932] Call:  git rev-parse HEAD
I0113 12:06:33.942] process 2089 exited with code 0 after 0.0m
I0113 12:06:33.943] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json
I0113 12:06:35.567] process 2090 exited with code 0 after 0.0m
I0113 12:06:35.568] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json#1578873878721942'
... skipping 8 lines ...