This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-15 00:00
Elapsed3m13s
Revision
Buildergke-prow-default-pool-cf4891d4-msqg
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/65dd0b94-7c09-410f-8197-135bcf19234a/targets/test'}}
podfaa8a487-3729-11ea-8603-da2f7a5855b4
resultstorehttps://source.cloud.google.com/results/invocations/65dd0b94-7c09-410f-8197-135bcf19234a/targets/test
infra-commit29e07a334
job-versionv1.16.5-beta.1.51+e7f962ba86f4ce
podfaa8a487-3729-11ea-8603-da2f7a5855b4
revisionv1.16.5-beta.1.51+e7f962ba86f4ce

Test Failures


Up 40s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.51+e7f962ba86f4ce bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0115 00:00:50.811] process 47 exited with code 0 after 0.0m
I0115 00:00:50.812] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0115 00:00:50.812] Root: /workspace
I0115 00:00:50.812] cd to /workspace
I0115 00:00:50.812] Configure environment...
I0115 00:00:50.813] Call:  git show -s --format=format:%ct HEAD
W0115 00:00:50.817] fatal: not a git repository (or any of the parent directories): .git
I0115 00:00:50.817] process 60 exited with code 128 after 0.0m
W0115 00:00:50.817] Unable to print commit date for HEAD
I0115 00:00:50.818] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0115 00:00:51.362] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0115 00:00:51.688] process 61 exited with code 0 after 0.0m
I0115 00:00:51.688] Call:  gcloud config get-value account
... skipping 426 lines ...
W0115 00:03:30.855] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0115 00:03:30.855] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0115 00:03:30.856] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0115 00:03:30.856] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0115 00:03:30.856] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0115 00:03:30.857] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0115 00:03:30.919] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0115 00:03:30.966] 2020/01/15 00:03:30 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.51+e7f962ba86f4ce bootstrap-e2e' finished in 534.617691ms
W0115 00:03:32.018] 2020/01/15 00:03:32 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0115 00:03:50.344] 2020/01/15 00:03:50 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.51+e7f962ba86f4ce bootstrap-e2e: exit status 1
W0115 00:03:50.349] Traceback (most recent call last):
W0115 00:03:50.350]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0115 00:03:50.350]     main(parse_args())
W0115 00:03:50.350]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0115 00:03:50.350]     mode.start(runner_args)
W0115 00:03:50.350]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0115 00:03:50.350]     check_env(env, self.command, *args)
W0115 00:03:50.351]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0115 00:03:50.351]     subprocess.check_call(cmd, env=env)
W0115 00:03:50.351]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0115 00:03:50.351]     raise CalledProcessError(retcode, cmd)
W0115 00:03:50.352] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable1', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0115 00:03:50.360] Command failed
I0115 00:03:50.360] process 268 exited with code 1 after 2.9m
E0115 00:03:50.360] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1
I0115 00:03:50.360] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0115 00:03:50.893] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0115 00:03:50.957] process 1390 exited with code 0 after 0.0m
I0115 00:03:50.958] Call:  gcloud config get-value account
I0115 00:03:51.310] process 1403 exited with code 0 after 0.0m
I0115 00:03:51.311] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0115 00:03:51.311] Upload result and artifacts...
I0115 00:03:51.311] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1217235087150551041
I0115 00:03:51.312] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1217235087150551041/artifacts
W0115 00:03:52.669] CommandException: One or more URLs matched no objects.
E0115 00:03:53.081] Command failed
I0115 00:03:53.082] process 1416 exited with code 1 after 0.0m
W0115 00:03:53.082] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1217235087150551041/artifacts not exist yet
I0115 00:03:53.082] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1217235087150551041/artifacts
I0115 00:03:56.167] process 1561 exited with code 0 after 0.1m
I0115 00:03:56.168] Call:  git rev-parse HEAD
W0115 00:03:56.176] fatal: not a git repository (or any of the parent directories): .git
E0115 00:03:56.177] Command failed
I0115 00:03:56.177] process 2088 exited with code 128 after 0.0m
I0115 00:03:56.177] Call:  git rev-parse HEAD
I0115 00:03:56.187] process 2089 exited with code 0 after 0.0m
I0115 00:03:56.188] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json
I0115 00:03:58.247] process 2090 exited with code 0 after 0.0m
I0115 00:03:58.251] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json#1578960315485609'
... skipping 8 lines ...