This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-15 12:00
Elapsed3m29s
Revision
Buildergke-prow-default-pool-cf4891d4-r8nq
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/8d5343a5-cca3-4dde-8e81-9b9c14e0c746/targets/test'}}
pod900ced50-378e-11ea-8603-da2f7a5855b4
resultstorehttps://source.cloud.google.com/results/invocations/8d5343a5-cca3-4dde-8e81-9b9c14e0c746/targets/test
infra-commitff065cbb3
job-versionv1.16.5-beta.1.51+e7f962ba86f4ce
pod900ced50-378e-11ea-8603-da2f7a5855b4
revisionv1.16.5-beta.1.51+e7f962ba86f4ce

Test Failures


Up 52s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.51+e7f962ba86f4ce bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0115 12:00:55.751] process 48 exited with code 0 after 0.0m
I0115 12:00:55.752] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0115 12:00:55.752] Root: /workspace
I0115 12:00:55.752] cd to /workspace
I0115 12:00:55.752] Configure environment...
I0115 12:00:55.753] Call:  git show -s --format=format:%ct HEAD
W0115 12:00:55.761] fatal: not a git repository (or any of the parent directories): .git
I0115 12:00:55.761] process 61 exited with code 128 after 0.0m
W0115 12:00:55.761] Unable to print commit date for HEAD
I0115 12:00:55.762] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0115 12:00:56.425] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0115 12:00:56.786] process 62 exited with code 0 after 0.0m
I0115 12:00:56.786] Call:  gcloud config get-value account
... skipping 426 lines ...
W0115 12:03:57.023] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0115 12:03:57.023] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0115 12:03:57.025] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0115 12:03:57.026] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0115 12:03:57.026] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0115 12:03:57.027] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0115 12:03:57.174] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0115 12:03:57.279] 2020/01/15 12:03:57 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.51+e7f962ba86f4ce bootstrap-e2e' finished in 1.017744775s
W0115 12:03:59.251] 2020/01/15 12:03:59 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0115 12:04:07.996] 2020/01/15 12:04:07 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.51+e7f962ba86f4ce bootstrap-e2e: exit status 1
W0115 12:04:08.014] Traceback (most recent call last):
W0115 12:04:08.014]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0115 12:04:08.014]     main(parse_args())
W0115 12:04:08.014]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0115 12:04:08.015]     mode.start(runner_args)
W0115 12:04:08.015]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0115 12:04:08.015]     check_env(env, self.command, *args)
W0115 12:04:08.015]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0115 12:04:08.015]     subprocess.check_call(cmd, env=env)
W0115 12:04:08.015]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0115 12:04:08.015]     raise CalledProcessError(retcode, cmd)
W0115 12:04:08.016] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable1', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0115 12:04:08.042] Command failed
I0115 12:04:08.042] process 269 exited with code 1 after 3.2m
E0115 12:04:08.043] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1
I0115 12:04:08.043] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0115 12:04:09.102] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0115 12:04:09.193] process 1391 exited with code 0 after 0.0m
I0115 12:04:09.193] Call:  gcloud config get-value account
I0115 12:04:09.836] process 1404 exited with code 0 after 0.0m
I0115 12:04:09.837] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0115 12:04:09.837] Upload result and artifacts...
I0115 12:04:09.837] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1217416289098665984
I0115 12:04:09.838] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1217416289098665984/artifacts
W0115 12:04:11.719] CommandException: One or more URLs matched no objects.
E0115 12:04:12.007] Command failed
I0115 12:04:12.008] process 1417 exited with code 1 after 0.0m
W0115 12:04:12.008] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1217416289098665984/artifacts not exist yet
I0115 12:04:12.008] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1217416289098665984/artifacts
I0115 12:04:15.217] process 1562 exited with code 0 after 0.1m
I0115 12:04:15.217] Call:  git rev-parse HEAD
W0115 12:04:15.224] fatal: not a git repository (or any of the parent directories): .git
E0115 12:04:15.225] Command failed
I0115 12:04:15.225] process 2089 exited with code 128 after 0.0m
I0115 12:04:15.226] Call:  git rev-parse HEAD
I0115 12:04:15.241] process 2090 exited with code 0 after 0.0m
I0115 12:04:15.241] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json
I0115 12:04:17.602] process 2091 exited with code 0 after 0.0m
I0115 12:04:17.603] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json#1579046642096864'
... skipping 8 lines ...