This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-16 00:00
Elapsed3m45s
Revision
Buildergke-prow-default-pool-cf4891d4-s69b
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/750c1431-eb6d-4f29-8846-e0e2d2b1151a/targets/test'}}
pod2848dba0-37f3-11ea-8f3e-66e48c863062
resultstorehttps://source.cloud.google.com/results/invocations/750c1431-eb6d-4f29-8846-e0e2d2b1151a/targets/test
infra-commit70a5174aa
job-versionv1.16.5-beta.1.51+e7f962ba86f4ce
pod2848dba0-37f3-11ea-8f3e-66e48c863062
revisionv1.16.5-beta.1.51+e7f962ba86f4ce

Test Failures


Up 47s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.51+e7f962ba86f4ce bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0116 00:00:49.847] process 47 exited with code 0 after 0.0m
I0116 00:00:49.847] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0116 00:00:49.847] Root: /workspace
I0116 00:00:49.848] cd to /workspace
I0116 00:00:49.848] Configure environment...
I0116 00:00:49.848] Call:  git show -s --format=format:%ct HEAD
W0116 00:00:49.854] fatal: not a git repository (or any of the parent directories): .git
I0116 00:00:49.854] process 60 exited with code 128 after 0.0m
W0116 00:00:49.855] Unable to print commit date for HEAD
I0116 00:00:49.855] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0116 00:00:50.603] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0116 00:00:50.977] process 61 exited with code 0 after 0.0m
I0116 00:00:50.978] Call:  gcloud config get-value account
... skipping 426 lines ...
W0116 00:04:14.597] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0116 00:04:14.599] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0116 00:04:14.601] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0116 00:04:14.602] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0116 00:04:14.603] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0116 00:04:14.604] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0116 00:04:14.745] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0116 00:04:14.841] 2020/01/16 00:04:14 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.51+e7f962ba86f4ce bootstrap-e2e' finished in 1.634991802s
W0116 00:04:16.833] 2020/01/16 00:04:16 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0116 00:04:20.212] 2020/01/16 00:04:20 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.16.5-beta.1.51+e7f962ba86f4ce bootstrap-e2e: exit status 1
W0116 00:04:20.232] Traceback (most recent call last):
W0116 00:04:20.233]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0116 00:04:20.233]     main(parse_args())
W0116 00:04:20.233]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0116 00:04:20.233]     mode.start(runner_args)
W0116 00:04:20.234]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0116 00:04:20.234]     check_env(env, self.command, *args)
W0116 00:04:20.234]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0116 00:04:20.234]     subprocess.check_call(cmd, env=env)
W0116 00:04:20.234]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0116 00:04:20.234]     raise CalledProcessError(retcode, cmd)
W0116 00:04:20.235] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable1', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0116 00:04:20.244] Command failed
I0116 00:04:20.244] process 268 exited with code 1 after 3.4m
E0116 00:04:20.244] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1
I0116 00:04:20.245] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0116 00:04:21.105] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0116 00:04:21.208] process 1390 exited with code 0 after 0.0m
I0116 00:04:21.208] Call:  gcloud config get-value account
I0116 00:04:21.828] process 1403 exited with code 0 after 0.0m
I0116 00:04:21.828] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0116 00:04:21.828] Upload result and artifacts...
I0116 00:04:21.829] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1217597474387005445
I0116 00:04:21.829] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1217597474387005445/artifacts
W0116 00:04:23.570] CommandException: One or more URLs matched no objects.
E0116 00:04:23.916] Command failed
I0116 00:04:23.916] process 1416 exited with code 1 after 0.0m
W0116 00:04:23.916] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1217597474387005445/artifacts not exist yet
I0116 00:04:23.916] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1217597474387005445/artifacts
I0116 00:04:27.495] process 1561 exited with code 0 after 0.1m
I0116 00:04:27.496] Call:  git rev-parse HEAD
W0116 00:04:27.502] fatal: not a git repository (or any of the parent directories): .git
E0116 00:04:27.503] Command failed
I0116 00:04:27.503] process 2088 exited with code 128 after 0.0m
I0116 00:04:27.503] Call:  git rev-parse HEAD
I0116 00:04:27.514] process 2089 exited with code 0 after 0.0m
I0116 00:04:27.517] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json
I0116 00:04:29.553] process 2090 exited with code 0 after 0.0m
I0116 00:04:29.554] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json#1579089862694312'
... skipping 8 lines ...