This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-12-31 02:31
Elapsed3m14s
Revision
Buildergke-prow-ssd-pool-1a225945-4sp7
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/415e1f8c-5264-447b-a4fc-b65816f6afe5/targets/test'}}
pod7ed36554-2b75-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/415e1f8c-5264-447b-a4fc-b65816f6afe5/targets/test
infra-commitd986bdd8e
job-versionv1.18.0-alpha.1.244+26d491f413e4fe
pod7ed36554-2b75-11ea-a07b-c6eb1bf16817
revisionv1.18.0-alpha.1.244+26d491f413e4fe

Test Failures


Up 1m34s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.244+26d491f413e4fe bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1231 02:31:07.094] process 47 exited with code 0 after 0.0m
I1231 02:31:07.094] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1231 02:31:07.094] Root: /workspace
I1231 02:31:07.095] cd to /workspace
I1231 02:31:07.095] Configure environment...
I1231 02:31:07.095] Call:  git show -s --format=format:%ct HEAD
W1231 02:31:07.100] fatal: not a git repository (or any of the parent directories): .git
I1231 02:31:07.100] process 60 exited with code 128 after 0.0m
W1231 02:31:07.100] Unable to print commit date for HEAD
I1231 02:31:07.101] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1231 02:31:07.671] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1231 02:31:08.009] process 61 exited with code 0 after 0.0m
I1231 02:31:08.009] Call:  gcloud config get-value account
... skipping 422 lines ...
W1231 02:33:15.752] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1231 02:33:15.752] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W1231 02:33:15.753] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1231 02:33:15.753] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1231 02:33:15.754] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1231 02:33:15.754] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1231 02:34:04.272] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1231 02:34:04.318] 2019/12/31 02:34:04 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.244+26d491f413e4fe bootstrap-e2e' finished in 49.003057084s
W1231 02:34:05.890] 2019/12/31 02:34:05 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1231 02:34:12.964] 2019/12/31 02:34:12 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.244+26d491f413e4fe bootstrap-e2e: exit status 1
W1231 02:34:12.970] Traceback (most recent call last):
W1231 02:34:12.970]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1231 02:34:12.970]     main(parse_args())
W1231 02:34:12.971]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1231 02:34:12.971]     mode.start(runner_args)
W1231 02:34:12.971]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1231 02:34:12.971]     check_env(env, self.command, *args)
W1231 02:34:12.971]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1231 02:34:12.971]     subprocess.check_call(cmd, env=env)
W1231 02:34:12.972]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1231 02:34:12.972]     raise CalledProcessError(retcode, cmd)
W1231 02:34:12.972] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1231 02:34:12.979] Command failed
I1231 02:34:12.980] process 268 exited with code 1 after 3.1m
E1231 02:34:12.980] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100
I1231 02:34:12.980] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1231 02:34:13.514] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1231 02:34:13.565] process 1375 exited with code 0 after 0.0m
I1231 02:34:13.566] Call:  gcloud config get-value account
I1231 02:34:13.892] process 1388 exited with code 0 after 0.0m
I1231 02:34:13.893] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1231 02:34:13.894] Upload result and artifacts...
I1231 02:34:13.894] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1211837073951035393
I1231 02:34:13.895] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1211837073951035393/artifacts
W1231 02:34:14.811] CommandException: One or more URLs matched no objects.
E1231 02:34:14.932] Command failed
I1231 02:34:14.933] process 1401 exited with code 1 after 0.0m
W1231 02:34:14.933] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1211837073951035393/artifacts not exist yet
I1231 02:34:14.934] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1211837073951035393/artifacts
I1231 02:34:16.770] process 1546 exited with code 0 after 0.0m
I1231 02:34:16.770] Call:  git rev-parse HEAD
W1231 02:34:16.775] fatal: not a git repository (or any of the parent directories): .git
E1231 02:34:16.775] Command failed
I1231 02:34:16.776] process 2073 exited with code 128 after 0.0m
I1231 02:34:16.776] Call:  git rev-parse HEAD
I1231 02:34:16.781] process 2074 exited with code 0 after 0.0m
I1231 02:34:16.782] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json
I1231 02:34:17.809] process 2075 exited with code 0 after 0.0m
I1231 02:34:17.810] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json#1577716485410557'
... skipping 8 lines ...